Announcement

Collapse
No announcement yet.

Input lag

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Input lag

    Hello!
    I am struggling to get rid of input lag. I've tried everything I found. Tutorial from ut99.org was helpful, I downloaded patches and DX10 and new OpenGL renderer, set settings, and got a very smooth and fast picture with stable high FPS, but there is still mouse input lag, it looks like the game starts to react to mouse move after 1 or 2 frames. What sffects this input lag?
    In short, currently I use OpenGL v3.7, has SwapInterval=0 (this disables VSync, should remove input lag, yes?), DirectInput=True, bMaxMouseSmoothing=False. Ah, and also MarkC_Windows_10+8.x+7_MouseFix to turn off acceleration. Input lag is still there, especially noticeable if to compare to UT2004, where the game instantly reacts to mouse.
    Please help.

    Update: Even mouse cursor in the main menu is lagging.
    Last edited by blinkfrog; 11-26-2019, 05:12 AM.

    #2
    its time for a new motherboard, seems like.

    Comment


      #3
      Fixed it!
      In "Preferences" window (that is launched by 'preferences' command in console) there is the Display category. There is a parameter "SlowVideoBuffering", which was set to "true". Changed to "false", and input lag is gone!
      This is somewhat strange for me though, as, if I understand correctly, this "Display" category is controlled by "[WinDrv.WindowsClient]" section in config, and should no affect 3D-renderer. Still, it removed lag from both 2D-menu and 3D-renderer.

      Comment


        #4
        slow video buffering is for old cards like those 4mb vesa cards by cirrus logic, so you wouldn't have to go buy an s3virge card if you didn't want to. anyway, glad your problem is solved.

        Comment

        Working...
        X