No announcement yet.

Unreal Ed 3.0 selection issue with Windows 10

  • Filter
  • Time
  • Show
Clear All
new posts


    Try these settings
    UT2004 Movement Mutator


      Originally posted by Calypto View Post

      Try these settings
      didnt help. thanks anyway


        Did you try to increase CacheSizeMegs, i don't use W10 for now but i know this fix lags for me in W7 with GTX970.

        UT2004.ini :



          It doesn't work...

          Last night I also tried VirtualBox with no luck...
 | f | t


            Same thing happens to me, I updated my pc and bought win 10 last year but didn't launch UT2004 ued since then. Today I did and it does as described - any click on a surface or an actor causes ued to hang for several seconds. i7 7820x, 32gb ram, gtx 1070.
            It's def not an antialiasing bug when you can't select anything except the last item in texture browser. This was easier to deal with.
            ʕ ´ ل͜ ´ ʔ


              I have to say a thing f*** microsh*t windows 10 I hate how they are managing the updates and many countless issues in what I call the worst O.S. made to date, my brother with an update lost all their data (from the last big update past year) I wonder why the hell they dont do any testing before releasing. Now I read this wow, I came back to win 8.1 and win 7. F*** off Microsoft


                I think its the mouse interface driver in the editor. when I ran vmware with win7 -it had no select lag at first but the mouse was CRAZED. a common bug seemingly with virtual windows installs and 3d apps. it just spins and spins and wont zoom in and ouut right. when i hacked the files for the vm so that the mouse wasnt crazed anymore then the select lag returned. basically, if windows 10 takes control of the mouse yer screwed. wish someone would fix this. I am starting to get ut2k4 map reguests again


                  did you try first installing the vwmare driver update pack by activating this option in properties before running your o.s?


                    Originally posted by bigfootpi View Post
                    it just spins and spins and wont zoom in and ouut right
                    I don't remember exactly where but that can be fixed in the VMware options (Pro version), it's not even hidden...
           | f | t


                      I've reported this thread through Support Center, I hope they don't ban me...

             | f | t


                        Few devs involved with UT2004 still work at Epic so don't expect any official solutions.

                        Things to bare in mind
                        Did you install the full final DirectX9 distro from the MS site (this will add missing files and HW support for older software)

                        UEd 3 is only available as 32 bit so is stuck with the DX8 renderer (can you use OpenGL?)
                        There is a 32bit DX9 renderer in ut2004-winpatch3204.exe but is unfinished and buggy (good luck).

                        Your Windows security settings may have DEP (Data Execution Prevention) set to opt-out rather than opt-in.
                        This can cause problems in older 32 bit software.
                        MS EMET (Enhanced Mitigation Experience Toolkit) features are now integrated into Windows 10, so other security settings may be to blame.

                        Personally I feel our best option is to get a new renderer made like many UE1 games have.
                        They have brand new renderers for 2 reasons.
                        1) The Linux UT99 project and the source code for the renderers.
                        2) Smirftsch at OldUnreal has a licence to use the source for Unreal, and was a member of the group that made the UT99 v451 update.

                        If the Linux source for the UT2004 renderers are available, perhaps Smirftsch could build us a new renderer for DX9 or above, and newer OpenGL.
                        Has anyone tried DX9 renderers from another UE2 game, or even the old free version of UE2SDK

                        Check your INI file and make sure the settings for the renderer you are using have this line set

                        ..also has anyone tried PixoDrv ? I remember it as an alternative renderer but don't remember why it exists.
                        Last edited by Dr.Flay; 04-02-2019, 02:28 AM.
                        Who wants a UT99 FOOD FIGHT ?


                          I've already tried every thing listed in your post minus de DX9 from another game (that I don't think it's going to work)...

                          UnrealEd only works with DX8...
                 | f | t


                            Did you already tried enable DirectPlay ? :


                              You miss the point of installing the DX9 runtimes distro from Microsoft.
                              Newer versions of Windows do not have all the old files from DX9 and before, only for DX10 and up.
                              To play any DX version below 10 it will have to rely on software emulation.
                              Using the final DirectX 9 distro will install all the older files for DX 9 and below, giving you access to direct HW functions for older DX.
                              To use either the DX8 or 9 renderer UT will need for the OS to have full support.

                              The tip posted by GLoups_AA should help a lot with all the right files in place. Nice find.
                              Click image for larger version

Name:	Win10DirectPlay.png
Views:	284
Size:	19.7 KB
ID:	405183
                              Last edited by Dr.Flay; 04-04-2019, 12:15 AM.
                              Who wants a UT99 FOOD FIGHT ?


                                I have DX9 installed, Steam installs DX9 every single time every single game that uses it is installed...

                                I already had DirectPlay installed too...

                                I've reinstalled DX9 AGAIN, it didn't work..
                       | f | t