Announcement

Collapse
No announcement yet.

Unreal Ed 3.0 selection issue with Windows 10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Originally posted by GLoups_AA View Post
    It's possible to install drivers for CPU intel integrated graphics and force an application to use it via the Control Panel or directly in W10 (Amd and Nvidia), like the Intel HD Graphics 630 which would be amply sufficient for ut2004, to make a test and see if the issue is Nvdia or amd related.

    https://support.serato.com/hc/en-us/...ging-graphics-

    https://www.laptopmag.com/articles/i...ics-comparison

    Hi, I didnt expect my i5 3450 supporting IGP, I turned it on in bios, installed the driver, the portviews are fine, but cpu still cant handle 18 static meshes, (selection delay was gone, as expected from disabling dGPU).
    Ive set memory size from 128 (default) to 1024, still nothing, its like it isnt even there

    You cannot force an application to use it on desktops. Nvidia Optimus does that, but it isnt supported on desktops, only laptops.
    There are ways to enable it, i got blackscreen and a bsod yesterday trying to enable it on win10 desktop, so this didnt work well.
    I basically still have to disable entire dGPU to use CPU Graphics, in the nvidia control center the option to choose which G-Processor to use isnt there. (Also rightclick on the .exe has no option to run on a specific GPU)
    Ive researched and it is only laptops with Nvidia Optimus which gets that option in the control center.

    So yeah thats that, my biggest question is why is it having no input delay when its on CPU, and suddenly gets one on dGPU.
    I wish the Integrated Graphics would change anything performance wise, in the SDK it doesnt feel like any performance was gained when its run on the CPU while IGP drivers are installed.

    HUGE EDIT:

    The trick isnt installing integrated graphics for the cpu only.
    It was to connect same screen twice. Once in mainboard, and once in GPU.
    Now: Win+P and choose "Only Another Screen" (Last option); the monitor swaps to the Mainboard connection (Automatically using integrated graphics).
    I was not aware that the cpu graphics wont work if the screen isnt plugged in mainboard (but came to me eventually with some thinking).
    This works as a solution for me specifically since i was only looking for a way to keep mapping on same pc, without lag because of cpu.
    All it takes is 2 actions: Win+P, choose last option, when done mapping, Win+P, first option.
    Windows thinks this way that the mainboard connection is the second screen btw.
    I got some answers from TWI aswell, they wont support and help with anything regarding this old SDK, they need to adress it and recompile, i can understand that its gonna be very complicated due to time and adapting to newest drivers. (Since it sounds to one of the TWI guys that its indeed windows/gpu driver related, but nothing for sure).

    With that said, Ill keep checking in here if someone trying to find a better solution than the above.
    For tech savy's: (Get Process Monitor(ProcMon)) and if youre patient, youll figure out that its very likely Direct3D. What to do with this information? I have no idea
    Last edited by Coffeediction; 06-18-2019, 04:49 PM.

    Comment


      #62
      Windows 10 1909, problem still there...
      UnrealArgentina.com | f | t

      Comment


        #63
        In the event that despite everything you're getting issues, download and run the Windows Update Troubleshooter, at that point reboot and attempt to refresh once more. In the event that the issues remain, you may need to stall out in. To begin with, watch that System Restore is designed (see beneath, number 7) and make a reestablish point.

        If People Want To Download GBWhatsApp 2019

        Comment


          #64
          This problem is directly related to D3DDrv.dll (all games..UE1, UE2). On SoftDrv.dll or OpenGLDrv.dll it's okay. Which is mainly a problem for Unreal editor 3.0 for UE2. I have more computers.
          Does not work (lag):
          - Win 7, 64-bit, Radeon RX550
          - Win 10 Nvidia 740
          Works:
          Win 8.1 Radeon AMD FirePro M6100 FireGL V
          Win 8.1 Radeon 5670
          Tested on games with the same settings....

          Does that mean there will be a problem somewhere in DirectX in windows? I tried to install 8.1 differently, turn on Direct play and so on, but still nothing ...
          I'll test ... and compare why it's running on some computers ...
          Last edited by AkyraDec; 12-20-2019, 07:27 AM.

          Comment


            #65
            It worked for me on Win 7 x64 and an ATI 5870...
            UnrealArgentina.com | f | t

            Comment


              #66
              use legacy drivers.

              Anyone who walks around saying - Update your drivers, should not be listened to.
              New GPU drivers do not have the stuff you need to run these old techs. It has been well documented on almost every unreal engine based game/ NVIDIA forums probably the other manufactures sites too()

              - I can run every version of Unreal/ Uned ever made with no issues, and on every version of Windows - no issues. I use a GTX 970- have no money and old stuff, i guess this has better compatibility. Everyone with new kit has issues. PhysX (although unrealted to your issue) is a good example. It simply does not function as it used to so for optimum performance and compatibility Legacy PhysX is required for Physx on old games

              Many manufactures have fixes for this stuff (leagacy support an enhancements built into new software) - get you google-fu onĀ¬!.
              - D3D windower maybe?
              Last edited by TKBS; 12-30-2019, 02:37 PM.
              Internet BlackOut in <2 weeks,last chance to request 4 years of Unreal Development(something from every Unreal Engine 50+ maps, chars, weapons, mods, mutators and more).

              Comment


                #67
                bumping this. Has anyone solved this or figured out a way to make Unreal Editor 3 (UT2004 editor etc) work in Windows 10?

                I can confirm if I dual boot the same machine into Windows 7 there is no problem with the viewports. In Windows 10 the viewports freeze for several seconds when trying to make a selection. It's totally unusable.

                Would love if someone could help us track down what's going on. I also noticed that GPU resources in task manager go very very high when the editor freezes for those seconds.

                Please help.

                Comment


                  #68
                  it's really help me a lot...

                  Comment


                    #69
                    Originally posted by GLoups_AA View Post
                    It's possible to install drivers for CPU intel integrated graphics and force an application to use it via the Control Panel or directly in W10 (Amd and Nvidia), like the Intel HD Graphics 630 which would be amply sufficient for ut2004, to make a test and see if the issue is Nvdia or amd related.
                    I have another computer with an AMD A8-7600 with an integrated Radeon R7 and a R9 200 Series GPU and, in fact, when using the APU, UnrealEd works correctly...

                    I don't have that computer in my house though so...
                    UnrealArgentina.com | f | t

                    Comment


                      #70
                      Windows 10 version 1909. facing the same issue.

                      Comment


                        #71
                        I have bad news. This problem is only driver problem. I have tried the same DX files in the Windows folder, same ini files, but the shared graphics of the NVidia 6100 cool, the RX550 doesn't work cool. I was just trying to replace the main graphics with: NVidia 8800GTS not working, Radeon 5670 cool.
                        I didn't change Directx, everything under Windows 10.
                        Unfortunately, the slowdown also occurs on Win7 and RX550.
                        Unfortunately, I think it's a driver error for both Radeon and Nvidia for some types, especially the new chips.

                        Only UT2004 Version: 3204 has D3D9Drv.dll.

                        Comment


                          #72
                          Originally posted by Party Boy View Post
                          I have another computer with an AMD A8-7600 with an integrated Radeon R7 and a R9 200 Series GPU and, in fact, when using the APU, UnrealEd works correctly...

                          I don't have that computer in my house though so...
                          Look, I've found that with just disabling the GPU from the Device Manager the editor works, I know it's not ideal but such is life...



                          It baffles me that it took me so many years to realize this...
                          Last edited by Party Boy; 06-06-2020, 12:28 PM.
                          UnrealArgentina.com | f | t

                          Comment


                            #73
                            Originally posted by Party Boy View Post

                            Look, I've found that with just disabling the GPU from the Device Manager the editor works, I know it's not ideal but such is life...



                            It baffles me that it took me so many years to realize this...
                            I just joined to say that it worked like a charm for me! Thanks for the help!

                            Comment

                            Working...
                            X