No announcement yet.

3D Sound in UT2004

  • Filter
  • Time
  • Show
Clear All
new posts

  • 3D Sound in UT2004


    Does anyone know how you can get UT2004 to use proper 3D sound? I currently have three Unreal games installed on my computer: Unreal Gold, UT, and UT2004. I don't have a sound card that does hardware 3D (does ANYBODY have such a card in a modern system?), but I find it hard to believe that without such a card, UT2004 can't do any better than the default.

    For Unreal, I installed the Oldunreal final patch and there is great positional 3D audio with environmental effects with the FMOD 3D Audio driver. UT, too, has great sound after applying the OpenAL driver.

    But UT2004 sounds like ****, even though it uses OpenAL by default. I've never heard a single ECHO in this game.

    Is there a way to change this?

    Thank you in advance!

  • #2
    Go to settings and set Audio mode to HW 3d audio + EAX and uncheck Use system driver. This works at least on my computer.

    Note that the amount of echo / reverb is map specific. This is because the map designer has to, for each area in the map, define how much echo there is. So if you don't hear any that's because the designer didn't bother to add it.

    Things like occlusion (eg. muffled sound behind walls) should still work everywhere.


    • #3
      Thank you very much! Great advice!


      • #4
        You need to have some Creative card and patch your ut2004 folder with the sbxf_utpatch_us_3369 for restore the awesomes 3d/eax sounds, just bought sound blaster X-fi Go! Pro for 25 euros from site like amaz** as an usb 2.0 card, it work very well, you must install the driver from the first link and every thing's working fine, i use w7 64 but it must be ok for all system because there's a driver for w8.1,w10 as well.
        Last edited by Akenatøn; 03-20-2017, 11:19 AM.


        • #5
          Thanks for the tip!

          In the meantime I realized that UT2004 works with OpenAl Soft. It sounds great, especially if compared to the default.