Announcement

Collapse
No announcement yet.

Ran out of Virtual Memory

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Ran out of Virtual Memory

    Hello all,

    So I came back to play one of my all time favorite games, UT2004 (installed from disks). It used to work fine, but now is having problems.


    I have two issues:

    The first is the most important:

    1. I keep getting a Ran out of Virtual Memory error when I try to choose my team in single player mode. Kind of crazy considering my i5, 16 GB of ram, 970GTX, etc.

    I tried changing the UT2004 config file CacheSizeMegs to 256, 4096, all sorts of numbers. There are two CacheSizeMegs, and I did change them both each time.

    So basically, I can't even choose my team.


    2. My other issue is screen tearing. I've tried vsync, adaptive vsync, etc. I also changed some setting a while back to limit all games to 59 fps since my monitor is 60 Hz.


    I understand there is supposed to be a log file in the System folder, but I don't see one.

    If anyone can help I'd love to go back to playing this game.


    Error:
    UT2004 Build UT2004_Build_[2004-03-03_02.42]

    OS: Windows NT 6.1 (Build: 7601)
    CPU: GenuineIntel PentiumPro-class processor @ 3500 MHz with 4095MB RAM
    Video: NVIDIA GeForce GTX 970 (9077)

    Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.

    History: FMallocWindows::Malloc <- FMallocWindows::Realloc <- 32EC0000 361321584 FArray <- FArray::Realloc <- 180660792*2 <- UObject::execDelegateFunction <- (GUICharacterListTeam Package.GUICharacterListTeam @ Function XInterface.GUICircularList.PgUp : 0084) <- UObject::ProcessEvent <- (UT2K4SPTab_TeamManagement Package.UT2K4SPTab_TeamManagement, Function GUI2K4.UT2K4SPTab_TeamManagement.onFreeAgentScroll) <- UObject::ProcessDelegate <- UGUIComponent::MousePressed <- (GUIButton Package.GUIButton) <- UGUIController::MousePressed <- UGUIController::NativeKeyEvent::LeftMouseClick <- UGUIController::NativeKeyEvent <- UInteractionMaster::MasterProcessKeyEvent <- UEngine::InputEvent <- UWindowsViewport::CauseInputEvent <- UWindowsViewport::UpdateInput <- UViewport::ReadInput <- APlayerController::Tick <- TickAllActors <- ULevel::Tick <- (NetMode=0) <- TickLevel <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop
    Last edited by Blueshifte; 10-12-2018, 12:23 PM. Reason: Added error

    #2
    1- How many maps do you have in your UT2004/Maps?, i know you can have this kind of issue in instant-action if you have too many maps in this folder, if so just move them temporaly to another one, this can happen when you have several hundred maps.


    2- If you have limited fps or vsync in user.ini you should try to go back and let the nvidia driver manage it through adaptive, of course check if you have the right monitor driver (analog, Hdmi .) for this to work correctly, lastly unless you have a new monitor with Gsync or so, Vsync can bring input Lags.

    The log file is *:\UT2004\System\UT2004.log

    CacheSizeMegs do nothing, default value is fine.
    Last edited by GLoups_AA; 10-12-2018, 04:00 PM.

    Comment


      #3
      Control panel > System and security > System > Advanced system settings > Performance > Settings > Advanced > Virtual memory > Change

      Check: "Automatically manage paging file size for all drives"

      Also check if you have free space in your C: drive...
      UnrealArgentina.com | f | t

      Comment


        #4
        GLoups_AA

        1. 198 maps. I'm in Single Player mode though not instant action.

        2. I did that as well. I tried on, off, vsync, and adaptive. It's on adaptive now. None of these settings made a difference. I use NVIDIA's drivers - it's connected via HDMI. There was a setting I found somewhere a while back where I just limited fps to 59 or 60 so vsync wouldn't be an issue. It's currently set to Adaptive.

        There is no log in that location (see attached photo).


        Party Boy

        That box is already checked. I did find a setting where it didn't have virtual memory assigned on the old drive. I tried manually assigning 16-24 GB and system managed. Neither changed the crash point unfortunately.

        I have over 150 GB free on the older drive I'm running UT2004 on and over 150GB free on my SSD (C).


        Here's a short video of what's happening. It happens at the exact same spot give or take a few seconds:
        https://drive.google.com/file/d/1czC...w?usp=drivesdk
        Attached Files

        Comment


          #5
          I'd just try reinstalling.

          Comment

          Working...
          X