No announcement yet.

UT2k4 crashes on Win10 when trying to run it in fullscreen and with 16 bit

  • Filter
  • Time
  • Show
Clear All
new posts

    UT2k4 crashes on Win10 when trying to run it in fullscreen and with 16 bit

    Hello @ all,

    I am trying to run UT2k4 (PL 3369) on my laptop (Lifebook E-Series with Intel UHD Graphics 620 onboard) with Windows 10 Build 1909 installed.
    I went curious about several tweaks because I did not get the game on a constant frame rate. I also tried to run it in 16 bit mode to get some more frames, but when I change it in the video game settings ingame, it instantly crashes.
    I only get the game started again when switching back to 32bit or starting the game in window mode. So everything depends on the following parameters in ut2004.ini:



    So as you can see I'm running the game with OpenGL because with D3D, it gets even worse regarding the frames.

    I look forward to get any kind of help.

    With kind regards,

    P.S.: UT99 runs fine ;-)

    I solved it by myself, but I'm not quite sure how.
    I just started the game with StartupFullscreen = true and Use16bit=True in compatibility mode for Windows XP which worked. I rewinded the settings and tried again and from now on it works for me.

    I also fetched more frames by simply connecting my monitor directly to the laptop instead of using the docking-station.
    The summarization of all these tasks helped me to play the game with constant rate around 80-90 which is more stable than I expected to be.

    If somebody has got the same experience I also recommend the following tutorials:

    I ended up with an .ini configuration which lays the focus more on stable frame-rates than on high performance.


      Also a good help is:
      Where I never had a problem until now was to put all the files on a place where you have full rights.. so like a seperate physical drive, or direct C:\
      CEONSS: ; ut2004:// ;