Announcement

Collapse
No announcement yet.

Windows 10 not compatible with 2K4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Windows 10 not compatible with 2K4

    I just installed the windows 10 technical preview last night. Went on 2k4 and it was all properly functioning in windowed view. As I dragged the window bar to the top for full screen a crash kept occurring.

    UT2004 Build UT2004_Build_[2005-11-23_16.22]


    OS: Windows NT 6.2 (Build: 9200)
    CPU: GenuineIntel PentiumPro-class processor @ 1862 MHz with 2047MB RAM
    Video: AMD Radeon HD 6800 Series (1393)


    LockRect failed: D3DERR_DEVICELOST


    History: UD3DRenderDevice::ReadPixels <- UD3DRenderDevice::Present <- UGameEngine:raw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

    Anyone know how to fix? I tried compatibility mode and it wasn't working. I am upgrading from Windows 7 to Windows 10 build 10162
    Last edited by squígz; 07-12-2015, 06:39 AM.

    #2
    Originally posted by ShokD View Post
    I just installed the windows 10 technical preview last night. Went on 2k4 and it was all properly functioning in windowed view. As I dragged the window bar to the top for full screen a crash kept occurring.

    UT2004 Build UT2004_Build_[2005-11-23_16.22]


    OS: Windows NT 6.2 (Build: 9200)
    CPU: GenuineIntel PentiumPro-class processor @ 1862 MHz with 2047MB RAM
    Video: AMD Radeon HD 6800 Series (1393)


    LockRect failed: D3DERR_DEVICELOST


    History: UD3DRenderDevice::ReadPixels <- UD3DRenderDevice::Present <- UGameEngine:raw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

    Anyone know how to fix? I tried compatibility mode and it wasn't working. I am upgrading from Windows 7 to Windows 10 build 10162
    Maybe dragging the window to the top isn't the right way to get the game fullscreen. Try selecting 'fullscreen' in the menu. I know this is the Windows method of making something full screen - a window - but I think the application needs to specify that, not the OS. Just a guess.

    People have had trouble with this problem in other games and some solved it by disconnecting any USB devices that aren't needed or using onboard sound. Not sure but hope it helps.
    My Unreal game collection. Unreal series screenshots (2560x1440)

    Comment


      #3
      Yes I tried this method and the same crash is occurring

      EDIT: I changed the 3d render device to Open Gl and it works but lots of lags, however it does not run on direct x 9??
      Last edited by squígz; 07-12-2015, 08:18 AM.

      Comment


        #4
        2047MB RAM? ^^ on your cpu or you mean actual RAM?
        - that's not enough RAM for windows 10, but if you are referring to internal CPU memory then nm.


        So there are many version of UT2004, you should post/ start with what version you have:

        • Steam?
        • Gog?
        • UT2004 Anthology?
        • UT2004 Standalone?
        • UT2004 ECE?


        Q.
        Is this a clean install, patched version, or copy/paste/ migrated from another install?

        Similar issue:
        In 2007 an almost identical problem was posted here: https://forums.epicgames.com/threads...n-Equals-Crash

        Windows 10 info:
        • You cannot get much support on a OS that is not officially released
        • you could wait until August and then message GoG to see if they have any info on Windows10 and ut2k4, because (sadly) you probably won't get support anywhere else.


        Have you tried?
        9/10 modifying or deleting your config will help. If you Change OS and your using a copy/paste method of ut2k4 then the info you had on "Firstrun" will be no longer applicable. Setting "bFirstRun=True may help"

        p.s.
        Anthology version and standalone work for me on Windows 10, i am currently using the latest nvidia drivers (batman hotfix)
        Last edited by TKBS; 07-12-2015, 08:31 AM.
        Internet BlackOut in <2 weeks,last chance to request 4 years of Unreal Development(something from every Unreal Engine 50+ maps, chars, weapons, mods, mutators and more).

        Comment


          #5
          Ut2k4 is dx8 not 9, there is dx9 64 bit patch of you wanna try it. Best way to run the game would be to delete you user and ut2004 ini files and try to start the game again.

          Comment


            #6
            Originally posted by bass3 View Post
            Ut2k4 is dx8 not 9, there is dx9 64 bit patch of you wanna try it. Best way to run the game would be to delete you user and ut2004 ini files and try to start the game again.
            Thanks it worked

            Comment


              #7
              Originally posted by ShokD View Post
              Thanks it worked
              What files, did you delete?
              I tried to delete the ut2004.ini but i still have the same problem...

              Comment


                #8
                It's quite easy I found a solution in another forum:

                Just change the settings:

                [Engine.Engine]
                RenderDevice=D3DDrv.D3DRenderDevice
                ;RenderDevice=Engine.NullRenderDevice
                ;RenderDevice=OpenGLDrv.OpenGLRenderDevice

                to

                [Engine.Engine]
                ;RenderDevice=D3DDrv.D3DRenderDevice
                ;RenderDevice=Engine.NullRenderDevice
                RenderDevice=OpenGLDrv.OpenGLRenderDevice

                Comment


                  #9
                  Sweet this worked for me, Thanx!

                  Comment


                    #10
                    There is also a D3D9 render device isn't there? I remember there being an experimental DLL. OpenGL iirc wouldn't render stuff like the license plates correctly, though I suppose none of that breaks the game.

                    UT4 modding discussion: irc.globalgamers.net #UTModders
                    Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

                    Comment


                      #11
                      Actuallly, you don't even need the 64-bit binary, changing the renderer or doing that mouselag trick at all. OpenGL has some quirks with reflections and the 64-bit binary also has some weird issues regarding sound pitch and glow maps on textures. For me, those things kinda disrupt the experience you were used to.

                      To make thr 32-bit version work, you only need two zip files from this website: http://enbdev.com/download.htm

                      1. Scroll down until you see the category "Converter". Download the DX8 to DX9 converter: http://enbdev.com/enbconvertor_dx8_dx9_v0036.zip, unzip and put the files in your System folder.
                      2. Scroll down and look for "Graphic modifications". Download something, for example this one: http://enbdev.com/mod_deusex_v0075e.htm, unzip and put the files in System.
                      3. Run UT2004 and see if it works. Each time upon starting the game, you will see ENBSeries versions written at the top-left corner of your screen. Don't lose your s* yet, it will go away after a short while.

                      I tested it on a Radeon HD 5450 and a GTX980Ti, both work. Switching resolution, tabbing out and setting graphics details won't crash. I am running Win 10 64.

                      Comment


                        #12
                        Sorry to revive an old thread but I have an easy fix for this problem FOR ANYONE WHO WANTS TO PLAY UT 2003 and 2004 without having to use the OpenGL method and stick with how you always been playing it.

                        open the .ini file in the system folder and replace the True with False on Reducemouselag=, This will bypass all the errors you see pop up and allow the game to run perfectly on any version of windows 10. no need to openGL force this game when it was mouselag that caused this whole problem haha

                        Comment


                          #13
                          TY!

                          Originally posted by DreamedArtist View Post
                          Sorry to revive an old thread but...
                          Kind sir, please, do NOT apologize. Your thing totally worked (which is great 'cause i didn't understand any of the things others were suggesting). Thank you!

                          Comment


                            #14
                            Originally posted by DreamedArtist View Post
                            Sorry to revive an old thread but I have an easy fix for this problem FOR ANYONE WHO WANTS TO PLAY UT 2003 and 2004 without having to use the OpenGL method and stick with how you always been playing it.

                            open the .ini file in the system folder and replace the True with False on Reducemouselag=, This will bypass all the errors you see pop up and allow the game to run perfectly on any version of windows 10. no need to openGL force this game when it was mouselag that caused this whole problem haha
                            THIS! This works!

                            Comment


                              #15
                              Originally posted by DreamedArtist View Post
                              Sorry to revive an old thread but I have an easy fix for this problem FOR ANYONE WHO WANTS TO PLAY UT 2003 and 2004 without having to use the OpenGL method and stick with how you always been playing it.

                              open the .ini file in the system folder and replace the True with False on Reducemouselag=, This will bypass all the errors you see pop up and allow the game to run perfectly on any version of windows 10. no need to openGL force this game when it was mouselag that caused this whole problem haha
                              Thanks! It really helped! Still can't believe that all this problems were because of mouselag

                              Comment

                              Working...
                              X