Announcement

Collapse
No announcement yet.

Windows 10 not compatible with 2K4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Mouse lag will solve problems but it will bring you also alot of issues, I have read about it abit and if you put it to false it will bring fps drops and mouse lag caused by connection between you and server.

    If you really want to fix the game without any issues install sweetfx or reshade framework, you get improved graphics wirh it and game runs better if you install 64 bit patch.

    Comment


      #17
      I'm not running my PC on win 10, but there was a good discussion about it on our forum.
      So when anybody has a problem what couldn't be solved until now, maybe a look on the topic will help.
      http://ceonss.net/viewtopic.php?f=2&t=710
      https://s20.postimg.org/jthlzuavx/M5400x100.png
      CEONSS: http://www.ceonss.net ; ut2004://176.57.143.200:7777 ; https://discord.gg/X4V8THM

      Comment


        #18
        Originally posted by DreamedArtist View Post
        Sorry to revive an old thread but I have an easy fix for this problem FOR ANYONE WHO WANTS TO PLAY UT 2003 and 2004 without having to use the OpenGL method and stick with how you always been playing it.
        Don't you dare apologise. This worked an absolute treat!!!!!! Thank you

        Comment


          #19
          Virtual Box, VM or other band-aid solutions aside, it seems that having a separate system to run older games may well turn out to be the simplest idea.
          My Unreal game collection. Unreal series screenshots (2560x1440)

          Comment


            #20
            DreamedArtist, you are a god. Thanks m8!

            Comment


              #21
              I upgraded from Windows 8.1 to Windows 10 yesterday, but the game still thinks I have Windows 8. After trying the fixes mentioned above, I am getting this error:
              UT2004 Build UT2004_Build_[2005-11-23_16.22]

              OS: Windows XP 5.1 (Build: 2600)
              CPU: GenuineIntel PentiumPro-class processor @ 3599 MHz with 1023MB RAM
              Video: No Video

              Can't find file for package 'D3D9Drv'

              History: UObject::SafeLoadError <- UObject::StaticLoadClass <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free
              I have a GeForce GTX 780, and a lot more than 1023Mb RAM.

              Comment


                #22
                [MENTION=306318]Empyre65[/MENTION] You have set your config to use D3D9, but you don't have the necessary files for it. You should set your config to use OpenGL or D3D as explained in the beginning of this thread: https://www.epicgames.com/unrealtour...d-useful-links

                In your case if you want to stick with D3D, you also need to change RenderDevice option to look like this:

                Code:
                RenderDevice=D3DDrv.D3DRenderDevice
                ;RenderDevice=D3D9Drv.D3D9RenderDevice
                ;RenderDevice=Engine.NullRenderDevice
                ;RenderDevice=OpenGLDrv.OpenGLRenderDevice
                ;RenderDevice=PixoDrv.PixoRenderDevice
                Last edited by _Lynx; 07-08-2016, 02:12 PM.
                "Yeah. _Lynx can fire the lightning gun, have the lightning bolt turn a 90 degree corner, stop and ask the closest teammate for directions, confuse the directions and get lost, realize it went the wrong way, make a U-Turn, and get a headshot on the intended target."
                - RenegadeRetard

                Comment


                  #23
                  Adding the D3DDrv line (which wasn't there before, even commented out) and commenting out the D3D9Drv line makes a different error window appear that says:
                  The procedure entry point Direct3DCreate9Ex could not be located in the dynamic link library C:\WINDOWS\system32\nvscap.dll

                  Comment


                    #24
                    That's odd. After clocking OK several times, The game launched in a small window (640x480). I was able to make it full screen 640x480, but when I tried a higher resolution (1920x1080 was not available), the game froze.
                    I am considering uninstalling and reinstalling the game, and then applying the fixes mentioned above.

                    Comment


                      #25
                      All the Unreal series games work fine on Windows 10.

                      For UT2003 and 4, you have to change the mouselag setting (as explained in _Lynx's link) in the .ini for D3D, but that's it. I'm using the 64 bit .exe as well for 2K4, but 2K3 is just totally vanilla and working great.

                      Unreal, NaPali, UT, Unreal 2, 2K3, 2K4, UT3 and the new UT all run flawlessly with Win10.
                      My Unreal game collection. Unreal series screenshots (2560x1440)

                      Comment


                        #26
                        Success! As somebody somewhere (maybe here) suggested, I deleted (renamed) the ut2004.ini file, and it works. I do have to click OK on several error messages every time I launch the game, and it launches in windowed mode, but then I can make it full screen and click some more error messages before it works, every time.

                        Comment


                          #27
                          I had the same issue. It's the ut2004.ini (or the settings/input menu) option to reduce mouse lag that seems to instantly cause CTDs in Win10 when on.

                          Basically, set "ReduceMouseLag=False", you can edit the ini with a simple text editor.

                          Comment


                            #28
                            Originally posted by Temeter View Post
                            I had the same issue. It's the ut2004.ini (or the settings/input menu) option to reduce mouse lag that seems to instantly cause CTDs in Win10 when on.

                            Basically, set "ReduceMouseLag=False", you can edit the ini with a simple text editor.

                            I do not see an "ini" file in the system folder. Help.
                            I installed the 3369 patch, then the 3339 one after it didn't work with the 3369 patch

                            *UPDATE*- figured it out, changed ReduceMouseLag to "False" in about 4 spots and the game seems to be working perfectly. Thank you!
                            Last edited by shane1v; 07-18-2016, 04:40 PM.

                            Comment


                              #29
                              Originally posted by Carbon View Post
                              All the Unreal series games work fine on Windows 10.

                              For UT2003 and 4, you have to change the mouselag setting (as explained in _Lynx's link) in the .ini for D3D, but that's it. I'm using the 64 bit .exe as well for 2K4, but 2K3 is just totally vanilla and working great.

                              Unreal, NaPali, UT, Unreal 2, 2K3, 2K4, UT3 and the new UT all run flawlessly with Win10.
                              Having the DX8 games forced into borderless windowed mode instead of true fullscreen is not "running flawlessly".

                              Comment


                                #30
                                Originally posted by Oubadah View Post
                                Having the DX8 games forced into borderless windowed mode instead of true fullscreen is not "running flawlessly".
                                You can get the game fully functioning without ANY issues, including depreciated functions from earlier DX versions when you make use of a DX8 to 9 converter. More about this below.

                                I see people in this forum still sharing the 'solution' to change the .ini value mouselag=true to false. I reported that 'solution' during dx12 fast ring release over a year ago on the steam forums. Meanwhile others on that forum found out it is being forced in borderless full screen and I took note, confirmed by others and my dropped stats, that the hitregistration is quite off for online play. Searching for a solution I stumbled upon a dx8 to 9 converter that is made for a large amount of older games, including gta 3, which solves all issues but takes a bit of time to set it up correctly for UT.

                                Get a full screen render (yes even game capture in OBS grabs it up), no alt tab or random crashing as with the 64bit version, no AL-Audio used or audio issues for hitzounds as with OpenGL, the mouse options and color and gamma settings as defined in your preferenced settings which are depreciated functions since windows 10 dx12 will be functioning again and no hitreg issues for playing in windowed modus. In other words you can get just your experience like in Windows XP or 7.

                                Backup your user.ini and ut2004.ini if you have made fancy settings. Follow the instructions for the fifth option OR try it out fastly by checking the quick fix at the top (drag and drop my settings into the ut folder).
                                http://steamcommunity.com/sharedfile.../?id=594282124

                                Comment

                                Working...
                                X