Announcement

Collapse
No announcement yet.

Windows Server | Showing Red in Join hub / servers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Windows Server | Showing Red in Join hub / servers

    Hi all,

    I've opted to run a dedicated server on a dedicated IP.

    I installed Windows 10, and followed the instructionsI found on YouTube to setup a UT4 Windows Server.

    I've got a mikrotik, I opened all the ports UDP 7777 and 7778, 15000 and a few others I detected the software is using.

    When I go to the server list in the hub / server section, it doesn't show my running server, unless I tick the show all empty hub/servers. Then it comes up in red (with no ping result) and I can connect and play on my server...

    How do I fix that it shows normally with a ping result...

    I have checked:

    1. Windows machine does not have any firewall on (all set off) and no av...
    2. The mikrotik has the correct port allowed and forwarding to the correct machine and allows ICMP traffic for ping (I can ping it from the command prompt).
    3. I can connect and play on the server from another location on the internet - and it works...

    I start the server with the following command:

    start UE4Server-Win64-Shipping.exe UnrealTournament DM-Lea?Game=DM?MaxPlayers=16?ShouldAdvertise=True -multihome=10.0.0.95 -port=7777 -log

    am I doing something wrong, or have I missed a setting or config somewhere that will get my server listed with a ping result.

    thanks

    Rob


    #2
    Welcome DJRob, you want to check that your server Engine.ini contains the following;
    Code:
    [/Script/OnlineSubsystemUtils.OnlineBeaconHost]
    ListenPort=7778
    This may serve as a better foundation with regard to instructions as well. You should be able to startup without the ShouldAdvertise=True. GL!

    Comment

    Working...
    X