Announcement

Collapse
No announcement yet.

Server not showing up on in-game Server List

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Server not showing up on in-game Server List

    Hi all,

    I followed this guide to setup a server on Linux:
    https://wiki.unrealengine.com/Server...%29#UT_Servers

    I can join the server by choosing find game by IP address and putting fun.unrealaussies.com as the IP. It successfully joins. Also I can use the console and do "open fun.unrealaussies.com" and it's fine.

    But it doesn't show up in the server list. Is there something I'm missing?

    #2
    If the server is on the same LAN as your game client (server is on your home connection) the only way you can connect to it is by IP (internal LAN IP). It won't show up in the server list for you, but it'll work fine for others (using your external IP).

    If the server isn't running on your home connection, then something else must be wrong.

    Comment


      #3
      have you forwarded port 7787 also?

      plz post your serverĀ“s unrealtounament.log

      Comment


        #4
        Originally posted by MoxNix View Post
        If the server is on the same LAN as your game client (server is on your home connection) the only way you can connect to it is by IP (internal LAN IP). It won't show up in the server list for you, but it'll work fine for others (using your external IP).

        If the server isn't running on your home connection, then something else must be wrong.
        It's not on my home connection, it's a dedicated server where no ports are firewalled. You can connect to it yourself just use the address I posted "fun.unrealaussies.com"

        UnrealTournament.log:

        Code:
        Log file open, 06/07/15 18:57:10LogInit:Display: Running engine for game: UnrealTournament
        LogInit:Display: Project file not found: /home/ogp/OGP_User_Files/ut4/LinuxServer/UnrealTournament/UnrealTournament.uproject
        LogInit:Display: 	Attempting to find via project info helper.
        LogUProjectInfo: Found projects:
        LogInit: Version: 4.7.0-2566237+++depot+UE4-UT-Releases
        LogInit: API Version: 2566237
        LogInit: Compiled (64-bit): May 27 2015 03:02:56
        LogInit: Compiled with Clang: 3.5.0 (tags/RELEASE_350/final)
        LogInit: Build Configuration: Test
        LogInit: Branch Name: ++depot+UE4-UT-Releases
        LogInit: Command line:  DM-DeckTest?Game=Duel?MustBeReady=1
        LogInit: Base directory: /home/ogp/OGP_User_Files/ut4/LinuxServer/Engine/Binaries/Linux/
        LogInit: Rocket: 0
        [2015.06.07-14.57.10:399][  0]LogTaskGraph: Started task graph with 2 named threads and 3 total threads.
        [2015.06.07-14.57.10:672][  0]LogInit: Using libcurl 7.38.0
        [2015.06.07-14.57.10:672][  0]LogInit:  - built for x86_64-unknown-linux-gnu
        [2015.06.07-14.57.10:672][  0]LogInit:  - supports SSL with OpenSSL/1.0.1i
        [2015.06.07-14.57.10:672][  0]LogInit:  - supports HTTP deflate (compression) using libz 1.2.5
        [2015.06.07-14.57.10:672][  0]LogInit:  - other features:
        [2015.06.07-14.57.10:672][  0]LogInit:      CURL_VERSION_SSL
        [2015.06.07-14.57.10:672][  0]LogInit:      CURL_VERSION_LIBZ
        [2015.06.07-14.57.10:672][  0]LogInit:      CURL_VERSION_IPV6
        [2015.06.07-14.57.10:672][  0]LogInit:      CURL_VERSION_ASYNCHDNS
        [2015.06.07-14.57.10:672][  0]LogInit:      CURL_VERSION_LARGEFILE
        [2015.06.07-14.57.10:672][  0]LogInit:      CURL_VERSION_TLSAUTH_SRP
        [2015.06.07-14.57.10:672][  0]LogInit:  Libcurl: checking if '/etc/pki/tls/certs/ca-bundle.crt' exists
        [2015.06.07-14.57.10:673][  0]LogInit:  Libcurl: checking if '/etc/ssl/certs/ca-certificates.crt' exists
        [2015.06.07-14.57.10:701][  0]LogInit:  CurlRequestOptions (configurable via config and command line):
        [2015.06.07-14.57.10:701][  0]LogInit:  - bVerifyPeer = true  - Libcurl will verify peer certificate
        [2015.06.07-14.57.10:701][  0]LogInit:  - bUseHttpProxy = false  - Libcurl will NOT use HTTP proxy
        [2015.06.07-14.57.10:701][  0]LogInit:  - bDontReuseConnections = false  - Libcurl will reuse connections
        [2015.06.07-14.57.10:701][  0]LogInit:  - CertBundlePath = /etc/ssl/certs/ca-certificates.crt  - Libcurl will set CURLOPT_CAINFO to it
        [2015.06.07-14.57.11:499][  0]LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
        [2015.06.07-14.57.11:507][  0]LogInit: Object subsystem initialized
        [2015.06.07-14.57.11:530][  0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleRule = ShortestSide'
        [2015.06.07-14.57.11:530][  0]LogConsoleResponse:Warning:   Found in ini file '../../../UnrealTournament/Saved/Config/LinuxServer/Engine.ini', in section '[/Script/Engine.RendererSettings]'
        [2015.06.07-14.57.11:530][  0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleCurve = (EditorCurveData=(Keys=),ExternalCurve=None)'
        [2015.06.07-14.57.11:530][  0]LogConsoleResponse:Warning:   Found in ini file '../../../UnrealTournament/Saved/Config/LinuxServer/Engine.ini', in section '[/Script/Engine.RendererSettings]'
        [2015.06.07-14.57.11:553][  0]LogInit: Selected Device Profile: [LinuxServer]
        [2015.06.07-14.57.11:553][  0]LogInit: Applying CVar settings loaded from the selected device profile: [LinuxServer]
        [2015.06.07-14.57.11:558][  0]LogInit: Linux hardware info:
        [2015.06.07-14.57.11:558][  0]LogInit:  - this process' id (pid) is 17614, parent process' id (ppid) is 17613
        [2015.06.07-14.57.11:558][  0]LogInit:  - we are not running under debugger
        [2015.06.07-14.57.11:558][  0]LogInit:  - machine network name is 'fun'
        [2015.06.07-14.57.11:558][  0]LogInit:  - we're logged in remotely
        [2015.06.07-14.57.11:558][  0]LogInit:  - Number of physical cores available for the process: 1
        [2015.06.07-14.57.11:558][  0]LogInit:  - Number of logical cores available for the process: 16
        [2015.06.07-14.57.11:558][  0]LogInit:  - Memory allocator used: binned
        [2015.06.07-14.57.11:558][  0]LogInit: Linux-specific commandline switches:
        [2015.06.07-14.57.11:558][  0]LogInit:  -nodwarf (currently OFF): suppress parsing of DWARF debug info (callstacks will be generated faster, but won't have line numbers)
        [2015.06.07-14.57.11:558][  0]LogInit:  -ansimalloc - use malloc()/free() from libc (useful for tools like valgrind and electric fence)
        [2015.06.07-14.57.11:558][  0]LogInit:  -jemalloc - use jemalloc for all memory allocation
        [2015.06.07-14.57.11:558][  0]LogInit:  -binnedmalloc - use binned malloc  for all memory allocation
        [2015.06.07-14.57.11:558][  0]LogInit:  -httpproxy=ADDRESS:PORT - redirects HTTP requests to a proxy (only supported if compiled with libcurl)
        [2015.06.07-14.57.11:558][  0]LogInit:  -reuseconn - allow libcurl to reuse HTTP connections (only matters if compiled with libcurl)
        [2015.06.07-14.57.11:558][  0]LogInit:  -virtmemkb=NUMBER - sets process virtual memory (address space) limit (overrides VirtualMemoryLimitInKB value from .ini)
        [2015.06.07-14.57.11:559][  0]LogInit:  - Physical RAM available (not considering process quota): 40 GB (40111 MB, 41073832 KB, 42059603968 bytes)
        [2015.06.07-14.57.12:083][  0]LogTextLocalizationManager: The requested culture ('en_US_POSIX') has no localization data; parent culture's ('en') localization data will be used.
        [2015.06.07-14.57.13:258][  0]LogExec:Warning: Cannot perform text import on property 'NavigationDataClass' here: NavigationDataClass=Class'/Script/UnrealTournament.UTRecastNavMesh',NavigationDataClassName=UnrealTournament.UTRecastNavMesh,AgentRadius=46.000000,AgentHeight=128.000000,AgentStepHeight=51.000000,bCanCrouch=False,bCanJump=False,bCanWalk=False,bCanSwim=False,bCanFly=False)
        [2015.06.07-14.57.15:001][  0]LogUObjectGlobals:Warning: Attempted to create a package with a short package name: Function_600 Outer: NullOuter
        [2015.06.07-14.57.15:001][  0]LogLinker:Warning: Function_600 has an inappropriate outermost, it was probably saved with a deprecated outer.
        [2015.06.07-14.57.15:388][  0]LogUObjectGlobals:Warning: Attempted to create a package with a short package name: Function_600 Outer: NullOuter
        [2015.06.07-14.57.15:388][  0]LogLinker:Warning: Function_600 has an inappropriate outermost, it was probably saved with a deprecated outer.
        [2015.06.07-14.57.15:479][  0]LogUObjectGlobals:Warning: Attempted to create a package with a short package name: Function_600 Outer: NullOuter
        [2015.06.07-14.57.15:479][  0]LogLinker:Warning: Function_600 has an inappropriate outermost, it was probably saved with a deprecated outer.
        [2015.06.07-14.57.20:837][  0]LogObj: 54474 objects as part of root set at end of initial load.
        [2015.06.07-14.57.20:837][  0]LogUObjectAllocator: 12950304 out of 0 bytes used by permanent object pool.
        [2015.06.07-14.57.21:069][  0]LogModuleManager:Warning: ModuleManager: Unable to load module 'ImageWrapper' because the file '/home/ogp/OGP_User_Files/ut4/LinuxServer/Engine/Binaries/Linux/' was not found.
        [2015.06.07-14.57.21:230][  0]LogModuleManager:Warning: ModuleManager: Unable to load module 'UMGEditor' because the file '/home/ogp/OGP_User_Files/ut4/LinuxServer/Engine/Binaries/Linux/' was not found.
        [2015.06.07-14.57.22:126][  0]LogAssetRegistry: FAssetRegistry took 0.7350 seconds to start up
        [2015.06.07-14.57.22:366][  0]LogAnalytics: Creating configured Analytics provider AnalyticsET
        [2015.06.07-14.57.22:366][  0]LogAnalytics: ET APIKey = UnrealTournament.Release. APIServer = http://etsource.epicgames.com/ET2/. AppVersion = 4.7.0-2566237+++depot+UE4-UT-Releases
        [2015.06.07-14.57.22:366][  0]LogAnalytics: SetUserId 000298690e060a070015016a6ef53f44|||Reg
        [2015.06.07-14.57.22:366][  0]LogAnalytics: AnalyticsET::StartSession [UnrealTournament.Release]
        [2015.06.07-14.57.22:366][  0]LogEngine: Initializing Engine...
        [2015.06.07-14.57.22:378][  0]LogInit: Texture streaming: Disabled
        [2015.06.07-14.57.22:386][  0]LogAnalytics: Creating configured Analytics provider AnalyticsET
        [2015.06.07-14.57.22:386][  0]LogAnalytics: ET APIKey = UTEditor.Binary.Release. APIServer = http://et2.epicgames.com/ET2/. AppVersion = 4.7.0-2566237+++depot+UE4-UT-Releases
        [2015.06.07-14.57.22:386][  0]LogAnalytics: ET APIKey = UTEditor.Binary.Release. DataRouterUploadURL = https://datarouter-public-service-gamedev.ol.epicgames.net/datarouter/api/v1/public/data. AppVersion = 4.7.0-2566237+++depot+UE4-UT-Releases
        [2015.06.07-14.57.22:386][  0]LogAnalytics: SetUserId 000298690e060a070015016a6ef53f44||
        [2015.06.07-14.57.22:386][  0]LogAnalytics: AnalyticsET::StartSession [UTEditor.Binary.Release]
        [2015.06.07-14.57.24:246][  0]LogPackageName: SearchForPackageOnDisk took   1.742s to resolve DM-DeckTest.umap
        [2015.06.07-14.57.24:246][  0]LogLoad: LoadMap: /Game/RestrictedAssets/Maps/WIP/DM-DeckTest?Name=Player?VersionCheck=1?Hat=/Game/EpicInternal/Cosmetic_Items/BP_Beanie.BP_Beanie_C?Taunt=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_PelvicThrust.Taunt_PelvicThrust_C?Taunt2=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_NoNo.Taunt_NoNo_C?Game=Duel?MustBeReady=1
        [2015.06.07-14.57.25:420][  0]LogWorld: Game class is 'UTDuelGame'
        [2015.06.07-14.57.25:421][  0]LogInit: BSD: Socket queue 262142 / 262142
        [2015.06.07-14.57.25:421][  0]LogInit: BSD: I am fun (103.18.40.124:0)
        [2015.06.07-14.57.25:546][  0]LogAIModule: Creating AISystem for world DM-DeckTest
        [2015.06.07-14.57.25:559][  0]LogWorld: Bringing World /Game/RestrictedAssets/Maps/WIP/DM-DeckTest.DM-DeckTest up for play (max tick rate 60) at 2015.06.07-18.57.25
        [2015.06.07-14.57.25:559][  0]UT: ===============
        [2015.06.07-14.57.25:559][  0]UT:   Init Game Option: ?Name=Player?VersionCheck=1?Hat=/Game/EpicInternal/Cosmetic_Items/BP_Beanie.BP_Beanie_C?Taunt=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_PelvicThrust.Taunt_PelvicThrust_C?Taunt2=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_NoNo.Taunt_NoNo_C?Game=Duel?MustBeReady=1
        [2015.06.07-14.57.25:559][  0]UT: Password: 0 NONE
        [2015.06.07-14.57.25:560][  0]UT: LobbyInstanceID: 0
        [2015.06.07-14.57.25:560][  0]UT: ==================
        [2015.06.07-14.57.25:560][  0]LogInit: BSD: Socket queue 262142 / 262142
        [2015.06.07-14.57.25:574][  0]LogWorld: Bringing up level for play took: 0.027816
        [2015.06.07-14.57.25:575][  0]UT:Warning: Failed to add Health_Small_C_0 to path network: no nearby navigable area was found
        [2015.06.07-14.57.25:575][  0]LogInit:Display: Game Engine Initialized.
        [2015.06.07-14.57.25:576][  0]LogConsoleResponse:Display: 
        [2015.06.07-14.57.25:576][  0]UT: Running 1 processors (16 logical cores)
        [2015.06.07-14.57.25:695][  0]LogLoad: Full Startup: 19.11 seconds (BP compile: 0.00 seconds)
        [2015.06.07-14.59.14:055][361]LogOnline:Warning: MCP: No session info to join for session (Game)
        [2015.06.07-14.59.15:722][451]LogOnline:Warning: MCP: ReadUserFile request failed. Invalid response. code=404 error={
          "errorCode" : "errors.com.epicgames.cloudstorage.file_not_found",
          "errorMessage" : "Sorry, we couldn't find a file stats.json for account 9888d3476aaa46cb8e7b73306bb3d437",
          "messageVars" : [ "stats.json", "9888d3476aaa46cb8e7b73306bb3d437" ],
          "numericErrorCode" : 12007,
          "originatingService" : "utservice"
        }
        [2015.06.07-14.59.23:093][883]UT: BEGIN GAME GameType: UTDuelGame_0
        [2015.06.07-14.59.23:093][883]UT: Difficulty: 3.000000 GoalScore: 0 TimeLimit (sec): 900
        [2015.06.07-15.05.08:893][191]LogPlayerController:Warning: Calling IsLocalController() while Player is NULL is undefined!
        [2015.06.07-15.05.08:894][191]LogOnline:Warning: MCP: No session info to leave for session (Game)
        [2015.06.07-15.05.38:724][945]UT: TravelToNextMap: 0 0
        [2015.06.07-15.05.38:724][945]LogExit: BeaconDriver IpNetDriver_1 shut down
        [2015.06.07-15.05.38:891][945]LogGameMode: ProcessServerTravel: /Game/RestrictedAssets/Maps/WIP/DM-Tuba
        [2015.06.07-15.05.39:726][995]UT: TravelToNextMap: 0 0
        [2015.06.07-15.05.40:730][ 54]UT: TravelToNextMap: 0 0
        [2015.06.07-15.05.41:716][112]UT: TravelToNextMap: 0 0
        [2015.06.07-15.05.42:719][171]UT: TravelToNextMap: 0 0
        [2015.06.07-15.05.42:735][172]LogEngine: Server switch level: /Game/RestrictedAssets/Maps/WIP/DM-Tuba
        [2015.06.07-15.05.42:735][172]LogLoad: LoadMap: /Game/RestrictedAssets/Maps/WIP/DM-Tuba?Name=Player?VersionCheck=1?Hat=/Game/EpicInternal/Cosmetic_Items/BP_Beanie.BP_Beanie_C?Taunt=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_PelvicThrust.Taunt_PelvicThrust_C?Taunt2=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_NoNo.Taunt_NoNo_C?Game=Duel?MustBeReady=1
        [2015.06.07-15.05.42:736][172]LogExit: GameNetDriver IpNetDriver_0 shut down
        [2015.06.07-15.05.43:273][172]LogWorld: Game class is 'UTDuelGame'
        [2015.06.07-15.05.43:273][172]LogInit: BSD: Socket queue 262142 / 262142
        [2015.06.07-15.05.43:276][172]LogAIModule: Creating AISystem for world DM-Tuba
        [2015.06.07-15.05.43:284][172]LogWorld: Bringing World /Game/RestrictedAssets/Maps/WIP/DM-Tuba.DM-Tuba up for play (max tick rate 60) at 2015.06.07-19.05.43
        [2015.06.07-15.05.43:284][172]UT: ===============
        [2015.06.07-15.05.43:284][172]UT:   Init Game Option: ?Name=Player?VersionCheck=1?Hat=/Game/EpicInternal/Cosmetic_Items/BP_Beanie.BP_Beanie_C?Taunt=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_PelvicThrust.Taunt_PelvicThrust_C?Taunt2=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_NoNo.Taunt_NoNo_C?Game=Duel?MustBeReady=1
        [2015.06.07-15.05.43:284][172]UT: Password: 0 NONE
        [2015.06.07-15.05.43:285][172]UT: LobbyInstanceID: 0
        [2015.06.07-15.05.43:285][172]UT: ==================
        [2015.06.07-15.05.43:285][172]LogInit: BSD: Socket queue 262142 / 262142
        [2015.06.07-15.05.43:285][172]LogOnline:Warning: MCP: Cannot create session 'Game': session already exists.
        [2015.06.07-15.05.43:294][172]LogWorld: Bringing up level for play took: 0.017801
        [2015.06.07-15.05.45:536][304]LogOnline:Warning: MCP: No session info to join for session (Game)
        [2015.06.07-15.05.47:065][393]LogOnline:Warning: MCP: ReadUserFile request failed. Invalid response. code=404 error={
          "errorCode" : "errors.com.epicgames.cloudstorage.file_not_found",
          "errorMessage" : "Sorry, we couldn't find a file stats.json for account 9888d3476aaa46cb8e7b73306bb3d437",
          "messageVars" : [ "stats.json", "9888d3476aaa46cb8e7b73306bb3d437" ],
          "numericErrorCode" : 12007,
          "originatingService" : "utservice"
        }
        [2015.06.07-15.05.59:909][147]LogOnline:Warning: MCP: No session info to leave for session (Game)
        [2015.06.07-15.06.02:018][271]UT: BEGIN GAME GameType: UTDuelGame_1
        [2015.06.07-15.06.02:019][271]UT: Difficulty: 3.000000 GoalScore: 0 TimeLimit (sec): 900
        [2015.06.07-15.06.31:911][ 29]UT: TravelToNextMap: 0 0
        [2015.06.07-15.06.31:912][ 29]LogExit: BeaconDriver IpNetDriver_3 shut down
        [2015.06.07-15.06.31:939][ 29]LogGameMode: ProcessServerTravel: /Game/RestrictedAssets/Maps/WIP/DM-Solo
        [2015.06.07-15.06.32:910][ 87]UT: TravelToNextMap: 0 0
        [2015.06.07-15.06.33:914][146]UT: TravelToNextMap: 0 0
        [2015.06.07-15.06.34:900][204]UT: TravelToNextMap: 0 0
        [2015.06.07-15.06.35:906][263]UT: TravelToNextMap: 0 0
        [2015.06.07-15.06.35:921][264]LogEngine: Server switch level: /Game/RestrictedAssets/Maps/WIP/DM-Solo
        [2015.06.07-15.06.35:921][264]LogLoad: LoadMap: /Game/RestrictedAssets/Maps/WIP/DM-Solo?Name=Player?VersionCheck=1?Hat=/Game/EpicInternal/Cosmetic_Items/BP_Beanie.BP_Beanie_C?Taunt=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_PelvicThrust.Taunt_PelvicThrust_C?Taunt2=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_NoNo.Taunt_NoNo_C?Game=Duel?MustBeReady=1
        [2015.06.07-15.06.35:921][264]LogExit: GameNetDriver IpNetDriver_2 shut down
        [2015.06.07-15.06.36:644][264]LogWorld: Game class is 'UTDuelGame'
        [2015.06.07-15.06.36:645][264]LogInit: BSD: Socket queue 262142 / 262142
        [2015.06.07-15.06.36:647][264]LogAIModule: Creating AISystem for world DM-Solo
        [2015.06.07-15.06.36:661][264]LogWorld: Bringing World /Game/RestrictedAssets/Maps/WIP/DM-Solo.DM-Solo up for play (max tick rate 60) at 2015.06.07-19.06.36
        [2015.06.07-15.06.36:661][264]UT: ===============
        [2015.06.07-15.06.36:661][264]UT:   Init Game Option: ?Name=Player?VersionCheck=1?Hat=/Game/EpicInternal/Cosmetic_Items/BP_Beanie.BP_Beanie_C?Taunt=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_PelvicThrust.Taunt_PelvicThrust_C?Taunt2=/Game/RestrictedAssets/Blueprints/Taunts/Taunt_No

        Comment


          #5
          I'm having a similar issue, the server is getting it's internal IP address instead of the outward facing IP of my router (strict Nat). Is there a way to set a hostname the server should report as? The router is wrapped in a dyndns so the hostname is always valid but forcibly setting an IP isn't guaranteed to always work (which i'm guessing is what the multi-home flag does?).

          Comment


            #6
            I'm not having an external IP problem, the server I installed on doesn't have an "internal" IP address, it only has an actual internet address which is 103.18.40.124 and people can successfully connect to it using that, or by using fun.unrealaussies.com

            The only thing that doesn't seem to happen, is the in-game server browser doesn't show the server on the list.

            Comment


              #7
              not even under the 'unresponsive servers' list? That's where mine landed, you can still connect directly to it by ip or hostname but the UT system can't ping it so it's in the list as a unresponsive host.

              Comment


                #8
                Nope, not even under "unresponsive servers" I changed the port to 8000 so now I connect using fun.unrealaussies.com:8000 but still not on the list

                Comment


                  #9
                  Try specifying the IP with the multihome command line argument. Under Win I use something like this

                  cd Engine\Binaries\Win64
                  start UE4Server-Win64-Test.exe UnrealTournament DM-Temple?Game=DM?MaxPlayers=8?botfill=2 -multihome=192.168.0.10 -port=7777 -log

                  Args should be the same under Linux, just a different name for the exe file and of course change the IP to your server's IP.

                  Comment


                    #10
                    That seems to have helped! Though sometimes the server doesn't show up, it now at least usually does. Note, that -multihome=fun.unrealaussies.com makes the server visible in the list, but impossible to connect to. However using the actual IP address does.

                    Now I'm having a problem with the Outpost map crashing it, but that's another story.....

                    Comment


                      #11
                      Originally posted by MoxNix View Post
                      If the server is on the same LAN as your game client (server is on your home connection) the only way you can connect to it is by IP (internal LAN IP). It won't show up in the server list for you, but it'll work fine for others (using your external IP).

                      If the server isn't running on your home connection, then something else must be wrong.
                      This must have just happened with the last update?

                      .... and if so, please change this back to how it was as it was very useful and needed! ... or, at least give us instructions on what are the new steps to get this to show in the server browser! ... or let us know that this is just temporary to work on other aspect of the game and will be added back later!?

                      I just installed a fresh new Game.ini and fired up a basic stock DM server and still no shows! ... even changed the game port! ... Nothing!


                      http://aggressivewarriors.com -=- {AW}'s Community Map Test Server -=-

                      Comment


                        #12
                        You need to use hairpin nat to treat your WAN ip as a usable WAN address, you cannot NAT to yourself without hairpin.

                        This has nothing to do with UT.

                        Comment


                          #13
                          Other names for 'nat hairpin' that may be useful for googling purposes are 'nat reflection' and 'nat loopback'. Not all routers support this technology (many disable it as a security feature) but some allow it and all non consumer open source router packages allow the functionality that I know of (pfsense, m00nwall, ddwrt, for example).

                          Comment


                            #14
                            it was working fine up until last night is when I noticed it when I wanted to test something from home with my wife!

                            IT SHOWED/WORKED JUST FINE BEFOR LAST BUILD! (@ least the last time I remember using it as a dedicated server) ....nothing has changed at my end!


                            http://aggressivewarriors.com -=- {AW}'s Community Map Test Server -=-

                            Comment


                              #15
                              There's still something wrong

                              The server does occasionally show up but it doesn't stay for long. After being on for 10 minutes it disappears off the list.

                              Still can connect using the ip address or fun.unrealaussies.com there is no router, it's a dedicated in Sydney and I join from my computer in Melbourne.

                              Comment

                              Working...
                              X