Announcement

Collapse
No announcement yet.

Editor Crash on Build Path

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Editor Crash on Build Path

    Hello Everyone,

    I'm working on a map but when I build paths the editor crashes, no error notification or report send just, stops responding, and I have to kill it from the task manager. Is this an issue with the unreal tournament navigation or is it an engine thing?

    I have a large navigation bounding box that covers the whole level, and prior to a few days ago it worked fine, I was able to package an alpha for testing, but since then it can't build, crashing without fail every time. When deleting the navmesh bounding box, it builds fine.

    Any and all solutions are welcome, thanks!
    Design | Production | Development

    Portfolio: http://www.nickburnsdesign.net
    ArtStation: https://www.artstation.com/artist/nickburnsdesign
    Studio Website: http://skypyre.com/
    Behance: https://www.behance.net/nickburnsdesign
    YouTube: https://www.youtube.com/channel/UC0x...jPpwOaGvGTniAw

    #2
    Open World Outliner, search on "nav", delete all 3 things it finds, save and rebuild. Then make a new navmeshboundsvolume and rebuild again.

    Also make sure you have at least one playerstart and one pickup in the map. Not positive if both are necessary but pretty sure at least one is.
    Last edited by MoxNix; 08-30-2015, 05:49 PM.

    Comment


      #3
      Just tried it, no success. The map is complete in terms of playerstarts and pickups.
      Design | Production | Development

      Portfolio: http://www.nickburnsdesign.net
      ArtStation: https://www.artstation.com/artist/nickburnsdesign
      Studio Website: http://skypyre.com/
      Behance: https://www.behance.net/nickburnsdesign
      YouTube: https://www.youtube.com/channel/UC0x...jPpwOaGvGTniAw

      Comment


        #4
        Originally posted by TomcaT112 View Post
        Just tried it, no success. The map is complete in terms of playerstarts and pickups.
        Ouch, I haven't had that problem in a long time but doing that always fixed it for me...

        Are you sure you deleted all 3 things? Not just the navmeshboundsvolume but the utrecastnavmesh and abstractnavdata too. If you only delete the volume it'll keep crashing until you delete all 3. Make sure you rebuild and save without them before a adding the new volume.

        And don't copy an existing brush or volume, make a brand new brush, size to fit and convert to navmeshboundsvolume, then save and rebuild. I had a problem with that once, a copied (and working fine in another map) navmesh wouldn't work in the map I copied it to.

        You might need to delete any NavBlockingVolumes too... I'm not sure about them since I wasn't using them at all when I had problems with nav rebuilds crashing.
        Last edited by MoxNix; 08-30-2015, 10:17 PM.

        Comment


          #5
          Okay so I started from the beginning. Deleted all 3 assets right from the World Outliner, then save and build. Then placed a NavMeshBoundsVolume in from the Volumes section in Modes, stretched it to the farthest walls on my map, and covered all walkable surfaces. Saved, and built, resulting in the same lock up.

          The map is pretty bare bones, all I have is BSP, weapons and pickup, player starts, skysphere, terrain with a landscape material on it, many point lights (static), one jump pad, sky light, directional light, atmosphereic fog, and a few volumes.

          Could it be conflicting with a KillZVolume, UT WaterVolume or BlockingVolume?

          EDIT:

          So the problem seems to have solved itself, but it appears as though it was caused by one of two things, the volume being exactly in line with a bsp, or a pickup I had that was in a small confined space, perhaps too small a space, causing the navmesh to freak out. Thanks MoxNix for your help!
          Last edited by TomcaT_; 09-01-2015, 08:30 PM.
          Design | Production | Development

          Portfolio: http://www.nickburnsdesign.net
          ArtStation: https://www.artstation.com/artist/nickburnsdesign
          Studio Website: http://skypyre.com/
          Behance: https://www.behance.net/nickburnsdesign
          YouTube: https://www.youtube.com/channel/UC0x...jPpwOaGvGTniAw

          Comment

          Working...
          X