Announcement

Collapse
No announcement yet.

Import Floor with colision blender to ut4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    look at your picture from editor its in right corner down, not in blender!

    Leave a comment:


  • replied
    Where is that i can't found it in blender ?

    Attached Files

    Leave a comment:


  • replied
    click convex decomposition bring it to max, and click apply. It will fix it for you.

    Leave a comment:


  • replied
    Yeah you're probably on the right track. I am doing something similar right now. I have a natural level with a large dirt floor. The floor has a 100,000+ triangles which made generating paths take hours. What I did was duplicate the floor, then use the Decimate tool in Blender to reduce the triangle count without losing the basic shape of the floor. Then I imported this mesh and made that the collision. Then I made it invisible so the complex floor is still shown. Make sure "Use simple collision as complex" is chosen in the mesh properties. This is per-poly collision. And IgnoreOnlyPawn is the collision setting on the real floor. Pathing now only takes a couple minutes. Good luck

    Leave a comment:


  • replied
    Thanks for u answer, i think the best way is recreate the level and using the import full level from blender


    i can make colision with litle things but for all thinks in one time

    Leave a comment:


  • replied
    When you can help it, don't rely on the editor automatically generating your collision because it can sometimes produce goofy results like this.

    Check out this page that explains how to create a collision mesh in Blender. If the object is named properly, the editor will recognize it as the collision when you import it.

    https://docs.unrealengine.com/latest...hes/index.html

    Leave a comment:


  • started a topic [BUG] Import Floor with colision blender to ut4

    Import Floor with colision blender to ut4

    Hello,

    i want import floor from blender to ut4 but problem with the collision i have this in blender :




    so now i recorde the files in fbx format and import it on utengine


    like u see the collision is not a plane is a pyramide why ?



    i do a video i think is a blender problem :

    model in blender : https://www.youtube.com/watch?v=TwnxtMsMHCk
    and importing on unreal : https://www.youtube.com/watch?v=sSEEkhiqABc

    what do u think please ?

    how do the colision with this model please ?
    Attached Files
    Last edited by Issa; 10-08-2015, 04:03 PM. Reason: more information
Working...
X