Announcement

Collapse
No announcement yet.

Bot paths and narrow walkways

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bot paths and narrow walkways

    Hi all, I've started working on a 1v1 showdown map for the MapCore comp and have come across some AI Navigation/Path bugs that I'm trying to fix. Any advice would be appreciated.

    I'll post a couple pics tonight when I get on my pc, but here's the general issue...

    I've been testing some narrow walkways with my layout (not too narrow, example 250x1000) that are basically in space, so there is possibility to fall off and die. I am noticing that the AI consistently just jumps off these walkways and dies. I haven't placed anything except bsp, navmesh and spawn points. The paths seem to build all ok so I don't get why the bots keep killing themselves. This occurs even if I don't engage in combat. Is there a way to fix this by adding waypoints? Or will that not have any affect? Again, I'll post a couple example pics tonight, roughly 8-9 hrs from now for further explanation.
    3d Artist
    UT Cosmetic Items |
    UT Cybernetic Build

    #2
    So here's what's happening, the bot runs around and most of the time, just jumps off the edge. X_X
    I'm gonna try a few nav changes, place some pickups or some waypoints. Will post here if I find a solution.

    Click image for larger version

Name:	Untitled.jpg
Views:	1
Size:	79.5 KB
ID:	345214
    3d Artist
    UT Cosmetic Items |
    UT Cybernetic Build

    Comment


      #3
      After building the paths (preferably after a total rebuild), press 'P' while being in viewport to see if anything strange happened to the navmesh and nodes.

      I think adding some pickups should help, if you don't have any.
      You can also try to block out that edge with UTNavBlockingVolume and see if it helps.
      Last edited by insomnaut; 04-07-2016, 06:25 AM.
      @insomnaut aka charon / DM-Coma / ArmorWare

      Comment


        #4
        Looks like a few pickups helped. I did try using a UTNavBlockingVolume around the edges but it didn't really prevent them from running off the edge.

        So yeah, a few pickups fixed this. However, I am getting a lot of coloring in my nav mesh, purples, reds etc.. if that would affect it?
        3d Artist
        UT Cosmetic Items |
        UT Cybernetic Build

        Comment

        Working...
        X