Announcement

Collapse
No announcement yet.

Black Triangles On Custom Mesh - Blender

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Black Triangles On Custom Mesh - Blender

    What am I doing wrong in Blender? My mesh has black patches, in Blender it looks fine. I must be doing something wrong while unwrapping the UV.

    Attached Files
    Win 10
    iMac (27-inch, Late 2013)
    3.5 GHz Intel Core i7
    32 GB 1600 MHz DDR3
    NVIDIA GeForce GTX 780M 4096 MB

    Maps:
    DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
    2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

    #2
    Try upping the lightmap resolution or setting the lightmap co-ordinate index to 1. (I have no idea what the latter does but when I change it it seems to fix similar bugs :/)
    :|

    Comment


      #3
      Thanks man! Do you mean in Blender or in UT?

      Originally posted by Flikswich View Post
      Try upping the lightmap resolution or setting the lightmap co-ordinate index to 1. (I have no idea what the latter does but when I change it it seems to fix similar bugs :/)
      Win 10
      iMac (27-inch, Late 2013)
      3.5 GHz Intel Core i7
      32 GB 1600 MHz DDR3
      NVIDIA GeForce GTX 780M 4096 MB

      Maps:
      DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
      2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

      Comment


        #4
        It looks like you have some faces that are flipped. In blender Tab into edit mode select all the polygons and under the shading/uvs tab click recalculate.

        Also if you have parts of your UV maps overlapping you will need a second UV channel for the light map. To do this you go under the object data tab (its the little triangle thing next to the wrench in the data panel) and there is a box for UV maps, click the plus and you will have a second UV channel. Unwrap this channel as you would normally just make sure nothing is overlapping.

        If you want you can pm me the FBX and I'll see what needs fixing and give you the full rundown.
        Mike :aka: thatscrawnykid
        Artist for Chaos: UT

        Comment


          #5
          Thanks man! I will give that a go right now, If I can't work it out I will PM ya. Cheers for the help!

          Originally posted by thatscrawnyki View Post
          It looks like you have some faces that are flipped. In blender Tab into edit mode select all the polygons and under the shading/uvs tab click recalculate.

          Also if you have parts of your UV maps overlapping you will need a second UV channel for the light map. To do this you go under the object data tab (its the little triangle thing next to the wrench in the data panel) and there is a box for UV maps, click the plus and you will have a second UV channel. Unwrap this channel as you would normally just make sure nothing is overlapping.

          If you want you can pm me the FBX and I'll see what needs fixing and give you the full rundown.
          Win 10
          iMac (27-inch, Late 2013)
          3.5 GHz Intel Core i7
          32 GB 1600 MHz DDR3
          NVIDIA GeForce GTX 780M 4096 MB

          Maps:
          DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
          2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

          Comment


            #6
            Originally posted by Flikswich View Post
            Try upping the lightmap resolution or setting the lightmap co-ordinate index to 1. (I have no idea what the latter does but when I change it it seems to fix similar bugs :/)
            The reason this works is because most meshes in UE4 use two UV maps uv0 is usually for the texture pass, and uv1 is usually used for the lightmap. Upping the resolution will fix problems like this but there is another underlying issue which I helped effects69 with via private message:

            Okay so the issue was the UV mapping. UV mapping is a pain in the neck and every model has its challenges. Blender makes this a bit easier with its UV sculpting but its always a chore. The automatic UV mapping is basically garbage for organic models. So what I did was mark a seam along the top of your cave (Its good practice to hide your seems to be in hard to see places) From there I used the UV sculpting feature to stretch the UV shell into a square shape filling as much of the UV square as possible. After that I use the minimize stretch tool (select a UV island then hit Ctrl-V and let it run) To even out the distortion. Now because I've only used one UV shell and there is no overlap it isn't necessary to have a separate UV set for the light map. This can be a pretty tricky workflow, I suggest watching a lot of tutorials on the subject and practice with some smaller props.

            This is an exception and light mapping is its own can of worms. The way your UV map was before there were many small triangles, and because light maps are textures with square pixels these small triangles look bad. There are a couple reasons for this one depends on the light map resolution. Typically light maps are a much lower res then the other textures this means that there isn't enough lighting detail to cover small UV islands resulting in bad shading. The trick here is to balance Good UV mapping with the right lightmap resolution. The other thing is making sure the light map UV's have enough space between them so that the lightmap texture doesn't "bleed" from one island into another. Basically the fewer Islands the better.

            It's a complex topic, though the UE4 help page does a okay job illustrating it:

            https://docs.unrealengine.com/latest...mapUnwrapping/


            However there is much more to light maps as illustrated here:

            http://www.worldofleveldesign.com/ca...-lightmaps.php

            Note: Yes this refers to UDK but the principals are what matter here.

            A bit old but still valid:

            http://www.hourences.com/tutorials-ue3-lightmapping/
            Mike :aka: thatscrawnykid
            Artist for Chaos: UT

            Comment


              #7
              Yup, BIG thanks to Mike for his help! The problem is now solved

              Attached Files
              Win 10
              iMac (27-inch, Late 2013)
              3.5 GHz Intel Core i7
              32 GB 1600 MHz DDR3
              NVIDIA GeForce GTX 780M 4096 MB

              Maps:
              DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
              2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

              Comment


                #8
                Originally posted by effects69 View Post
                Yup, BIG thanks to Mike for his help! The problem is now solved

                Glad I could help! I know its information overload, but basically all you need to remember for lightmap uv's is that the UV's cannot overlap, you should have as few uv shells as possible, and there should be give or take about 15% empty space between those uv's to prevent light bleeding. The amount of space between the UV's depends on the lightmap resolution as well. A smaller lightmap will have pixels that are being stretched over the surface of the model increasing the possibility of bleeding.
                Mike :aka: thatscrawnykid
                Artist for Chaos: UT

                Comment


                  #9
                  Hahha yup, big overload, but it's something I need to learn

                  Originally posted by thatscrawnyki View Post
                  Glad I could help! I know its information overload, but basically all you need to remember for lightmap uv's is that the UV's cannot overlap, you should have as few uv shells as possible, and there should be give or take about 15% empty space between those uv's to prevent light bleeding. The amount of space between the UV's depends on the lightmap resolution as well. A smaller lightmap will have pixels that are being stretched over the surface of the model increasing the possibility of bleeding.
                  Win 10
                  iMac (27-inch, Late 2013)
                  3.5 GHz Intel Core i7
                  32 GB 1600 MHz DDR3
                  NVIDIA GeForce GTX 780M 4096 MB

                  Maps:
                  DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
                  2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

                  Comment

                  Working...
                  X