Announcement

Collapse
No announcement yet.

A problem with swarm agent

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG] A problem with swarm agent

    Hello everyone! It,s the second time I do encounter this problem. I solved it once, but the second time, the old solution from internet forum doesn,t working.

    I solved the geometry error mentioned a time ago by my own.
    According to my information, one of the posible causes for this error is related to the high usage of repetetive or duplicated static meshes.
    The second suspicious thing is my own solution to an old geometry problem.

    After one part of my map was blocked by a grey untrespassible field, I have cut through a tunnel in this field using a lot of subtractive geometry and regained old parts of my level.

    The third problem is caused by content from other games,techdemos. I have to confess that I made heavy usage of static meshes and textures copied and merged by content from Epics Infiltrator Demo. I have searched im internet for new Unreal Engine 4 static meshes, because the standart library in ut 4 editor has limited my creativity. So I came to this dare and "cunning" idea to transfer static meshes from gratis tech demo "Infiltrator" into Unreal Tournament 4 Editor. I was so happy about the fact that it even worked and have forgotten about all kinds of problems, It may will cause in the future

    . Some of original Infiltrator textures and shaders caused the first error message. If I have found an easier way to get more static meshes somewhere else, I would never have followed the wrong path of stealing things.

    Another thing I know from my studies of problem related topics on the internet is, it,s caused my a memory leak or has a close relation to it.
    I,m still searching for posible sollutions and every aditional way to solve this problem would be great! Every time this error is caused by different circumstances and the best way ist to learn, how to avoid to get this far.

    As my nickname says, I,m a just an unreal engine 4 noob, so I don,t have all thouse kind of knowledge about rendering processes and technical things, I just do things that I have learned in the past with some first person shooter editors but I don,t think, my work is that bad compared to my lack of knowledge and noobiness

    #2
    Originally posted by UnrealEngineNoob View Post
    Some of original Infiltrator textures and shaders caused the first error message. If I have found an easier way to get more static meshes somewhere else, I would never have followed the wrong path of stealing things.
    I'm 99,9 % sure you're allowed to use all of the Epic Tech Demos that are in the Launcher in UT-Maps.
    btw, Epic has migrated some Content from the Infiltrator-Demo to the UT-Editor a while ago.

    Click image for larger version  Name:	Content_Restricted_Infiltrator.jpg Views:	2 Size:	251.0 KB ID:	394507

    What is your problem with the Swarm Agent?
    Does it not start?
    Does it start, but not build lighting?

    Attached Files
    Last edited by barsam2a; 11-06-2017, 04:42 PM.
    WIP - Maps (UT - Build 0.1.12.1): https://goo.gl/v8ze8Y
    Channel: https://www.youtube.com/user/barsam2a

    Comment


      #3
      It does start but only a short time after i always get the same error message, lighting build failed, swarm agent failed to kick off.
      Here some additional information from my error log

      18:43:08: ......... recreating SwarmAgent cache staging area
      18:43:08: ...... initializing connection to SwarmCoordinator
      18:43:08: ......... using SwarmCoordinator on RENDER-01
      18:43:10: ......... SwarmCoordinator failed to be initialized
      18:43:10: ...... initializing local performance monitoring subsystem
      18:43:11: ... initialization successful, SwarmAgent now running
      18:43:11: [Interface:TryOpenConnection] Local connection established
      18:43:11: [Job] Accepted Job 6EEDD812-447E8329-CD16C781-7A3590BA
      18:44:02: [Interface:OpenChannel] Error: System.IO.IOException: Der Prozess kann nicht auf die Datei "C:\Program Files\Epic Games\UnrealTournamentEditor\Engine\Saved\Swarm\SwarmCache\AgentStagingArea\v1.6B9B9F7695E65FBDC8278CC9DAA5A085052CFA83.mtrlgz" zugreifen, da sie von einem anderen Prozess verwendet wird.
      bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
      bei System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
      bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
      bei NSwarm.FSwarmInterface.OpenChannel(String ChannelName, EChannelFlags ChannelFlags)

      Comment


        #4
        Join these discord channels (if you haven't already), someone can surely help you there

        Official UT-Mapping-Channel

        Unreal-Carnage-Mapping-Channel
        WIP - Maps (UT - Build 0.1.12.1): https://goo.gl/v8ze8Y
        Channel: https://www.youtube.com/user/barsam2a

        Comment

        Working...
        X