Announcement

Collapse
No announcement yet.

Bots Not Damaged From Pain Causing Zone

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Bots Not Damaged From Pain Causing Zone

    After a whole day of me thinking my pain causing Volume wasn't working, I finaly noticed that bots are not effected by it, but players are. Anyone else notice this? Or is there a secret setting I have to toggle with to get the volume to hurt bots?
    Last edited by effects69; 04-15-2015, 02:07 PM.
    Win 10
    iMac (27-inch, Late 2013)
    3.5 GHz Intel Core i7
    32 GB 1600 MHz DDR3
    NVIDIA GeForce GTX 780M 4096 MB

    Maps:
    DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
    2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

    #2
    BUMP. Anyone have an idea to why this is happening, or not as the case may be.
    Win 10
    iMac (27-inch, Late 2013)
    3.5 GHz Intel Core i7
    32 GB 1600 MHz DDR3
    NVIDIA GeForce GTX 780M 4096 MB

    Maps:
    DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
    2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

    Comment


      #3
      My guess would be that something the UT team has done in programming the bots is responsible for them not registering as a player and thus not receiving pain from volumes... just report it as a bug and wait for it to hopefully be fixed in a week or two.

      UT4 modding discussion: irc.globalgamers.net #UTModders
      Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

      Comment


        #4
        Another thing you might conceivably be able to do is alter the pain volume itself by making it into a blueprint then playing around with what it can harm.

        UT4 modding discussion: irc.globalgamers.net #UTModders
        Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

        Comment


          #5
          The bots get killed just fine by the volumes in DM-DeckTest... are you using the same class?

          Comment


            #6
            I'm using the Pain Causing Volume. It's set in matinee and moves into place when a trigger is activated. I put the trigger on the inside of the room to test it and it killed me just fine. When I push a bot in there and activate the trigger it doesn't do anything to the bot.
            Win 10
            iMac (27-inch, Late 2013)
            3.5 GHz Intel Core i7
            32 GB 1600 MHz DDR3
            NVIDIA GeForce GTX 780M 4096 MB

            Maps:
            DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
            2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

            Comment


              #7
              I don't even know where to start in the blueprint for this action. I already have a Blueprint set up to get the trigger working with the doors, lights, sounds and moving volume brush.

              Originally posted by HenrikRyosa View Post
              Another thing you might conceivably be able to do is alter the pain volume itself by making it into a blueprint then playing around with what it can harm.
              Win 10
              iMac (27-inch, Late 2013)
              3.5 GHz Intel Core i7
              32 GB 1600 MHz DDR3
              NVIDIA GeForce GTX 780M 4096 MB

              Maps:
              DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
              2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

              Comment


                #8
                It has something to do with it being a movable volume. When the same volume is not attached to the trigger it works fine. But I need the volume to turn on when the trigger is activated. So I set it to a movement track and had it come up through the floor. This obviously isn't doing what I thought it would do.
                Win 10
                iMac (27-inch, Late 2013)
                3.5 GHz Intel Core i7
                32 GB 1600 MHz DDR3
                NVIDIA GeForce GTX 780M 4096 MB

                Maps:
                DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
                2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

                Comment


                  #9
                  Is your volume having that same issue as the particle generators you talked about in your other thread, where simply disabling the volume or hiding it doesn't work?

                  UT4 modding discussion: irc.globalgamers.net #UTModders
                  Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

                  Comment


                    #10
                    you could probably also expose the volume damage variable to matinee and keyframe 0 damage when it's off, then 20 per second when you want it to do damage.

                    UT4 modding discussion: irc.globalgamers.net #UTModders
                    Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

                    Comment


                      #11
                      No. It's moving and resting just fine as I also have it set up in Blueprint. + It kills me just fine after it has moved into place. Check out the vid. I moved the volume outside of the room, it's still triggered and moves up through the floor once the button is pressed. Note how it kills me and not the bot.

                      Originally posted by HenrikRyosa View Post
                      Is your volume having that same issue as the particle generators you talked about in your other thread, where simply disabling the volume or hiding it doesn't work?
                      Win 10
                      iMac (27-inch, Late 2013)
                      3.5 GHz Intel Core i7
                      32 GB 1600 MHz DDR3
                      NVIDIA GeForce GTX 780M 4096 MB

                      Maps:
                      DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
                      2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

                      Comment


                        #12
                        I already tried that, it didn't seem to effect anything. :s

                        Originally posted by HenrikRyosa View Post
                        you could probably also expose the volume damage variable to matinee and keyframe 0 damage when it's off, then 20 per second when you want it to do damage.
                        Win 10
                        iMac (27-inch, Late 2013)
                        3.5 GHz Intel Core i7
                        32 GB 1600 MHz DDR3
                        NVIDIA GeForce GTX 780M 4096 MB

                        Maps:
                        DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
                        2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

                        Comment


                          #13
                          didn't affect anything? but the variable did expose correctly to matinee?

                          UT4 modding discussion: irc.globalgamers.net #UTModders
                          Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

                          Comment


                            #14
                            No, it wouldn't change, If set to off it just stayed off, even after ticking on, on the last marker.

                            Originally posted by HenrikRyosa View Post
                            didn't affect anything? but the variable did expose correctly to matinee?
                            Win 10
                            iMac (27-inch, Late 2013)
                            3.5 GHz Intel Core i7
                            32 GB 1600 MHz DDR3
                            NVIDIA GeForce GTX 780M 4096 MB

                            Maps:
                            DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
                            2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

                            Comment


                              #15
                              I mean the actual numerical damage variable, not a boolean.

                              Create a new float track and see if the property you need is there.
                              Last edited by HenrikRyosa; 04-15-2015, 07:02 PM.

                              UT4 modding discussion: irc.globalgamers.net #UTModders
                              Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

                              Comment

                              Working...
                              X