Announcement

Collapse
No announcement yet.

Light Leaking Through Walls/Floors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Light Leaking Through Walls/Floors

    OK so the issue I'm having now is light leaking. I have some torches on a wall, but you can see the light from the lower room/space glowing up the wall even though there is a floor between them. I did two things just to make sure. One, I made sure the wall was overlapping the floor and no space at all. Still leaks.

    Two, I split the wall into two-one for the upper space and one for the lower. Made sure there are no gaps. Still leaks.

    How can I fix this? Really ruins the lighting effects.

    P.S. I should add that this is all BSP at the moment. I also had some SphereReflectionCapture objects upper and lower. I made sure the influence didn't overlap into the other areas. No love. Still leaks.
    Last edited by BigAl3D; 11-18-2015, 09:44 AM. Reason: Added P.S.


    W.I.P.s
    DM-Containers

    #2
    have you rebuilt the geometry and lighting recently? This is pretty common with maps that need to be rebuilt.
    PayBack

    Comment


      #3
      Thanks for the reply. Well yeah. After every test I mentioned in the OP, I hit build. I'm assuming that builds everything fresh. Correct? I also just tried changing the lighting quality to medium on a build. Same results. My next test tonight will be to use static meshes.


      W.I.P.s
      DM-Containers

      Comment


        #4
        Check on light settings. There is a couple radius options. Both have a visual one is a yellowish orange and the other one is blue cant remember name of that one but if u over look that it does what u said

        Comment


          #5
          Make sure you're using reflection capture, and that it's not overlapping the rooms too much; you can get a leaking effect like that where the light isn't actually effecting the lightmap, just the reflection colour.

          Comment


            #6
            Still Leaking

            Here's a couple of screenshots. In the first one, mainly BSP, no gaps anywhere and the reflection spheres are not overlapping. In the second shot, I made a small room with a static mesh wall from the browser. Same problem. The only thing different about these lights is the have the flicker material in the light function. I removed the light function material, build, still leaks. This is very odd. I guess I'll delete the particle fire and see if that makes a difference.

            I just did a test in another part of the map with standard lights, made them bright and placed them near the wall at the top. No leaks.



            Attached Files


            W.I.P.s
            DM-Containers

            Comment


              #7
              OK, so I've boiled down my problem to having Cast Shadows DISABLED. I know in Cinema 4D, if you don't cast shadows, you can illuminate areas that should be darker. I had copied these torch lights from the Titan map. I'm guessing if I go back to where I grabbed it from, that there isn't an issue in that cave-like area for a leak.

              Even more knowledge. By turning on Cast Shadows, this gives me red "X" on the light since they're Stationary Lights. If I change it to Static to get rid of the X, the Light Function is disabled which I guess makes sense. I guess I just need to make the light's radius small enough not to overlap and I'm good.
              Last edited by BigAl3D; 11-20-2015, 09:35 AM.


              W.I.P.s
              DM-Containers

              Comment


                #8
                Use 2 lights, one small radius stationary with cast shadows off for the flickering effect close to the source plus a larger radius static light with cast shadows on to illuminate things further from the source.
                Last edited by MoxNix; 11-20-2015, 10:04 AM.

                Comment


                  #9
                  The problem shouldnt be the light but rather the reflectionspheres.
                  Reflection goes through walls, especially light - you have to either get rid of the ref. spheres or smaller their radius. You could also play with the reflec. intensity, one of it or a combination should hopefully fix your issue.

                  I hope this will help, let us know.
                  Nonemms Music Thread DM-Lea(Youtube Soundcloud )
                  Fabian Joosten - composer for media

                  Comment


                    #10
                    Thanks for the replies.

                    @MoNix - I'll give that two-light trick a try, but I'm guessing it will just increase the build times. Eh, not enough to worry about on this map I suppose.

                    @Nonemm – As you can see in the shot above, the reflection sphere radius was reduced with both in that area. No influence going through the floor at all. I think I will delete all of them anyway and start fresh. Plus, I think I need to learn more about how and when to use the spheres in the first place.

                    I forgot to ask why isn't there a way to make the flame particles themselves emit light? I know about the emissive property in the materials editor, but is that just for visible light or actual light rays?
                    Last edited by BigAl3D; 11-20-2015, 08:35 PM.


                    W.I.P.s
                    DM-Containers

                    Comment


                      #11
                      Well, turns out there IS a way to make the fire emit its own light! Pretty cool, but it still has the same issue with its light leaking through walls regardless of reflections spheres. In this hallway with torches, almost all that light is coming from the particle system. It has a slower flicker than the other method, but I'm going to dig around to see about speeding that up. Maybe there's a shadow option as well. The second image shows where the parameters are to turn on the light function.

                      I made the mistake of changing the main system instead of making a duplicate so now any map using that object is way bright and emits light. Back to the menus...

                      Attached Files
                      Last edited by BigAl3D; 11-26-2015, 10:50 AM.


                      W.I.P.s
                      DM-Containers

                      Comment


                        #12
                        Another update. The P_TorchFire emitter does have an option for shadows, but after enable all the options and even getting into the noise material to turn on Default Lit, still the same leak. I think my dream has be crushed. Nice to know you CAN make the fire emit light as long as it's used in the proper place.


                        W.I.P.s
                        DM-Containers

                        Comment

                        Working...
                        X