Announcement

Collapse
No announcement yet.

Problems with my map

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems with my map

    Hello .... i have a question.

    I am working on a map for some time.
    A DM-Map covered in fog.
    I am at the beginning and without textures or static meshes and so on.

    But i wanted to make it ready for bots.
    To test it and see how it works and to enjoy what i have done so far as a beginner of working with unreal editor.

    I have build a "Navmeshboundsvolume" and covered my whole level with it.
    The problem is ... it should look green like in the tutorials ... but it looks like a rainbow.
    Why?
    What has gone wrong and what i have to do to fix that problem?
    Or is it ok and normally?
    Look a the picture i added.

    The bots run around ... but not everywhere and they act a Little bit strange and not really intelligent like in maps of other Players.

    Hope someone can help me with some ideas or maybe tutorials who are made for bloody beginners of Building a map with the Editor.


    Greetings Rongkongcoma
    Attached Files

    #2
    Well, it's hard to tell since you don't have anything selected, but I'm questioning the two boxes you have. Is the lower box the navmesh? Can you only run on the lower half of the map? Also, what is that other box that up high and thinner?


    W.I.P.s
    DM-Containers

    Comment


      #3
      Sounds like your Navmesh is working. They changed it a while back, it's supposed to look like a rainbow instead of just green now.

      Is your Navmesh high enough to encompass all the parts you want bots running around on? If you're not sure, change it so the top of your Navmeshboundsvolume is flush with the BlockingVolume over the top of the map.

      Edit: Actually in the second sreenshot I can see the bounds volume is cutting through the collision spheres on a couple pickups which means the volume definitely isn't high enough. Make the nav volume flush with the BV over the top and it should work better.

      Your navmesh bounds volume needs to be at least as high as the highest surface you want bots navigating + player height + a little bit more. Then you have to consider how much additional air you can get with jumps, including assisted jumps with lifts, rockets, boots and even combination assisted jumps.
      Last edited by MoxNix; 01-25-2016, 11:04 PM.

      Comment


        #4
        Hello again.

        You are right ... MoxNix.

        Everything seems to be normal.
        The Bot runs around ... also on the upper parts of my map ... and in modification "godlike" i have no chance to win. :-)

        Seems that only the rainbowlike colors where confusing for me.

        Now i know that it is not a Problem to have more Colors than only green it is ok.

        Thanks so far for the info.

        Comment

        Working...
        X