Announcement

Collapse
No announcement yet.

How do I play my map online with my friends?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How do I play my map online with my friends?

    Hoping someone can help a noob mapper with his first level. I finally finished a custom level I have been working on for a long time. I cooked and packaged it successfully and uploaded it to UT file storage when asked to do so. How do I play this map online with my friends? Do I use a Hub? I can start a LAN game with the map but I don't see it anywhere else in any multiplayer options. Thank you for helping out a first timer!!

    #2
    Hi!

    Good that you finished your map.
    Maybe you get the hold of it now, and the scene needs people like you!


    Best thing to do is start a server yourself.
    Download the UTserver on below from this page:
    https://www.epicgames.com/unrealtour...-notes-june-28

    Use this guide to setup your server and your map.
    https://www.unreal4.tk/ut4-guides/ut4.php

    (Best thing is, to setup redirection for file upload to your friend to assure fast downloads.

    Try to read carefully step by step.
    If you have any questions, let me know!

    * A mod might move this topic to the general help section i have the feeling.
    Last edited by iSenSe`; 11-13-2017, 05:49 PM.

    Comment


      #3
      Thank you very much for the information. I am not really interested in setting up a server that runs on my machine. Not very fair to my friends who are playing with me from across the internet! LOL! Isn't there a way I can run my game on the Epic Hubs that are in the game already? Again, thank you for the info you shared, much appreciated!

      Comment


        #4
        You cannot upload your map to a HUB/Server. The Admin(s) of a HUB/Server are the only ones who can add a map to the rotation pool.

        Try the personal server route. If your friends can connect with ~100 ping or less, it should be playable. (Yeah, you'll have like 8 ping!)
        No one sees what tomorrow knows.

        Comment


          #5
          Having issues getting my own server going. I have followed the server setup instruction to the letter. Attaching the server log file, maybe someone can assist. At initial startup of the server it just keeps running and running and running, it never closes. As always, any help is greatly appreciated. Log file attached.
          Attached Files

          Comment


            #6
            Thank you for posting the log!

            Could you post your startup script/batch as well?

            It should be something like this:
            start UE4Server-Win64-Shipping.exe UnrealTournament DM-Q3DM17-UNG?Game=DM?MaxPlayers=12?IgnoreIdle=1?ForceNoBots=1?MaxPlayerWait=25?MaxReadyWait=5?GoalScore=25?Timelimit=0?Mutator=Instagib -port=2222 -log

            That DM map you see there (DM-Q3DM17-UNG)
            Every map offcourse needs to loaded up in your Game.ini.

            example:
            [/Script/UnrealTournament.UTDMGameMode]
            MapRotation=/Game/DM-Q3DM17-UNG


            [/Script/UnrealTournament.UTBaseGameMode]
            RedirectReferences=(PackageName="DM-Q3DM17-UNG-WindowsNoEditor",PackageURLProtocol="http",PackageURL="utstats.esy.es/utfiles/DM-Q3DM17-UNG-WindowsNoEditor.pak",PackageChecksum="9235aefed4f9dd9c4efe2489b8468be7")


            Check if this is filled correctly.

            Comment


              #7
              I am not getting past the very first initial start up that is described in the server setup instructions. Where is says that the server will close down itself and then I can set my own MOTHD, etc. It just runs and runs and runs, I have to force quit it to get it to close. My game.ini file is not populating at all.

              Click image for larger version

Name:	11-14-2017 3-42-03 PM.jpg
Views:	312
Size:	26.3 KB
ID:	394737
              Last edited by From_Behind; 11-14-2017, 04:46 PM.

              Comment


                #8
                Post the script you are trying to start now.
                Let's have a look.

                Also post your mapname.

                Comment


                  #9
                  I spotted this error in your log:
                  Code:
                  [2017.11.14-04.12.59:090][  0]LogNet:Warning: Failed to init net driver ListenURL: /Game/RestrictedAssets/Maps/WIP/DM-Spacer?Name=Player?VersionCheck=1?Game=DM?MaxPlayers=16: WinSock: binding to port 7777 failed (21)
                  [2017.11.14-04.12.59:105][  0]LogNet:Warning: Failed to init net driver ListenURL: :7787//Engine/Maps/Entry: WinSock: binding to port 7787 failed (21)
                  This could mean you are trying to use the -multihome directive with a wrong (internal) IP or the ports 7777 UDP and 7787 UDP are already in use by something else.
                  I suspect you are binding to a wrong IP though.

                  Can you show me your batch file contents?


                  Edit: Wrote a portion in the guide to find the ip you should be using for multihome:
                  https://www.pro2play.com/games/ut4/guide.php#multihome
                  Last edited by zunnie; 11-14-2017, 05:44 PM.
                  Pro 2 Play Community Website @ https://www.pro2play.com/
                  UT4 Server/Hub Guide @ https://www.pro2play.com/games/ut4/guide.php
                  UT3 Server Guide @ https://www.pro2play.com/games/ut3/serverguide.php
                  Need help? Join Discord Chat @ https://discord.gg/ETv384q

                  Comment


                    #10
                    Thanks guys, appreciate the feedback. I have the correct IP of my machine (192.168.17.141). I am simply trying to run the very first batch file that the instructions tell you to run, the RunServer.bat file with my correct internal IP address. Here it is:

                    cd Engine\Binaries\Win64
                    start UE4Server-Win64-Shipping.exe UnrealTournament DM-Spacer?Game=DM?MaxPlayers=16 -multihome=192.168.17.141 -port=7777 -log

                    So now I am here, see attachment. It's no longer endlessly scrolling, but it still never closes and the Game.ini file is not populated.

                    Attached Files

                    Comment


                      #11
                      So very slowly, this is happening, see attachment. Thanks!
                      Attached Files

                      Comment


                        #12
                        If you are absolutely sure it's the correct IP then i know a few possible reasons for it to not work:
                        1) The ports 7777 and 7778 UDP are already in use on your pc by another process (for a hub add 14000 to this)
                        2) The server executable is being prevented by some program (antivirus?) from binding to the ports
                        3) The server (windows) firewall is blocking the executable from binding to the ports

                        Alternatively, you could try removing the -multihome directive from the batch so it binds automatically instead, worth a try maybe?
                        Pro 2 Play Community Website @ https://www.pro2play.com/
                        UT4 Server/Hub Guide @ https://www.pro2play.com/games/ut4/guide.php
                        UT3 Server Guide @ https://www.pro2play.com/games/ut3/serverguide.php
                        Need help? Join Discord Chat @ https://discord.gg/ETv384q

                        Comment


                          #13
                          Very close to running your sever with the right map almost!
                          Check indeed if the ports are forwarded in your modem with that IP.
                          Hope you have the username/password

                          Otherwise you can reset your modem by holding or pressing the reset button for approx. 30secs. (note the LED's blinking)
                          *Warning, all your modem/router settings will be set back to default (if you have a build-in router, your WiFi password is back to factory settings)

                          After this reset the modemlogin is also set back to standard usually admin/admin (Google: your modem brand/type admin login)
                          Last edited by iSenSe`; 11-15-2017, 03:54 PM.

                          Comment


                            #14
                            Just to be sure, i think you did, but did you unblock the zip download for the server before extracting it?
                            Pro 2 Play Community Website @ https://www.pro2play.com/
                            UT4 Server/Hub Guide @ https://www.pro2play.com/games/ut4/guide.php
                            UT3 Server Guide @ https://www.pro2play.com/games/ut3/serverguide.php
                            Need help? Join Discord Chat @ https://discord.gg/ETv384q

                            Comment


                              #15
                              Thanks guys, really appreciate the info, I will look into this. What about map rotation? There is a lot of different info on this forum. I have followed the guide but on this point its a little fuzzy. It just says "this converts to this". Isn't it different for "standard" maps included in the .pak file that downloads with the server files? I have the path from opening my custom .pak file with NotePad++ but how does that convert? The path is: UnrealTournament/Content/DM-MyMapName.umap.

                              Comment

                              Working...
                              X