Announcement

Collapse
No announcement yet.

Pitch black reflective surfaces problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Pitch black reflective surfaces problem

    Click image for larger version

Name:	b552d83a72546e0bfb5a6886c462db90.jpg
Views:	1
Size:	541.9 KB
ID:	355581Click image for larger version

Name:	d8c622611171b945998e9716b41873d6.png
Views:	1
Size:	836.3 KB
ID:	355580

    It happens when the game has effects setting on "low" or "medium". It's fine on high or epic. Any ideas? (Happens on my map only)
    Last edited by overman; 03-16-2015, 05:04 AM.

    #2
    Do you have any reflection capture actors in your level?

    Comment


      #3
      Originally posted by Clawfist View Post
      Do you have any reflection capture actors in your level?
      yes I do, sphere captures

      Comment


        #4
        Hmm not sure then, might be something is getting dropped there. I'll pass along and see if somebody has any ideas.

        Comment


          #5
          I have found that switching my lights from static to stationary fixes the problem. I'm not sure if that's normal but there it is. Thanks for your help.

          Comment


            #6
            Hey man, I'm not really satisfied with that solution! Do you think you could send a version of the map for me to look at?

            Are those black surfaces metallic?

            When I get in tomorrow I'll take a look at what fratures we might disable on lower settings.

            Edit:
            A good way to start debugging problems is to use the g-buffer visualization mode in the editor. See if you can find anything odd happening in there.

            nick
            Last edited by Nick Donaldson; 03-16-2015, 09:46 PM.
            Designer

            aka. neoduck

            Comment


              #7
              Hey, sorry that was not the problem after all. It still happens with stationary lights. The problem is with surfaces with metallic at 1. At low and medium effects settings there doesn't seem to be reflections on the surfaces so they appear totally black. You can test this with "Material'/Game/RestrictedAssets/Environments/Liandri/Materials/M_Metal'". It seemed to only happen in my map because I've used this material a lot but it seems that it's a global problem after all.

              Comment


                #8
                I'll look into it, thanks!
                Designer

                aka. neoduck

                Comment


                  #9
                  So it looks like we made some bad choices when it comes to lower-end scalability settings.

                  We're currently disabling the reflection environment on low and medium settings.

                  The way I view scalability in this regard is to provide lower quality options for low-spec machines, but never to "break" the visuals. This seems to fall under the "broken" category. Sorry!!

                  Technical tangent:
                  The "reflection environment" is a series of cube maps captured using the reflection capture actors and used by our physically based shading model. The reflection environment decides which cubemap to apply by looking at which captures overlap each pixel, and choosing the one with the smallest radius (with the assumption that the smallest capture is probably the most "local" and accurate capture for that area). At the border, it blends smoothly between them.

                  The way these are applied is very similar to defered lighting, so you pay for "overdraw" on each pixel, depending on how many reflection captures overlap each pixel on screen.

                  On our mobile renderer, we use a simplified approach; for each mesh, only use the closest reflection capture. This can cause some discontinuities where two meshes meet (and each one has a different cubemap capture applied), but it's a much cheaper method, and these artifacts can be worked around.

                  I'm hoping we can port this cheaper rendering path over to the PC renderer instead of totally dropping the reflection environment for lower settings.

                  Nick
                  Designer

                  aka. neoduck

                  Comment


                    #10
                    try to set Directional light settings > reset all the shadows settings do the same in world shadows settings after set sky light to stationary verify directional lighting settings > cascated shadow maps and reset settings, verify again world settings >
                    light softness and reset after build all... sorry for bad english

                    Comment

                    Working...
                    X