Announcement

Collapse
No announcement yet.

Question: How to fix sound cue from constantly being triggered.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Question: How to fix sound cue from constantly being triggered.

    I have 2 sound cues set to a triggered button. the button and my triggers and everything are working great. It's done through Matinee and Blueprint. the sound cues are going through my Blueprint.

    The problem is this. Players are able to constantly set the sound cues off during a game by triggering the button (only the sounds that are constantly re activated) It becomes VERY annoying during a game when players keep hitting the button. How can I set it to only play the cues once per trigger, so they can only be triggered again after the initial trigger has reset.

    I hope this makes sense? I've attached a video.

    Also, when you shoot the trigger with a weapon the sounds play twice as loud as they do when you run into the trigger, is there a way to fix this? I've noticed that certain weapons are unable to set the trigger off, is that an editor bug or is that in the settings too?


    Thanks again!!!

    Win 10
    iMac (27-inch, Late 2013)
    3.5 GHz Intel Core i7
    32 GB 1600 MHz DDR3
    NVIDIA GeForce GTX 780M 4096 MB

    Maps:
    DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
    2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

    #2
    Well... why not just disable the trigger itself for a set amount of time after it's pressed... (yep it's me again)

    UT4 modding discussion: irc.globalgamers.net #UTModders
    Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

    Comment


      #3
      lol hello again :P and thx!

      I could do that, I just need to work out how to do that :P

      Originally posted by HenrikRyosa View Post
      Well... why not just disable the trigger itself for a set amount of time after it's pressed... (yep it's me again)
      Win 10
      iMac (27-inch, Late 2013)
      3.5 GHz Intel Core i7
      32 GB 1600 MHz DDR3
      NVIDIA GeForce GTX 780M 4096 MB

      Maps:
      DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
      2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

      Comment


        #4
        Attached a screen shot of my current BluePrint.
        Attached Files
        Win 10
        iMac (27-inch, Late 2013)
        3.5 GHz Intel Core i7
        32 GB 1600 MHz DDR3
        NVIDIA GeForce GTX 780M 4096 MB

        Maps:
        DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
        2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

        Comment


          #5
          I tried using the Destroy actor in BluePrint, but it just stops the trigger for being activated again. This would be great if there was a way to add a reset after the trigger got destroyed.
          Win 10
          iMac (27-inch, Late 2013)
          3.5 GHz Intel Core i7
          32 GB 1600 MHz DDR3
          NVIDIA GeForce GTX 780M 4096 MB

          Maps:
          DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
          2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

          Comment


            #6
            Also thought that a delay after the reverse might work, but it won't compile when I do that.
            Win 10
            iMac (27-inch, Late 2013)
            3.5 GHz Intel Core i7
            32 GB 1600 MHz DDR3
            NVIDIA GeForce GTX 780M 4096 MB

            Maps:
            DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
            2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

            Comment


              #7
              Try a multigate after your trigger and before the Play:



              Out 0 links to what you have now
              Out 1 links say, a delay node, and goes back around to "Reset" on the gate.
              Loop should be off so the button can't be mashed over and over to bypass that. pressing it a third time with Loop off should simply make it do nothing.
              Make the start index 0.

              This is all theory for now, but worth a try.

              UT4 modding discussion: irc.globalgamers.net #UTModders
              Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

              Comment


                #8
                OMG you are a STAR! That worked! Thanks so much! I've attached a screen of the working Bluepring layout in case anyone else needs to do this.

                Originally posted by HenrikRyosa View Post
                Try a multigate after your trigger and before the Play:



                Out 0 links to what you have now
                Out 1 links say, a delay node, and goes back around to "Reset" on the gate.
                Loop should be off so the button can't be mashed over and over to bypass that. pressing it a third time with Loop off should simply make it do nothing.
                Make the start index 0.

                This is all theory for now, but worth a try.
                Attached Files
                Win 10
                iMac (27-inch, Late 2013)
                3.5 GHz Intel Core i7
                32 GB 1600 MHz DDR3
                NVIDIA GeForce GTX 780M 4096 MB

                Maps:
                DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
                2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

                Comment


                  #9
                  Glad it worked!

                  UT4 modding discussion: irc.globalgamers.net #UTModders
                  Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

                  Comment

                  Working...
                  X