Announcement

Collapse
No announcement yet.

[Map] DM-DeepBlueAstral [The Latest Version 20200711]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Ho,ok, THX for the clarification

    Leave a comment:


  • replied

    Originally posted by Stevelois View Post
    Yep.

    I didn't found info about the "Base Desirability" setting? The way I understand it, the lower the number, higher the priority? In fact, I did change some ammo and health values but bots don't seem to care about the new "Desirability". I put lower values, test, put higher values, test and bots behave the same...

    About my English, I often make grammar errors. I don't know many, many words and I don't understand how to write things from various time like past, present, future. But, to exchange on forums, the words are often the same so it look fine most of the time lol.


    No, the higher the value of the desirability, the more it increases the priority. It can go beyond 1. The concept of the item desirability has been in UT since long ago. Not sure if UT99 had it (will have to reinstall the game to check that editor, it's been more than 5 years since the last time i did that) but UT2003 had.
    http://www.unreal.ut-files.com/3DEdi...line/ammo.html

    It was called MaxDesirability.

    Anyway, the base desirability works for the ammo or health items in UT4 (to this point), not for those pickups from the pickup bases, like weapons or armors or powerups. Simply put, those pickup bases are just inventories or bases, they are not the pickups. They allow you to define which pickups to spawn/drop from them. And those pickups are mostly BP and if you open one of those item BP you can find "Base Pickup Desirability" in its properties, and you can see it has a value of 2 for the powerups and 1.5 if it's an armor, etc. And that parameter is the one you want, but it is not exposed to the level designer.

    Leave a comment:


  • replied
    Yep.

    I didn't found info about the "Base Desirability" setting? The way I understand it, the lower the number, higher the priority? In fact, I did change some ammo and health values but bots don't seem to care about the new "Desirability". I put lower values, test, put higher values, test and bots behave the same...

    About my English, I often make grammar errors. I don't know many, many words and I don't understand how to write things from various time like past, present, future. But, to exchange on forums, the words are often the same so it look fine most of the time lol.

    Leave a comment:


  • replied
    Great news to hear it works for you!
    Yeah it could be very useful if things like these could be more documented or explained technically so that mappers can save some time. Hey your English is good, well, good enough to me at least coz I can't tell if it's your native language or not.

    Leave a comment:


  • replied
    Well Chong, I wanted to THX you again because bots are now using the lifts

    It seem it was one or a combination of the UTRecastNavMesh-UT settings. I did spend lots of time before I ask your help trying this & that in the settings in the last few weeks but the bots was still not using the lifts. With your settings, it work as it is supposed to be. Bots are really good now and they even surprise me! Many settings aren't documented and when English isn't your first language, a miracle is a must to get it work!

    Leave a comment:


  • replied
    This is veeeeeeeeeeeeeeery helpful my friend

    THX a lot for the details Chong, I appreciate very much!!!!

    Leave a comment:


  • replied
    Originally posted by Stevelois View Post
    Hey Chong

    I wanted to ask, can you tell me which settings you changes in the RecastNavMesh so bots behave so well?

    I'm making a level that when I replace the stock lifts by my own, the bots don't use them? The custom mesh use a simple collision box, and the pivot point is fine too. But when I rebuild the paths the bots still don't use the lifts? I would appreciate you can share your info

    Click image for larger version

Name:	2021-01-29 12_56_28-UnrealTournament - Unreal Editor.jpg
Views:	70
Size:	62.1 KB
ID:	412022
    Click image for larger version

Name:	2021-01-29 12_59_07-UnrealTournament - Unreal Editor.jpg
Views:	58
Size:	45.6 KB
ID:	412023

    These are the values.

    For lifts,
    1) supposedly the mesh pivot doesn't matter
    2) make sure LiftExits are connected to the lifts, accordingly
    3) make sure LiftExits are properly flagged to be exit only or with lift jump
    4) make sure the LiftExits are on navmesh
    5) on the UTRecastNavMesh, make sure you select "Draw Special Paths" to show the navlink for lifts
    Click image for larger version

Name:	2021-01-29 13_06_45-UnrealTournament - Unreal Editor.jpg
Views:	60
Size:	150.5 KB
ID:	412024
    6) supposedly, after rebuild the navmesh, if you see these blue navlinks, you know the navmesh side of setup is mostly fine
    7) select your lift, in its properties, you can find "Navmesh Scale" under "AI", you might want to tweak that value in some cases for easier access or more precise access
    8) up to this point, the basic setup should be fine, now you'll need to check how to make bot prefer lifts in some cases
    9) to do that, you might want to reduce the triangles of navmesh between your intended point from-where-to-go-for-the-lift and the LiftExit, by placing the exit on a better triangle or tweaking the recast navmesh actor
    10) you might also want to add items on the lift destination side to attract bots, and even increase the "Base Desirability" of the items, this is actually useful, not just for lifts

    Leave a comment:


  • replied
    Hey Chong

    I wanted to ask, can you tell me which settings you changes in the RecastNavMesh so bots behave so well?

    I'm making a level that when I replace the stock lifts by my own, the bots don't use them? The custom mesh use a simple collision box, and the pivot point is fine too. But when I rebuild the paths the bots still don't use the lifts? I would appreciate you can share your info

    Leave a comment:


  • replied
    Originally posted by ÐutchSmºke View Post
    Correct indeed sir!
    Being renamed/hashed, this shouldn't be the case. I have other multi versioned maps that all play with no issue..@EPIC
    More replays to follow!
    Not sure why. I guess that's probably because my maps use mostly custom assets which are constantly modified through the map iterations.

    Originally posted by Achernar View Post
    Hello chonglee, just wanted to say I'm really enjoying all your work on this one. Plays well and I have not found any glitches. Loving the great variety of alternative pathways, makes for so much replay ability, all rapped up in one stunning backdrop. Hats off.
    Hey Achernar, thanks for the feedback! Nice to hear you love the alternative paths. I wonder how you actually use them:P

    Leave a comment:


  • replied
    Hello chonglee, just wanted to say I'm really enjoying all your work on this one. Plays well and I have not found any glitches. Loving the great variety of alternative pathways, makes for so much replay ability, all rapped up in one stunning backdrop. Hats off.

    Leave a comment:


  • replied
    Correct indeed sir!
    Being renamed/hashed, this shouldn't be the case. I have other multi versioned maps that all play with no issue..@EPIC
    More replays to follow!

    Leave a comment:


  • replied
    @
    Originally posted by ÐutchSmºke View Post
    A very nice après-vacation surprise to come back to! Thank you kind sir!
    Reloaded onto the LPA.
    Also sent you a link to some issues encountered.
    Hi ÐutchSmºke!
    I had a look of your video, that's a COMMON issue when you have the old version(s) of the map on your PC.
    Check the attached picture.

    What happened on your side was you were seeing both the old assets and the new ones. In the attached picture, that black part was the old floor mesh from the previous released version. The new floor is a different mesh with a different name, which is the bright part in the picture.
    Usually, when you install a new version of a map, make sure you remove the old one(s) or rename it. I usually rename the filename extension to .pak.bk so that it is clearly a backup and it won't be recognized by the game as a valid map.

    The issue happens because the game scans the assets in the pak files, if you have 2 maps/paks with same references of assets (that is, same asset names and they are referenced by both paks), you play 1 of them, you are bound to see issues like this!

    The black parts are just messy lightmaps when they are being applied to the wrong version of meshes.
    Attached Files

    Leave a comment:


  • replied
    A very nice après-vacation surprise to come back to! Thank you kind sir!
    Reloaded onto the LPA.
    Also sent you a link to some issues encountered.
    Last edited by ÐutchSmºke; 07-25-2020, 04:05 PM. Reason: Test run

    Leave a comment:


  • replied
    Thanks Stevelois!

    Yeah sometimes I wonder why IES profiles are not used much in UT4. I guess if more official maps had been done there could be some nice examples...
    Thanks for mentioning my new site, well it's barely a site, I plan to add pages but it'll be slow due to lack of time on that :P I always want a site like yours with more info and interesting stuff

    Leave a comment:


  • replied
    Did a run alone in this new version, and I must say, impressive work, as always!!

    I really like all what you've made. The custom assets, VFX, sounds are unique and look and feel awesome We don't see Light IE profiles often in UT4. Very nice. As you mentioned, mats needs more love, but in all, the final will be another must in my book.

    Excellent work Chong!

    I've update my blog links to your new site.

    Have a nice day

    Leave a comment:

Working...
X