No announcement yet.

Failure building on Ubuntu 14.04

  • Filter
  • Time
  • Show
Clear All
new posts

    Failure building on Ubuntu 14.04

    Hello all, I want to build and run a standalone UnrealTournament on my local machine (i.e., not connect to a remote server). I have an ASUS gaming laptop with an NVidia GEFORCE GTX 670MX graphics card. I have verified that I can play a pre-built version of the game on Windows 10 on this machine. However, I run into trouble when trying to run a compiled version on Linux. I am using clang-3.5 on Ubuntu 14.04

    Here's what I tried.
    0. apt-get install nvidia-352-dev
    1. git cloned the UnrealTournament repo
    2. ./ (mono crashes once or twice, but I repeatedly execute until success)
    3. ./
    4. make
    5. ./Engine/Binaries/Linux/UE4Editor ---> crashes after sitting for a while, doesn't start GUI.
    [2016.08.02-09.30.37:134][ 0]LogInit: -virtmemkb=NUMBER - sets process virtual memory (address space) limit (overrides VirtualMemoryLimitInKB value from .ini)
    [2016.08.02-09.30.37:134][ 0]LogInit: - Physical RAM available (not considering process quota): 16 GB (16002 MB, 16386304 KB, 16779575296 bytes)
    [2016.08.02-09.30.37:134][ 0]LogTextLocalizationManager: No translations for ('') exist, falling back to 'en' for localization and internationalization data.
    [2016.08.02-09.30.37:134][ 0]CrashReportClientLog: CrashReportReceiverIP:
    [2016.08.02-09.30.37:134][ 0]CrashReportClientLog: DataRouterUrl: https://datarouter-public-service-pr...v1/public/data
    Assertion failed: false [File:Runtime/Core/Public/Templates/Function.h] [Line: 316]
    Attempting to call a null TFunction!
    [2016.08.02-09.30.37:135][ 0]LogLinux:Error: appError called: Assertion failed: Assertion failed: false [File:Runtime/Core/Public/Templates/Function.h] [Line: 316]
    Attempting to call a null TFunction!

    [2016.08.02-09.30.37:135][ 0]LogLinux: === Critical error: ===

    6. make UE4Game-Linux-Test (and also Shipping)

    7. ./Engine/Binaries/Linux/UE4Game-Linux-Test UnrealTournament (and also Shipping) ---> crashes with error message saying cannot find the uproject file.
    Failed to open descriptor file "../../../UE4Game-Linux-Shipping/UE4Game-Linux-Shipping.uproject" (this file doesn't actually exist)

    8. make UnrealTournament* (i.e., any of the targets) --> compilation fails the same way
    [2016.08.02-09.38.11:367][ 0]LogCompile: Autogenerating boilerplate cpp: GameplayAbilities.generated.cpp
    [2016.08.02-09.38.11:412][ 0]LogCompile: Success: Parsed 12767 line(s), 2497 statement(s) in 0.14 secs.
    LogCompile: /media/data//Unreal/UnrealTournament/UnrealTournament/Source/UnrealTournament/Private/UTSocialStyle.h(16): Error: Unrecognized type 'FSocialStyle' - type must be a UCLASS, USTRUCT or UENUM
    Unrecognized type 'FSocialStyle' - type must be a UCLASS, USTRUCT or UENUM

    Question: Which targets should I be building? What do I need to do to get this working? Apologies, I looked at the forums but I couldn't solve the issue. The instructions that I found don't seem to work.

    It looks like there are bugs in Github preventing it from building... again.

    What branch are you trying to build? Bog standard `make` should work if everything is functioning properly, but typically you would want to build UnrealTournamentDevelopment, I believe. I can check a bit later if I can get it to build anywhere.
    HABOUJI! Ouboudah! Batai d'va!
    BeyondUnreal - Liandri Archives [An extensive repository of Unreal lore.] - Join us on IRC [ - #beyondunreal]


      I tried both clean-master and release. Same failures. Btw, 'make' does not build UE4Game-Linux-*, had to name those explicitly to build.

      I also verified that the pre-build pre-alpha Linux client game released July 13 2016 works on my machine: LinuxNoEditor/Engine/Binaries/Linux/UE4-Linux-Shipping

      Would it be possible to tell me an earlier commit on either branch that has been verified to work? Perhaps the one used to build the July 13th release?

      Also I notice the difference in the name of the executables: UE4Game-Linux-Shipping when building from source vs UE4-Linux-Shipping in the pre-built. Does this indicate that some build instructions have changed?

      I would really appreciate if I can get UE4 working in the next 2-3 days as I am working towards a deadline to evaluate feasibility of UE4 for a project.


        I have the same problem on Ubuntu 14.04. When will this be fixed? Or can I fix it myself somehow?

        Tushark: the build on just the Unreal Engine succeeded for me. Like described here (so from
        Btw I noticed this is incompatible with Unreal Tournament, it asked to recompile stuff which also failed.
        Last edited by Jar-El; 08-16-2016, 02:25 AM.


          Thanks Jar-El for debugging some more.

          Is there a git commit or release tag that can be used to correctly build and run the game on either Windows or Linux? It can be old, don't need the latest stuff. Just something that works for now.