Announcement

Collapse
No announcement yet.

[Solved] Unreal Tournament (pre-alpha) Localization Problem on GNU/Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG] [Solved] Unreal Tournament (pre-alpha) Localization Problem on GNU/Linux

    Hi,

    I have tried to run Unreal Tournament (pre-alpha) on my Linux Mint 17.3 (x64) system for months. For every build, I have encountered the same problem. Today, I changed my system language into English from Turkish; as it appeared the game launches just fine. Here is the terminal output of the game when I try to launch it when my system language is in Turkish.

    Code:
    ~/ut2014/LinuxNoEditor/Engine/Binaries/Linux $ ./UE4-Linux-Shipping UnrealTournament
    Using binned.
    4.14.0-3190340+++UT+Release-Next 505 0
    Disabling core dumps.
    Signal 11 caught.
    Malloc Size=131076 LargeMemoryPoolOffset=131092 
    CommonLinuxCrashHandler: Signal=11
    Malloc Size=65535 LargeMemoryPoolOffset=196655 
    Malloc Size=131160 LargeMemoryPoolOffset=327832 
    Malloc Size=131160 LargeMemoryPoolOffset=459016 
    Malloc Size=131160 LargeMemoryPoolOffset=590200 
    Using binned.
    LogPlatformFile: Not using cached read wrapper
    LogInit:Display: RandInit(481844309) SRandInit(481844310).
    LogTaskGraph: Started task graph with 4 named threads and 5 total threads with 1 sets of task threads.
    LogInit: Build: ++UT+Release-Next-CL-3190340
    LogInit: Engine Version: 4.14.0-3190340+++UT+Release-Next
    LogInit: Compatible Engine Version: 4.14.0-3190340+++UT+Release-Next
    LogInit: Net CL: 3190340
    LogInit: Compiled (64-bit): Nov  8 2016 14:09:37
    LogInit: Compiled with Clang: 3.7.0 (tags/RELEASE_370/final)
    LogInit: Build Configuration: Shipping
    LogInit: Branch Name: ++UT+Release-Next
    LogInit: Command line:  -Abslog=~/Belgeler/UnrealTournament/Saved/Logs/UnrealTournament-CRC.log ~/Belgeler/UnrealTournament/Saved/Crashes/crashinfo-UnrealTournament-pid-2721-0002F9D8120B0D0B003702901CB00C9F/
    LogInit: Base directory: ~/ut2014/LinuxNoEditor/Engine/Binaries/Linux/
    LogInit: Installed Engine Build: 1
    LogInit: Presizing for max 100000 objects, including 0 objects not considered by GC, pre-allocating 0 bytes for permanent pool.
    LogInit: Object subsystem initialized
    [2016.11.11-10.55.19:481][  0]LogInit: Linux hardware info:
    [2016.11.11-10.55.19:481][  0]LogInit:  - we are the first instance of this executable
    [2016.11.11-10.55.19:481][  0]LogInit:  - this process' id (pid) is 2725, parent process' id (ppid) is 2721
    [2016.11.11-10.55.19:481][  0]LogInit:  - we are not running under debugger
    [2016.11.11-10.55.19:481][  0]LogInit:  - 
    [2016.11.11-10.55.19:481][  0]LogInit:  - 
    [2016.11.11-10.55.19:481][  0]LogInit:  - we're logged in locally
    [2016.11.11-10.55.19:481][  0]LogInit:  - we're running with rendering
    [2016.11.11-10.55.19:481][  0]LogInit:  - CPU: GenuineIntel 'Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz' (signature: 0x406E3)
    [2016.11.11-10.55.19:481][  0]LogInit:  - Number of physical cores available for the process: 2
    [2016.11.11-10.55.19:481][  0]LogInit:  - Number of logical cores available for the process: 4
    [2016.11.11-10.55.19:482][  0]LogInit:  - Cache line size: 64
    [2016.11.11-10.55.19:482][  0]LogInit:  - Memory allocator used: binned
    [2016.11.11-10.55.19:482][  0]LogInit: Linux-specific commandline switches:
    [2016.11.11-10.55.19:482][  0]LogInit:  -nodwarf (currently OFF): suppress parsing of DWARF debug info (callstacks will be generated faster, but won't have line numbers)
    [2016.11.11-10.55.19:482][  0]LogInit:  -ansimalloc - use malloc()/free() from libc (useful for tools like valgrind and electric fence)
    [2016.11.11-10.55.19:482][  0]LogInit:  -jemalloc - use jemalloc for all memory allocation
    [2016.11.11-10.55.19:482][  0]LogInit:  -binnedmalloc - use binned malloc  for all memory allocation
    [2016.11.11-10.55.19:482][  0]LogInit:  -httpproxy=ADDRESS:PORT - redirects HTTP requests to a proxy (only supported if compiled with libcurl)
    [2016.11.11-10.55.19:482][  0]LogInit:  -reuseconn - allow libcurl to reuse HTTP connections (only matters if compiled with libcurl)
    [2016.11.11-10.55.19:482][  0]LogInit:  -virtmemkb=NUMBER - sets process virtual memory (address space) limit (overrides VirtualMemoryLimitInKB value from .ini)
    [2016.11.11-10.55.19:482][  0]LogInit:  - Physical RAM available (not considering process quota): 4 GB (3383 MB, 3465048 KB, 3548209152 bytes)
    [2016.11.11-10.55.19:522][  0]LogUObjectArray: 141 objects as part of root set at end of initial load.
    [2016.11.11-10.55.19:522][  0]LogUObjectAllocator: 23432 out of 0 bytes used by permanent object pool.
    [2016.11.11-10.55.19:522][  0]LogUObjectArray: CloseDisregardForGC: 0/0 objects in disregard for GC pool
    [2016.11.11-10.55.19:522][  0]LogPaths:Warning: No paths for game localization data were specifed in the game configuration.
    [2016.11.11-10.55.19:523][  0]LogInit:Warning: No paths for engine localization data were specifed in the engine configuration.
    [2016.11.11-10.55.19:523][  0]LogTextLocalizationManager: No translations for ('') exist, falling back to 'en' for localization and internationalization data.
    [2016.11.11-10.55.19:524][  0]CrashReportClientLog: CrashReportClientVersion=1.0.0
    [2016.11.11-10.55.19:524][  0]CrashReportClientLog: CrashReportReceiver disabled
    [2016.11.11-10.55.19:524][  0]CrashReportClientLog: DataRouterUrl: https://datarouter-public-service-prod06.ol.epicgames.com/datarouter/api/v1/public/data
    [2016.11.11-10.55.19:525][  0]CrashReportClientLog: FullCrashDump: UE4, NetworkLocation: , bExactMatch:1
    [2016.11.11-10.55.19:525][  0]CrashReportClientLog: FullCrashDump: ++Orion+, NetworkLocation: \\epicgames.net\root\Projects\Paragon\QA_CrashReports, bExactMatch:0
    [2016.11.11-10.55.19:531][  0]LogModuleManager:Warning: ModuleManager: Module 'AnalyticsET' not found - its StaticallyLinkedModuleInitializers function is null.
    Assertion failed: ModuleManager.IsModuleLoaded(ModuleName) [File:Runtime/Core/Public/Modules\ModuleManager.h] [Line: 247] 
    Tried to get module interface for unloaded module: 'AnalyticsET'[Callstack]  00  0x000000000085fbaf  FLinuxPlatformStackWalk::CaptureStackBackTrace(unsigned long long*, unsigned int, void*) [D:\Build\++UT+Release-Next+Compile\Sync\Engine\Source\Runtime\Core\Private\Linux/LinuxPlatformStackWalk.cpp, line 945]
    [Callstack]  01  0x00000000007afc55  FGenericPlatformStackWalk::StackWalkAndDump(char*, unsigned long, int, void*) [D:\Build\++UT+Release-Next+Compile\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform/GenericPlatformStackWalk.cpp, line 146]
    [Callstack]  02  0x000000000085faa3  Unknown [D:\Build\++UT+Release-Next+Compile\Sync\Engine\Source\Runtime\Core\Private\Linux/LinuxPlatformStackWalk.cpp, line 893]
    [Callstack]  03  0x00000000008db05d  FDebug::LogAssertFailedMessage(char const*, char const*, int, wchar_t const*, ...) [Runtime/Core/Public/Containers/ContainerAllocationPolicies.h, line 460]
    [Callstack]  04  0x000000000078082e  FAnalyticsET& FModuleManager::GetModuleChecked<FAnalyticsET>(FName) [Runtime/Core/Public\Containers/ContainerAllocationPolicies.h, line 484]
    [Callstack]  05  0x000000000078075f  FAnalyticsET& FModuleManager::LoadModuleChecked<FAnalyticsET>(FName) [Runtime/Core/Public/Modules/ModuleManager.h, line 291]
    [Callstack]  06  0x000000000076f72f  FCrashReportAnalytics::Initialize() [D:\Build\++UT+Release-Next+Compile\Sync\Engine\Source\Programs\CrashReporter\CrashReportClient\Private/CrashReportAnalytics.cpp, line 49]
    [Callstack]  07  0x00000000007757b8  RunCrashReportClient(wchar_t const*) [D:\Build\++UT+Release-Next+Compile\Sync\Engine\Source\Programs\CrashReporter\CrashReportClient\Private/CrashReportClientApp.cpp, line 327]
    [Callstack]  08  0x000000000077d669  main [Runtime/Core/Public\Containers/ContainerAllocationPolicies.h, line 484]
    [Callstack]  09  0x00007ffa3293ff45  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7ffa3293ff45]
    [Callstack]  10  0x000000000076947e  ~/ut2014/LinuxNoEditor/Engine/Binaries/Linux/CrashReportClient() [0x76947e]
    
    [2016.11.11-10.55.21:065][  0]LogLinux:Error: appError called: Assertion failed: Assertion failed: ModuleManager.IsModuleLoaded(ModuleName) [File:Runtime/Core/Public/Modules\ModuleManager.h] [Line: 247] 
    Tried to get module interface for unloaded module: 'AnalyticsET'
    
    [2016.11.11-10.55.21:065][  0]LogLinux: === Critical error: ===
    
    
    [2016.11.11-10.55.21:065][  0]LogLinux: Assertion failed: Assertion failed: ModuleManager.IsModuleLoaded(ModuleName) [File:Runtime/Core/Public/Modules\ModuleManager.h] [Line: 247] 
    Tried to get module interface for unloaded module: 'AnalyticsET'
    
    
    
    [2016.11.11-10.55.21:066][  0]LogExit: Executing StaticShutdownAfterError
    [2016.11.11-10.55.21:067][  0]LogGenericPlatformMisc: FPlatformMisc::RequestExit(1)
    Engine crash handling finished; re-raising signal 11 for the default handler. Good bye.
    Parçalama arızası
    My system information via Steam;

    Code:
    Computer Information: 
        Manufacturer:  Unknown 
        Model:  Unknown 
        No Touch Input Detected 
         
    Processor Information: 
        CPU Vendor:  GenuineIntel 
        CPU Brand:  Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz 
        CPU Family:  0x6 
        CPU Model:  0x4e 
        CPU Stepping:  0x3 
        CPU Type:  0x0 
        Speed:  2800 Mhz 
        4 logical processors 
        2 physical processors 
        HyperThreading:  Supported 
        FCMOV:  Supported 
        SSE2:  Supported 
        SSE3:  Supported 
        SSSE3:  Supported 
        SSE4a:  Unsupported 
        SSE41:  Supported 
        SSE42:  Supported 
        AES:  Supported 
        AVX:  Supported 
        CMPXCHG16B:  Supported 
        LAHF/SAHF:  Supported 
        PrefetchW:  Unsupported 
         
    Network Information: 
        Network Speed:   
         
    Operating System Version: 
        Linux Mint 17.3 Rosa (64 bit) 
        Kernel Name:  Linux 
        Kernel Version:  4.4.0-22-generic 
        X Server Vendor:  The X.Org Foundation 
        X Server Release:  11701000 
        X Window Manager:  Metacity (Marco) 
        Steam Runtime Version:  steam-runtime-beta-release_2016-09-02 
         
    Video Card: 
        Driver:  NVIDIA Corporation GeForce 940M/PCIe/SSE2 
     
        Driver Version:  4.5.0 NVIDIA 370.28 
        OpenGL Version: 4.5 
        Desktop Color Depth: 24 bits per pixel 
        Monitor Refresh Rate: 59 Hz 
        VendorID:  0x10de 
        DeviceID:  0x1347 
        Revision Not Detected 
        Number of Monitors:  1 
        Number of Logical Video Cards:  1 
        Primary Display Resolution:  1920 x 1080 
        Desktop Resolution: 1920 x 1080 
        Primary Display Size: 12,17" x 6,85"  (13,94" diag) 
                                                30,9cm x 17,4cm  (35,4cm diag) 
        Primary Bus: PCI Express 4x 
        Primary VRAM: 2048 MB 
        Supported MSAA Modes:  2x 4x 8x 16x  
         
    Sound card: 
        Audio device: Realtek Generic 
         
    Memory: 
        RAM:  3383 Mb 
         
    Miscellaneous: 
        UI Language:  English 
        LANG:  tr_TR.UTF-8 
        Microphone:  Not set 
        Steam Controller Cable and Base:  Not set 
        Total Hard Disk Space Available:  140677 Mb 
        Largest Free Hard Disk Block:  11334 Mb 
        VR Headset: None
    I can happily provide more information if needed. Thank you, regards.
    Last edited by rea987; 11-13-2016, 10:12 AM. Reason: Solved

    #2
    At last! I found a way to launch the game with different localization that the system's default language. If the game needed to launched on a non-supported localization, LC_ALL=C should be added before the launch command and argument.

    Code:
    LC_ALL=C ./UE4-Linux-Shipping UnrealTournament
    solved my problem. LC_ALL=en_US might solve the issue as well. The interesting thing is I found that solution from entirely unrelated Unity game; Gone Home which has a similar localization problem that prevents game to run properly with variety of localizations.

    http://pcgamingwiki.com/wiki/Gone_Ho...rking_properly
    https://steamcommunity.com/app/23243...76115478302160

    Comment

    Working...
    X