Announcement

Collapse
No announcement yet.

Having to hit a key multiple times to switch weapons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG] Having to hit a key multiple times to switch weapons

    This has been happening the last few days quite often. I pick up a gun, hit my weapon bind (let's say it's "R" in this case) to switch to the weapon, and it doesn't switch. I have to hit it 2-4 times for the weapon to switch and this is happening in the middle of fights. It's very consistent if I play with 170 ping in Europe, but it was happening constantly yesterday on Epic HQ where I ping 80 as well, and even happening on AW where I ping 20. Sometimes I will have had the weapon for quite a while and it's not newly picked up and it occurs. I've added an angry face to the topic so you can see what I look like when this happens.

    #2
    Thanks for reporting. I thought it was just me. I thought it was my keyboard, so I was going to try a different one before playing today and then report.

    I was doing some tests, as I thought it was only for newly picked up weapons. But it does happen for me with weapons I have had for a while.

    I notice it on rocket launcher and flak cannon the most.

    Rocket launcher was worse, I'd pick it up and then have to press a few times before it would switch.

    I have some footage from my game last night. Didn't have mic on, which would have been good as you'd be able to hear when it didn't work as I started mashing the key to respond

    I've got weapon hidden if that makes any difference? Not sure if its an animation issue.
    Another crazy idea brought to you by richardboegli ;P

    Comment


      #3
      I wonder if the client has to wait for server to acknowledge weapon change before the weapon changes?
      If so it could be a packet loss issue.
      Another crazy idea brought to you by richardboegli ;P

      Comment


        #4
        I also have weapon hidden. It happens to me with the link gun usually.

        Comment


          #5
          I forgot to mention that sometime when I fire the rocket launcher it takes two clicks to respond.
          I noticed this for the first time yesterday, usually when in the middle of a fire fight.
          It is not the weapon switch delay time. I already had weapon selected and hadn't fired it yet, so it should have been instant.
          Another crazy idea brought to you by richardboegli ;P

          Comment


            #6
            Changed my mouse and it still happened occasionally.

            Tried lowering my frame cap to match the server cap rate of 150FPS and no difference.

            Show weapon made no difference.

            My ping can vary a bit every now and then, so I think it could be a stability issue.

            I've got some footage where I had someone against the wall and was trying to fire my flak cannon and nothing....
            Another crazy idea brought to you by richardboegli ;P

            Comment


              #7
              If you are holding a weapon for at least a few seconds, then try to switch to a different weapon, does this occur? Or is it an issue only when switching between multiple weapons rapidly?

              Comment


                #8
                Originally posted by [Epic]Frost View Post
                If you are holding a weapon for at least a few seconds, then try to switch to a different weapon, does this occur? Or is it an issue only when switching between multiple weapons rapidly?
                Frost - Yes to the first question.

                Comment


                  #9
                  adding my support to richardboeglis assertion that rl won't fire sometimes in a firefight. it's as if the server randomly chooses whose shot to ignore. after maybe 3-4 clicks it finally fires one shot by which time I'm basically dead.

                  UT4 modding discussion: irc.globalgamers.net #UTModders
                  Contrib Digest | UT2341 - Henrik's UT4 Dev Blog | Twitter

                  Comment


                    #10
                    This has been happening for quite a while and has been reported before. When first picking up a weapon, it's like the server has to acknowledge you have it before you can switch to it and that seems to take a few seconds.

                    So you pick it up, immediately try to switch to it and nothing happens.

                    Comment


                      #11
                      Originally posted by MoxNix View Post
                      This has been happening for quite a while and has been reported before. When first picking up a weapon, it's like the server has to acknowledge you have it before you can switch to it and that seems to take a few seconds.

                      So you pick it up, immediately try to switch to it and nothing happens.
                      I play offline quite a lot and have observed the same problem, I assumed it was just that the game doesn't establish you have the weapon until the "pickup" is complete

                      Comment


                        #12
                        Happens to me as well, most noticeably for me when I'm trying to load up multiple rox after either switching to it or just picking it up. Will be holding down secondary and when I expect based on timing that 2 or 3 rox should have loaded, I'll find when I release fire they never actually loaded.
                        NoBrainsNoAims^ // nbna^
                        My movies on YouTube:
                        UT2k4: UT~]i[mmortalZ Part 1
                        , Part 2 / UT~]i[mmortalZ 2 / UT Immortalz 3
                        UT4: Rocket Jumping - Titan Pass

                        UT4: Frag Highlights #1 / #2 / #3 NEW

                        Comment


                          #13
                          I can confirm that problem. At first i was thinking about shooting with enforcer then taking the first weapon after respawn.
                          That obviously cause a delay due to the enforcer cooldown.
                          But I found that it happen without firing before.
                          The game make the sound like you really have changed weapon but when you fire you are still with enforcer.
                          I noticed that especially in Nick Test with ASMD. In Chill with rocket and flak. And in deck with flak again. But this is an inpression maybe.

                          Comment


                            #14
                            Hasn't happened to me in a while but usually I'd be holding down mini and spraying while walking over another weapon pick it up. Continue spraying for a bit longer never letting go of fire. Then try to switch to the weapon I just picked up. Nothing happens. I go back and run over the weapon I picked up again then it let's me switch but hasn't happened in a while.
                            Join the community Facebook page
                            https://www.facebook.com/pages/Unreal-Tournament-4-Community/302380673298678

                            Comment


                              #15
                              *Phew*, I thought I was losing my mind or really hadn't been improving

                              Also noticed that stinger doesn't seem to fire first round sometimes.

                              Curious as to why it is being exhibited offline.

                              I've got a feeling it is something to do with dropped packets, tick rate and ping compensation not lining up. Maybe a race condition somewhere?

                              I'd have to have a closer look, just the first thing that comes to mind.
                              Another crazy idea brought to you by richardboegli ;P

                              Comment

                              Working...
                              X