Announcement

Collapse
No announcement yet.

Strange colors for textures in 0.1.10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG] Strange colors for textures in 0.1.10

    This issue seems similar to the one brought up in this thread, where you asked the user to email you for more information, but I can't exactly tell if it's the same issue from their screenshot.

    Some diagnostic information:
    • Distribution: Fedora 25
    • Kernel: 4.10.13
    • GPU: AMD HD 6870
    • Driver: open source "Radeon"
    • MESA: 17.0.5-2

    In case it helps, I threw my terminal output of running the game and going into the Player Settings menu (where the bug is visible) on Fedora's built-in pastebin service. Side note, I do have to launch the game with '-opengl3' in my launch parameters, otherwise I get a segmentation fault.

    Hope it helps, and free to contact me (or request I email you), I'm glad to help however I can.


    Click image for larger version

Name:	Screenshot from 2017-05-08 21-34-38.png
Views:	3
Size:	704.1 KB
ID:	386500
    Attached Files

    #2
    It's not the same issue, I've even added a disclaimer on the pinned topic on how to upgrade mesa:
    /!\ Unfortunately, starting with the 2016 halloween build, it seems like Unreal Tournament isn't compatible with Pre-GCN hardware running on the open source driver anymore, as you can see here. So, unless something changes on the r600 driver, HD 6000 series cards and older will render the game incorrectly. (Or you can try to stick with an outdated linux distro and use the last catalyst driver from 2015)
    Sadly I can't test it anymore on my HD 6850 because I've already upgraded to an RX 470, but you can try the AMDGPU PRO driver to see if it works. Devs are pretty focused on RadeonSI at the moment so there wasn't so much activity on r600 since last year.
    uWarfare :: Website :: devART :: Italian UEd Community @ Exiles of UEd

    Comment


      #3
      Originally posted by SgtRenny View Post
      but you can try the AMDGPU PRO driver to see if it works
      Sadly according to the page it doesn't seem like it supports card this old. Guess I'll have to wait for a new system to be able to play it on Linux. I was just coming for a look anyways, so I guess I can boot the ol' Windows drive for a bit. Side question (if you happen to know), how does it work with Nvidia cards? It's even older, but I do have a 9800 GTX+ sitting in a drawer.

      Comment


        #4
        Well, the game was barely playable on my HD6850 so with a weaker architecture, 200MHz less and half the vRAM of your current card expect very poor performance assuming it will work.
        uWarfare :: Website :: devART :: Italian UEd Community @ Exiles of UEd

        Comment


          #5
          Originally posted by iBurley View Post
          Side question (if you happen to know), how does it work with Nvidia cards? It's even older, but I do have a 9800 GTX+ sitting in a drawer.
          The Legacy Nvidia drivers have the Disco Light Bug with UT4 and its not playable. I still don't know if it is Nvidia or Epic that is to blame. Have asked but no respond. I think either Epic or Nvidia can fix this bug if they wanted as it have been fixed in the none legacy drivers.
          Last edited by Eazy; 05-10-2017, 03:57 PM.

          Comment


            #6
            I guess we'll see when the linux build will start getting some love from the devs. Right now the most played Blitz map have serious rendering issues on linux (as you can see here) and it's impossible to play.

            But i think it's very unlikely for epic to open engine tickets for legacy drivers targeting cards with wich you'll not be able to play the game at decent framerates and the r600 guys seems to have put that driver in "maintenance mode" (it's getting new features only when they can copy-paste most of the code from RadeonSI or when their implementation is trivial, like the On-Disk Shader Cache).
            uWarfare :: Website :: devART :: Italian UEd Community @ Exiles of UEd

            Comment

            Working...
            X