Announcement

Collapse
No announcement yet.

Linux build 3436913 crashes with error message

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Linux build 3436913 crashes with error message

    I've just tried testing the latest build for Linux (UnrealTournament-Client-XAN-3436913-Linux) and the game fails to launch on Ubuntu 17.04.

    The message in the error modal reads:

    The game module 'UnrealTournament' could not be loaded. There may be an operating system error or the module may not be properly set up.
    I've tried running both:
    • /LinuxNoEditor/Engine/Binaries/Linux/UE4-Linux-Shipping
    • /LinuxNoEditor/Engine/Binaries/Linux/UE4-Linux-Test






    I've also tried removing the -SaveToUserDir and -opengl4 command-line arguments, to no effect.

    From the logs in folder: ~/Documents/UnrealTournament/Saved/Crashes/crashinfo-UnrealTournament-[some pid], I can see this suspicious entry:

    [...]
    LogInit: Display: Project file not found: /opt/games/UT4/LinuxNoEditor/UnrealTournament/UnrealTournament.uproject
    LogInit: Display: Attempting to find via project info helper.
    LogUProjectInfo: Found projects:
    [...]
    Could that be the root cause?

    I've searched for any .uproject files from the root installation folder, but there seem to be none around.
    In fairness, there seems to be none in the previous build I've tested either (UnrealTournament-Client-XAN-3395761-Linux, working for me).

    Once the modal is dismissed, the game delegates to the crash handler in the background, and stays idle with a black screen.

    Thanks for your help.

    Edit
    • I have tried adapting the recommendation from this similar post on Windows to Linux, but no luck
    • I have tried the older build once again: now it gives me the same error! Not sure what's going on, old build used to work for me

    Last edited by menajrl; 06-11-2017, 01:35 PM. Reason: removed bug prefix, this is not exactly a bug per se

    #2
    Resolved

    I should have looked at the logs in my home folder, instead of the application logs only.

    This line underlined an issue I could fix, in ~/Documents/UnrealTournament/UnrealTournament.log:

    LogLinux:Warning: dlopen failed: libgconf-2.so.4: cannot open shared object file: No such file or directory
    Installing the missing lib fixed the issue for me:

    sudo apt-get install libgconf2-4

    Comment

    Working...
    X