Announcement

Collapse
No announcement yet.

UT could not save profile with the MCP. Your settings may be lost.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [BUG] UT could not save profile with the MCP. Your settings may be lost.

    I have this bug with the latest version of UT (0.1.12, 3510431).
    When I make some change in the settings and click ok it says "UT could not save profile with the MCP. Your settings may be lost."

    I'm using ArchLinux x86_64.

    McpProfile::QueryProfile UE4-0A7458BD0XXXXX2FCA288D94D 0 ConnectionFailure - Connection to the server failed. ConnectionFailure

  • #2
    It also says: could not save progression with the MCP.

    Comment


    • #3
      Seems to be a problem with libcurl
      LogHttp:Warning: 0x7fd783b6b700: request failed, libcurl error: 27 (Out of memory)
      LogHttp:Warning: 0x7fd783b6af80: request failed, libcurl error: 27 (Out of memory)
      LogHttp:Warning: 0x7fd8241fcc00: request failed, libcurl error: 27 (Out of memory)
      LogHttp:Warning: Retry exhausted on https://ut-public-service-prod10.ol....me/v2/profile/myprofilenumber/client/QueryProfile?profileId=profile0&rvn=691
      LogProfileSys:Error: McpProfile::QueryProfile UE4-0899E853200707020036001210B3A787 0 ConnectionFailure - Connection to the server failed. ConnectionFailure
      LogProfileSys:Warning: OnQueryProfileComplete failed for Myalias accountId=myaccountId profileId=profile0 HTTP=0 ErrorCode=ConnectionFailure
      LogHttp:Warning: Retry 1 on https://entitlement-public-service-p...t/api/account/myaccountId/entitlements?namespace=ut
      LogHttp:Warning: Retry exhausted on https://ut-public-service-prod10.ol....dstorage/user/myaccountId/user_progression_1
      LogOnline:Warning: MCP: Invalid response. CorrId=UE4-044EBA1C140707020036025D10057D1D code=0 errorcode=ConnectionFailure errormessage=Connection to the server failed. errorraw=ConnectionFailure
      LogOnline:Warning: MCP: WriteUserFile request failed. Connection to the server failed.
      then any MCP request will fail the same way.
      LogOnline:Error: OSS: McpUtils request https://ut-public-service-prod10.ol....tings/account/myaccountId/mmrbulk failed. No Response

      Comment


      • #4
        Tried again a clean install of 0.1.12 with same result. It is retrieving profile infos as all settings and progresses are there but it can't save things.
        So, I reinstalled 0.1.11 which is saving progression but "New version available" windows is popping up every time. Is there a setting that we can add that can prevent it to show up? Even better but for further releases, could it be possible to add a "OK, remind me later" check box that would prevent it to pop up again till you close the game and would ask again at next start?

        Comment


        • #5
          Got same error, any fixes?

          Comment


          • #6
            This issue is still present in the 0.1.12.1 patch

            Comment


            • #7
              On Mageia x64, after a clean install of 0.1.12.1, it seemed to work in menu, at least, I didn't see messages.
              But right after checking my settings I started a CTF match against bots and it crashed after few mins apparently for same reason.
              Note that 0.1.12 was not crashing in this conditions but, for once, I think that it is a good thing since devs should have received detailed logs.
              If not, feel free to ask.

              Comment


              • #8
                It looks like I am getting the same errors as others did from day one of the July 2017 release.

                F24 on ASUS Z77 with i7-2600K, 16Gb ram, and GTX780Ti Classified

                I have the log entries;
                lots of the following Warnings and errors;
                [2017.09.28-01.08.13:945][774]LogHttp:Warning: 0x7ff04cdc9a00: request failed, libcurl error: 27 (Out of memory)Retry 2 on https://ut-public-service-prod10.ol....storage/system
                [2017.09.28-01.08.19:025][361]LogHttp:Warning: Retry 2 on https://entitlement-public-service-p...t/api/account/
                Last edited by Bobba_Novis; 09-28-2017, 12:14 PM.
                My Rig- ASUS Z68, core I7 2600K @4.6Ghz and GTX980 Ti WindForce G1 as seen on my VG248 @144Hz
                Weekly Warfare Matches every Fri-Sat Midnite-3:30am (US East Coast Time) GMT -5

                Comment


                • #9
                  For Arch Linux I installed libcurl-compat. Seems to be working. Made a few Player Settings changes: no error and changes remained after restart.
                  No one sees what tomorrow knows.

                  Comment


                  • #10
                    Fedora26 here,

                    Code:
                    dnf install curlpp
                    solved the issue...

                    upsss, after game restart same issue :/

                    [2017.09.30-20.12.54:294][510]LogHttp:Warning: 0x7f4e4812c400: request failed, libcurl error: 27 (Out of memory)

                    Last edited by eBosnic; 09-30-2017, 04:13 PM.

                    Comment


                    • #11
                      Yeah, I spoke too soon, also. After minor player changes seemed to work, I tried getting my 40th gold star (unlocks new skin: Samael - Blood Moon) by running Blitz-Fort challenge with all the crazy graphic glitches. After win, error reappeared.

                      Tried eBosnic's hint and installed libcurlpp from AUR: no go.

                      Another problem I noticed is that after a fresh start HUB/Server browser works. After anything causes MCP error, browser is empty.
                      No one sees what tomorrow knows.

                      Comment


                      • #12
                        darkskyabove, having exactly same issues, my hub wont work at all, and whole window is just freezed then I have to crtl+c it... :/

                        Comment


                        • #13
                          good to know i'm not the only one with these issues...
                          if i assume that we're all on other distro's with possibly other libcurl versions, i'd say a problem crawled into the UT release?
                          (running Solus with curl 7.56.1)

                          Comment


                          • #14
                            Still having the same issues, and i would like to test with an older release... but it seems they're nowhere to be found.

                            Comment


                            • #15
                              Found a sketchy workaround for some MCP issues.

                              1. If you plan to play online do not change any settings prior to opening HUB browser. Once I get the MCP error, the browser stays empty.
                              2. On a fresh launch I can usually make 1 or 2 settings changes w/o error. I'm still trying to dial in my sens (M570 trackball) and crosshair (probably sticking with Cross #1 ???: tiny plus sign 4 all weapons).
                              3. After a succesful change, I quit game and restart. This way changes are saved.

                              Still no luck getting my 40th challenge star. Finish Blitz in Fort with all the insane graphical glitches and it gives me the new skin (Samael - Blood Moon) followed by MCP error.

                              thutex: I run bleeding edge Arch (meaning I upgrade daily) and have the same curl version. It is possible that newer curl introduced regression(s); though I kinda doubt that due to the importance of curl on so many systems. Arch-Testing is a beast when it comes to systems analysis.
                              No one sees what tomorrow knows.

                              Comment

                              Working...
                              X