Announcement

Collapse
No announcement yet.

UT could not save profile with the MCP. Your settings may be lost.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by eBosnic View Post
    Fedora26 here,

    Code:
    dnf install curlpp
    solved the issue...

    upsss, after game restart same issue :/

    [2017.09.30-20.12.54:294][510]LogHttp:Warning: 0x7f4e4812c400: request failed, libcurl error: 27 (Out of memory)
    Same with F24x64. libcurl error
    Weekly Warfare Matches. We play every Fri and Sat 12:00 Midnight to 04:00 AM, US East Coast Time, GMT -5 hrs, EPIC North America Warfare #2

    Comment


      #17
      Originally posted by darkskyabove View Post
      Found a sketchy workaround for some MCP issues.

      1. If you plan to play online do not change any settings prior to opening HUB browser.

      thutex: I run bleeding edge Arch (meaning I upgrade daily) and have the same curl version. It is possible that newer curl introduced regression(s); though I kinda doubt that due to the importance of curl on so many systems. Arch-Testing is a beast when it comes to systems analysis.
      This worked for me.

      UT3 Warefare is still active. We play every Fri and Sat 12:00 Midnight to 04:00 AM, US East Coast Time, GMT -5 hrs, EPIC Warfare #2 or #3
      My Rigs - WIN7 - ASUS Z68, I7 2600K @4.6Ghz, 16Gb ram, GTX780Ti Classified, VG248 @144Hz
      - Fedora Linux - ASUS Z77, I7 2600K @4.6Ghz, 16Gb ram, GTX780Ti WindForce, VG248 @144Hz
      Weekly Warfare Matches. We play every Fri and Sat 12:00 Midnight to 04:00 AM, US East Coast Time, GMT -5 hrs, EPIC North America Warfare #2

      Comment


        #18
        I just ran into this problem on Ubuntu. For those who arrive here via Google, in the future, here is the solution for Ubuntu (and Mint, etc.):
        sudo apt-get install libcurlpp-dev
        (You might be able to get away with libcurlpp0 instead of libcurlpp-dev, if you don't want to install the development package.)

        Comment


          #19
          Disentropy That looks to be a downgrade to curl 7.3-5, which makes sense as the error started occuring after some curl upgrade (don't remember when). Current Arch is now at curl 7.61; along with Ubuntu cosmic (I assume that's Ubuntu's dev branch). With curl 7.61 I can still produce the error.

          My new sketchy workaround involves DL prior UT version (people smarter than me might have saved the prior version), make profile changes, quit, launch current UT. I didn't go through that 11GB DL (@10mbps) just to make profile changes; I did it to get my 40th challenge star by playing prior version with -opengl3 flag so that FR-Fort was playable and MCP saved my progress. Yee Haw!

          Another possible workaround is to make profile changes while logged in to an online game. I haven't fully tested this, but I recently achieved an XP level-up that unlocked a cosmetic while playing online. No MCP problem.
          No one sees what tomorrow knows.

          Comment


            #20
            same issue, curl packages i got:
            Code:
            curl-7.63.0_1          Client that groks URLs
            curlpp-0.8.1_1         C++ wrapper for libcURL
            libcurl-7.63.0_1       The multiprotocol file transfer library
            libcurl-devel-7.63.0_1 The multiprotocol file transfer library - development files

            Comment


              #21
              with current curl versions (see above) i have the "out of memory" problem (which btw isn't true, but a bug looking up the actual error message; see linked mailing list below), tried downgrading curl to 7.50 (since 7.35 doesn't even build on my system due to it still expecting the old libssl api), now i get errors like:
              Code:
              [2018.12.27-12.29.18:820][695]LogHttp:Warning: Retry 1 on https://entitlement-public-service-prod08.ol.epicgames.com/entitlement/api/account/14c17be08dd649ebbc4d778dd3f47db2/entitlements?namespace=ut
              [2018.12.27-12.29.18:850][697]LogHttp:Warning: 0x7ff2e9ddda80: request failed, libcurl error: 35 (SSL connect error)
              [2018.12.27-12.29.18:850][697]LogHttp:Warning: Retry exhausted on https://ut-public-service-prod10.ol.epicgames.com/ut/api/game/v2/ratings/account/14c17be08dd649ebbc4d778dd3f47db2/mmrbulk
              [2018.12.27-12.29.18:851][697]LogOnline:Error: OSS: McpUtils request https://ut-public-service-prod10.ol.epicgames.com/ut/api/game/v2/ratings/account/14c17be08dd649ebbc4d778dd3f47db2/mmrbulk failed. No Response

              interestingly both the exact same downgraded version as well as the newer version of the curl binary both connect to those api urls just fine (but then obviously get a authentication failure json response):
              Code:
              *   Trying 34.192.135.46...
              * TCP_NODELAY set
              * Connected to account-public-service-prod03.ol.epicgames.com (34.192.135.46) port 443 (#0)
              * ALPN, offering h2
              * ALPN, offering http/1.1
              * successfully set certificate verify locations:
              *   CAfile: /etc/ssl/certs/ca-certificates.crt
                CApath: none
              * TLSv1.2 (OUT), TLS handshake, Client hello (1):
              * TLSv1.2 (IN), TLS handshake, Server hello (2):
              * TLSv1.2 (IN), TLS handshake, Certificate (11):
              * TLSv1.2 (IN), TLS handshake, Server key exchange (12):
              * TLSv1.2 (IN), TLS handshake, Server finished (14):
              * TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
              * TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
              * TLSv1.2 (OUT), TLS handshake, Finished (20):
              * TLSv1.2 (IN), TLS change cipher, Change cipher spec (1):
              * TLSv1.2 (IN), TLS handshake, Finished (20):
              * SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
              * ALPN, server accepted to use h2
              * Server certificate:
              *  subject: CN=*.ol.epicgames.com
              *  start date: Mar 12 00:00:00 2018 GMT
              *  expire date: Apr 12 12:00:00 2019 GMT
              *  subjectAltName: host "account-public-service-prod03.ol.epicgames.com" matched cert's "*.ol.epicgames.com"
              *  issuer: C=US; O=Amazon; OU=Server CA 1B; CN=Amazon
              *  SSL certificate verify ok.
              * Using HTTP2, server supports multi-use
              * Connection state changed (HTTP/2 confirmed)
              * Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
              * Using Stream ID: 1 (easy handle 0x55a97751a400)
              > GET /account/api/oauth/verify?includePerms=true HTTP/2
              > Host: account-public-service-prod03.ol.epicgames.com
              > User-Agent: curl/7.63.0
              > Accept: */*
              >
              * Connection state changed (MAX_CONCURRENT_STREAMS == 128)!
              < HTTP/2 401
              < date: Thu, 27 Dec 2018 12:40:47 GMT
              < content-type: application/json
              < x-epic-error-code: 1032
              < x-epic-error-name: errors.com.epicgames.common.authentication.authentication_failed
              < x-epic-correlation-id: b8a163e6-c93f-4162-bf00-f611afb31e20
              <
              * Connection #0 to host account-public-service-prod03.ol.epicgames.com left intact
              {"errorCode":"errors.com.epicgames.common.authentication.authentication_failed","errorMessage":"Authentication failed for /api/oauth/verify","messageVars":["/api/oauth/verify"],"numericErrorCode":1032,"originatingService":"com.epicgames.account.public","intent":"unknown"}
              according to the curl mailing list (https://curl-library.cool.haxx.narki...f-memory-error) this is most likely an issue with the SSL options giving to curl failing in libssl which is then misinterpreted by curl as a "out of memory" error (because it fetches the wrong error message). so i guess the ssl settings provided to the curl request are just wrong/unsupported/etc or libssl was actually never initialized (see https://curl.haxx.se/mail/lib-2009-02/0042.html). so probably something dying around or before https://github.com/EpicGames/UnrealT...nager.cpp#L233


              for the record my runtime curl loginit is:
              Code:
              LogInit: Using libcurl 7.48.0-DEV
              LogInit:  - built for x86_64-unknown-linux-gnu
              LogInit:  - supports SSL with OpenSSL/1.0.2h
              LogInit:  - supports HTTP deflate (compression) using libz 1.2.8
              LogInit:  - other features:
              LogInit:      CURL_VERSION_SSL
              LogInit:      CURL_VERSION_LIBZ
              LogInit:      CURL_VERSION_IPV6
              LogInit:      CURL_VERSION_ASYNCHDNS
              LogInit:      CURL_VERSION_LARGEFILE
              LogInit:      CURL_VERSION_TLSAUTH_SRP
              LogInit:  Libcurl: checking if '/etc/pki/tls/certs/ca-bundle.crt' exists
              LogInit:  Libcurl: checking if '/etc/ssl/certs/ca-certificates.crt' exists
              LogInit:  CurlRequestOptions (configurable via config and command line):
              LogInit:  - bVerifyPeer = true  - Libcurl will verify peer certificate
              LogInit:  - bUseHttpProxy = false  - Libcurl will NOT use HTTP proxy
              LogInit:  - bDontReuseConnections = false  - Libcurl will reuse connections
              LogInit:  - CertBundlePath = /etc/ssl/certs/ca-certificates.crt  - Libcurl will set CURLOPT_CAINFO to it
              LogOnlineGame:Display: MCP CONFIG: Selected Dev backend in Prod environment, based on passed override ""
              note how the libcurl version reported (7.48) is completely different from both my current (7.63) and temporarily downgraded (7.50) version. i smell an api change between the included header and library, so maybe matching libcurl+libssl versions should be provided in the 3rd party folders?

              even building that exact version and providing it with LD_LIBRARY_PATH and LD_PRELOAD (for good measure :P) did just result in "libcurl error 35 (SSL connect error)". so i guess that's before the api change that broke the error detection and made it look like an out of memory, but still broken ssl settings and/or uninitialized libssl.

              since it's the only option to curl i seem to be able to influence i tried -ExecCmds="n.VerifyPeer 0", which didn't change anything (not even the "bVerifyPeer" value in loginit)
              Last edited by nonchip; 12-29-2018, 09:05 AM.

              Comment


                #22
                ابغا سيرفر خاص على هذا الحساب tsmibra6@gmail.com

                Comment

                Working...
                X