Announcement

Collapse
No announcement yet.

Graphic Issue - ShowFlag.SkyLighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Graphic Issue - ShowFlag.SkyLighting

    Here's a major issue, should be well known by the Linux guys. It occours, if you have Nvidia drivers 340 or higher, if i recall correctly.

    Summary:

    "ShowFlag.SkyLighting 1" (Standard Setting) introduces rainbow colored lighting / breaks visibility completely

    Version:
    October 03, 2014: XAN-2318482-Linux
    October 10, 2014: XAN-2324838-Linux
    October 16, 2014: XAN-2330705-Linux


    Description:
    The lighting effects, which are in the console called "ShowFlag.SkyLighting" break the gameplay in terms of visibility completely. It depends mostly on the lighting conditions on the map, on Focus you get mostly rainbow colored surfaces. If you start NickTest for example, you can see almost nothing besides white and some bright bloomy colors, there it breaks the visibility completely.
    The known workaround is to open console and type: ShowFlag.SkyLighting 0

    Steps to Repro:
    1. Start the game and play a map
    2. Should see it now

    Attachments:
    Youtube Video:
    Last edited by Kurozumi; 10-24-2014, 08:16 AM. Reason: added Video
    OS: Arch Linux / Kernel: 4.0.5-1 / Graphics: Nvidia 352.09-1 / Audio: Alsa 1.0.29-1

    #2
    Yes, and it's an issue in NVIDIA drivers only. Best solution would be for someone from Epic to contact NVIDIA and tell them to fix their drivers
    Unreal Tournament 4 eXpanded MultiPlayer (UT4XMP) efforts
    My website, listing all my Unreal series mods and mutators

    Comment


      #3
      Driver version: 343.22-4

      Bug is still in there.

      Comment


        #4
        I think they are already on to it (according to RCL on IRC). In my opinion best thing would be actually to complain to NVIDIA personally to make them aware their customers care about this isuse.
        UTLauncher - standalone Unreal Tournament server browser / Download / Github
        ut.rushbase.net - free community hosting for Unreal Tournament assets

        Comment


          #5
          That's nice to hear, i added a Youtube video for the problem, too
          OS: Arch Linux / Kernel: 4.0.5-1 / Graphics: Nvidia 352.09-1 / Audio: Alsa 1.0.29-1

          Comment


            #6
            This bug seems officially fixed. Updated the graphics drivers to 343.36, released on 2014.12.05.
            Quote Nvidia: "Fixed a bug that rendered very bright garbage data onto some textures in UnrealEngine 4 applications. This issue is known as the "disco bug" by the UnrealEngine 4 Linux community."

            So check your repositories for the newer Nvidia drivers, worked for me !
            OS: Arch Linux / Kernel: 4.0.5-1 / Graphics: Nvidia 352.09-1 / Audio: Alsa 1.0.29-1

            Comment


              #7
              Originally posted by Kurozumi View Post
              This bug seems officially fixed. Updated the graphics drivers to 343.36, released on 2014.12.05.
              Quote Nvidia: "Fixed a bug that rendered very bright garbage data onto some textures in UnrealEngine 4 applications. This issue is known as the "disco bug" by the UnrealEngine 4 Linux community."

              So check your repositories for the newer Nvidia drivers, worked for me !
              n1... \o/ wohoooo! i party this very hard!

              Comment


                #8
                confirmed fixed. same driver version, arch linux.

                Comment


                  #9

                  Comment


                    #10
                    Hm, nice, but I hope this will get backported to the 340 branch as well.
                    Unreal Tournament 4 eXpanded MultiPlayer (UT4XMP) efforts
                    My website, listing all my Unreal series mods and mutators

                    Comment


                      #11
                      Is there a temporary fix for this I could use. Have a Geforce 250GTS (Legacy) and the latest driver I can find is 340.76.

                      Edit. Trided with "ShowFlag.SkyLighting 0" in console, but it shows really weird colors on walls etc. Seems there is always something that hinders me to play UT4 on linux. Might be time to give this up.

                      GG
                      Last edited by Eazy; 03-11-2015, 11:39 AM.

                      Comment


                        #12
                        Has this disco bug been fixed, or are people with Nvidia legacy graphic card excluded to play this game on Linux?

                        Perhaps the performance requirement is to high for a Nvidia 250gts to play this game anyway?

                        Comment

                        Working...
                        X