Announcement

Collapse
No announcement yet.

sudo: ./UE4: command not found

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    sudo: ./UE4: command not found

    Hi everyone!

    Since the last update I cannot start UT4 on Linux.
    It downloaded the newest zip-file "UnrealTournament-Client-XAN-2504664-Linux.zip" and unzipped it.
    Before the new release it worked fine for me. The previous version still works for me.

    I started the game like I did before:
    cd /home/giantanteater/Downloads/LinuxNoEditor/Engine/Binaries/Linux/
    ./UE4 UnrealTournament

    The first time it told me there are not enough permissions to do this.
    So I did sudo:
    sudo ./UE4 UnrealTournament

    As result I only get this message:
    sudo: ./UE4: command not found

    I logged the error with ltrace and strace into a file:
    ltrace http://pastebin.com/wVNJLqV5
    strace http://pastebin.com/Q4dpBQGi

    System + Hardware specs:
    :~$ lsb_release --all
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 14.04.2 LTS
    Release: 14.04
    Codename: trusty

    Mainboard: Z77A-G45 (MS-7752)
    RAM: 2x 4GiB DIMM DDR3 Synchron 1600 MHz (0,6 ns)
    CPU: Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz
    GPU: GK106 [GeForce GTX 660]
    GPU-DRIVER: NVIDIA binary driver-version 331.113 (tested)
    SOUND: Asus Xonar DGX - CMI8788 [Oxygen HD Audio]
    SSD: 250GB Samsung SSD 850 EVO



    Can anyone help me to start the UT4?

    #2
    Before I opened this topic, I searched a lot in the web and tried some commands and possibilities.
    It would be helpful for me, if anyone could give me an idea what could cause this problem.

    Comment


      #3
      Originally posted by darkskyabove
      Looks like the file /home/giantanteater/Downloads/LinuxNoEditor/Engine/Binaries/Linux/UE4 does not have execute permission.

      Try: chmod +x
      /home/giantanteater/Downloads/LinuxNoEditor/Engine/Binaries/Linux/UE4

      It's pretty standard for linux binaries to not have execute permission as default. When you install from the package manager (apt-get for Ubuntu?), this step is done for you.

      I would suggest being more careful with sudo. It's usually reserved for tasks that require root privilege. Files that you have in your home directory should be owned by your user and never require root privilege.
      That's all what was necessary, so simple and easy. Thank you very much!
      (I moved to Linux two weeks ago)

      Comment

      Working...
      X