Announcement

Collapse
No announcement yet.

How to optimize FPS on mac

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to optimize FPS on mac

    Im running a Mac Book Air 13in mid 2012

    1.8 ghz intel core i5

    4 gb 1600 MHz DDR3

    Intel hd graphics 4000 1536

    The game is playable for me but when the action picks up the games framerate dips considerably, so I've been trying to optimize the games fps so that it is playable for me on higher levels.

    I found this http://merchantmonarchy.blogspot.com...imization.html

    but many of the commands do not work in the ingame console, I'm on mac so I don't have a game.ini folder, and some of the other aforementioned folders.

    Where can I find the config file on mac?

    #2
    That's a really week card mate, it's an integrated one and I doubt that it can run the game properly without drops...

    Comment


      #3
      That's my blog post you linked. The game has changed a lot since then, if I still had that same system today the game would play even worse on it now. I do have the same graphics card in my second computer now but with a better CPU (X4 B93 with mild OC to 3.08Ghz) and it barely gets 35 FPS average(with no ini tweaks that is). That's a very weak card for UT4 but still better than HD 4000 integrated graphics.

      Game.ini is not a folder, it's a file in your game's config folder. But the vast majority of ini tweaks go in Engine.ini not Game.ini. Also Mac support lags far behind PC support, a lot of things that work on PC (including some config settings) don't work on Mac yet.
      Last edited by MoxNix; 10-16-2015, 04:41 PM.

      Comment


        #4
        Hey just updating you guys I have some settings that make the game play super smooth even on my system.

        resolution 904x546 windowed, I can play smooth up to about 1280x720, then it starts to hurt a little.
        frame rate cap at 250 and smooth frame rate. <--- i initially had smooth framerate off and it would cause the framerate to be a LOT worse. this helped out alot.

        i also use r.simpledynamiclighting 1 if i still have issues but its usually solid. accept on outpost 23. that stage hurts my fps.
        i wanted to mention that I hope unreal keeps some of these test stages because there softer on my computer and fps.

        I also have the game scaled down to about 65% with all light and special effects unclicked and set to off in graphics settings (show advanced options)

        I had to deal with some mouse smoothing issues as well but eventually worked out some kinks.

        so far the game is solid on my less then optimal parts with these settings.

        **P.s. also changing your FOV may help as well mine is at 105.
        Last edited by The Jedi; 10-16-2015, 03:37 PM.

        Comment

        Working...
        X