Announcement

Collapse
No announcement yet.

Constant Strafing Left

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Constant Strafing Left

    I was a huge fan of the original UT and just found out about this project. Unfortunately, when I try to play it I am stuck strafing left and the mouse sometimes disappears completely.

    Can this be fixed? I'm presumably running the latest version since I downloaded it last night. Could this be because I have dual displays?

    #2
    Do you happen to be running anything in the background while playing the game?

    Comment


      #3
      check to see if your gamepad is connected. eg a stick or pad is being pressed
      UT40K:The Chosen - Warhammer 40,000 for UE4
      ut40kgeodav - UE4 Tutorials

      Comment


        #4
        Originally posted by [EPIC] Wombo View Post
        Do you happen to be running anything in the background while playing the game?
        Mail, Firefox, Messages, iTerm

        Originally posted by Geodav View Post
        check to see if your gamepad is connected. eg a stick or pad is being pressed
        I have a gamepad connected, but there's nothing pushing on any of its buttons.

        Comment


          #5
          from past experience this effect has been caused by gamepad/joystick/steeringwheel, just try disconnecting them and have another go.

          i'm not a mac user but this sort of thing has happenen a lot with game pads since UE started to support them.

          could be another type of input device that might be causing it
          UT40K:The Chosen - Warhammer 40,000 for UE4
          ut40kgeodav - UE4 Tutorials

          Comment


            #6
            Thanks. Unplugging the gamepad worked. Is there perhaps a workaround that would not require me to unplug it every time I want to play?

            Comment


              #7
              not that i know of, i'd suggest double checking the pad or test with a different one, might just be a sticky switch/stick/pad
              UT40K:The Chosen - Warhammer 40,000 for UE4
              ut40kgeodav - UE4 Tutorials

              Comment


                #8
                Originally posted by hqahtani View Post
                Thanks. Unplugging the gamepad worked. Is there perhaps a workaround that would not require me to unplug it every time I want to play?
                Calibrate the gamepad (if it's analog) and place the gamepade anywhere the sticks are not moved.
                ] Map Scaler Tool | Betrayal for UT4 | No Spawn Protection | No Pickup Timer | BioLauncher (revived) | ForcePickupSpawn | Map cosmetics::P | Safe Spawn::P | Why numbers for Health/Armor suck!::ANALYSIS/CONCEPT
                ] UT3 Addons: NoMoreDemoGuy | PickupRespawnTweak | Mutate Spec | MutePawnSounds | NoPlayerBeacon | Epic FTW | Epic FOCK | TripodSound (... and many more)

                Comment


                  #9
                  This is weird. I grabbed an app called Joystick Show to try and figure out what's going on, since the gamepad works with the emulators I tend to use. The gamepad has no analog controls, just a d-pad that moves up/down and left/right (no diagonals). Axis 3 is left/right and axis 4 is up/down. There are no buttons to correspond with axes 0–2, yet axis 0 seems to be engaged.

                  Attached Files

                  Comment


                    #10
                    Some non-analog gamepads also need to be calibrated. It is the same if you press a button/D-Pad-direction and connect the gamepad to the computer. The then received values from the gamepad (whether it is sent to polled), are used as "default"/zero values. Releasing the button would then add the difference to the resulting output. In your case, you can see Axis 0 is pressed (-1). Not sure if there is a generic calibration tool (shipped) on Mac (/the OS on your Mac).
                    ] Map Scaler Tool | Betrayal for UT4 | No Spawn Protection | No Pickup Timer | BioLauncher (revived) | ForcePickupSpawn | Map cosmetics::P | Safe Spawn::P | Why numbers for Health/Armor suck!::ANALYSIS/CONCEPT
                    ] UT3 Addons: NoMoreDemoGuy | PickupRespawnTweak | Mutate Spec | MutePawnSounds | NoPlayerBeacon | Epic FTW | Epic FOCK | TripodSound (... and many more)

                    Comment


                      #11
                      I've had this happen several times as well. Haven't noticed anything in particular that causes it. If you hit the escape key twice (once to pause the game and again to unpause it), the strafing stops.

                      In my case, there is a wired keyboard and wired mouse plugged in but no controllers or keypads, etc. The only programs besides the game are the Epic Launcher, Little Snitch, Dash, Yojimbo, Boinc manager (Boinc manages Seti@home and is set to suspend Seti when UT4 is running), and an instance of tail that was ssh'd in from another computer that is displaying the log file.

                      Mac Pro 8-core Xeon E5, 64GB, 2xAMD D700 6GB - El Capitan 10.11.3

                      Comment


                        #12
                        Originally posted by nerd3 View Post
                        If you hit the escape key twice (once to pause the game and again to unpause it), the strafing stops.
                        I'll try that soon and see how it works.

                        Mac Pro 8-core Xeon E5, 64GB, 2xAMD D700 6GB - El Capitan 10.11.3
                        Drool.

                        I was playing Counter-Strike Global Offensive and Team Fortress 2 last night with no problems, along with VICE (a Commodore 64 emulator). I also have no problems playing the PC version of UT2K using CrossOver.

                        Comment


                          #13
                          "If you hit the escape key twice (once to pause the game and again to unpause it), the strafing stops."

                          This doesn't work as well as I thought. The strafing does stop but sometimes it starts doing it again first time you hit any movement key. Could be that whatever condition was triggering it in the first place hadn't been cleared.

                          This time when I quit the game (and the launcher) and then restarted it, the strafing problem was gone.

                          Comment


                            #14
                            I downloaded the latest update last night and tried what you suggested, although it did not have an effect.

                            Comment


                              #15
                              Interesting, it still works for me (other than that one time in my post above). Are you sure you used the escape key and not the tilde key? If you used the tilde to get to the console, the strafing will resume as soon as you go back to the game. The escape key gets you to the menus (don't know the official term, I think of it as the pause key). When the strafing starts, I hit escape, wait about a second, and hit it again.

                              Comment

                              Working...
                              X