Announcement

Collapse
No announcement yet.

Low FPS, Crashes, Bad Mouse Tracking and unplayable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG] Low FPS, Crashes, Bad Mouse Tracking and unplayable

    Are there going to be any Mac fixes in the near future? 10fps, crashing, mouse pointer accuracy/tracking is still messed up. When I was running win 7 on my mac, UT played like a dream. I just wish it would play well on my mac OS Then I wouldn't have to stress out about trying to get Windows to work via my boot camp + I hate Win 10. Other games designed for mac seem to run very well on my system.

    Aiming is still impossible, the low fps obviously effect game play + the random crashes are annoying. I know you guys are working hard on the windows side of it, and that's great, but I would love to be able to play it on my imac too. I'm running El-Capitan and my specs are in my sig.
    Win 10
    iMac (27-inch, Late 2013)
    3.5 GHz Intel Core i7
    32 GB 1600 MHz DDR3
    NVIDIA GeForce GTX 780M 4096 MB

    Maps:
    DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
    2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

    #2
    Hi Effects,

    We are aware of the Unreal Tournament issues with Mac. We have engine programmers working on Mac metal support, which should provide substantial performance improvements. We aren't sure yet when these will make it into UT, but we'll keep the community in the loop. Sorry for the troubles.
    Stacey Conley
    -----------------------------
    Unreal Tournament Community Manager
    Epic Games, Inc.
    Twitter | Twitch | Facebook | Instagram | YouTube | Pinterest

    Comment


      #3
      Thanks for the reply.

      I guess I will just wait then.


      Originally posted by Flak View Post
      Hi Effects,

      We are aware of the Unreal Tournament issues with Mac. We have engine programmers working on Mac metal support, which should provide substantial performance improvements. We aren't sure yet when these will make it into UT, but we'll keep the community in the loop. Sorry for the troubles.
      Win 10
      iMac (27-inch, Late 2013)
      3.5 GHz Intel Core i7
      32 GB 1600 MHz DDR3
      NVIDIA GeForce GTX 780M 4096 MB

      Maps:
      DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
      2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

      Comment


        #4
        Did you notice the performance drop with the new builds with UE4.11?

        Someone I play with uses Mac, I'll query them about their setup. I have a feeling they are using Win7 bootcamp, but I'll check.

        Ideally playing native would be great.
        Another crazy idea brought to you by richardboegli ;P

        Comment


          #5
          Yeah the performance drop on both my mac and my windows boot was so bad after the latest builds, I have had to just quit playing

          Originally posted by richardboegli View Post
          Did you notice the performance drop with the new builds with UE4.11?

          Someone I play with uses Mac, I'll query them about their setup. I have a feeling they are using Win7 bootcamp, but I'll check.

          Ideally playing native would be great.
          Win 10
          iMac (27-inch, Late 2013)
          3.5 GHz Intel Core i7
          32 GB 1600 MHz DDR3
          NVIDIA GeForce GTX 780M 4096 MB

          Maps:
          DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
          2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

          Comment


            #6
            Originally posted by effects69 View Post
            Yeah the performance drop on both my mac and my windows boot was so bad after the latest builds, I have had to just quit playing
            Something seems very wrong.

            I could understand Mac side, but on Windows side, you should still be getting reasonable performance even though it will probably be reduced. It shouldn't have reduced this much.

            What were you getting in previous UE4.8 builds ? ie: What was FPS, resolution and detail settings?

            My first suspicion is that maybe your Nvidia card is not being used and it is defaulting to an onboard card?

            I'm not too familiar with iMacs and their construction, but considering it is a 780M, it makes me think that it has another graphics card just like laptops. Its called Optimus Technology by Nvidia.

            The Nvidia control panel tool has the option, just force it to always use Nvidia card.

            Good luck.
            Another crazy idea brought to you by richardboegli ;P

            Comment


              #7
              I'm not sure if it has an on-board card too, I will have to look into that.

              As far as settings, I'm using the same settings I always have, I even tried lowering everything and it made no difference,

              I have 85 % screen percentage, 90 FOV, Everything low apart from textures set to high, highest screen resolution.

              My avrg FPS were about 120 uncapped before the last few builds, now it dips between 60 and 20 on windows and between 30 and 10 on the mac OS (even when capped at 60fps)

              I updated to all the latest graphics drivers and it didn't make any difference. I'm running Windows 10 Home and EL-Capitan.


              Originally posted by richardboegli View Post
              Something seems very wrong.

              I could understand Mac side, but on Windows side, you should still be getting reasonable performance even though it will probably be reduced. It shouldn't have reduced this much.

              What were you getting in previous UE4.8 builds ? ie: What was FPS, resolution and detail settings?

              My first suspicion is that maybe your Nvidia card is not being used and it is defaulting to an onboard card?

              I'm not too familiar with iMacs and their construction, but considering it is a 780M, it makes me think that it has another graphics card just like laptops. Its called Optimus Technology by Nvidia.

              The Nvidia control panel tool has the option, just force it to always use Nvidia card.

              Good luck.
              Win 10
              iMac (27-inch, Late 2013)
              3.5 GHz Intel Core i7
              32 GB 1600 MHz DDR3
              NVIDIA GeForce GTX 780M 4096 MB

              Maps:
              DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
              2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

              Comment


                #8
                Originally posted by effects69 View Post
                I'm not sure if it has an on-board card too, I will have to look into that.

                As far as settings, I'm using the same settings I always have, I even tried lowering everything and it made no difference,

                I have 85 % screen percentage, 90 FOV, Everything low apart from textures set to high, highest screen resolution.

                My avrg FPS were about 120 uncapped before the last few builds, now it dips between 60 and 20 on windows and between 30 and 10 on the mac OS (even when capped at 60fps)

                I updated to all the latest graphics drivers and it didn't make any difference. I'm running Windows 10 Home and EL-Capitan.
                OK, I think I have the answer HOPEFULLY

                I was just about to hit send on my response (Original Response below), when I it hit me as to what the issue probably is, as it is affecting you in BOTH operating systems, not just one.

                Please disable your sound card in both operating systems. I believe this will fix your FPS issue immediately.

                A few people have had a similar issue with this new version, you described it as Low FPS and Bad Mouse Tracking which is equivalent to STUTTERING.

                Thread: Game freezes temporarily during gameplay, makes it unplayable
                Thread: Game Randomly Freezes Every 10 Seconds Or So
                Thread: Game freezes after update

                As you will have no sound now, either use a Bluetooth headphones / speakers or USB speakers. I don't know if you can install a new soundcard in an iMac?? But that should work too.

                Credit goes to [MENTION=5800]Megasporwic[/MENTION] for diagnosing the issue of disabling soundcard and replacing with another soundcard.

                I suggested [MENTION=253173]uradorable[/MENTION] try Bluetooth headphones and they tried wireless bluetooth speakers which worked.

                If this doesn't work, see my original response:

                Original Response:
                It really does sound like the reason is it is using an alternate video card.
                This would be what I would hunt down and verify ASAP as I honestly believe this is the issue.

                What other graphic intensive games do you play?
                Another crazy idea brought to you by richardboegli ;P

                Comment


                  #9
                  Neither ideas work :P

                  I will just wait it out until the game is Mac ready, I hardly have any free time anyway.
                  Win 10
                  iMac (27-inch, Late 2013)
                  3.5 GHz Intel Core i7
                  32 GB 1600 MHz DDR3
                  NVIDIA GeForce GTX 780M 4096 MB

                  Maps:
                  DM-RadioActive (Work In progress) DM-Ethos (WIP) DM-QWERTY (WIP) DM-TwinFalls(WIP)
                  2k4 DM-MoonGames, DM-Abrenabba, DM-Aphelion, DM-Pyrimid-Of-Gold, DM-UPH-Hexed, Dm-Saint, DM-LethalAdixion, DM-C4-Ariza, Dm-C4-SleepyTomb,

                  Comment


                    #10
                    Originally posted by effects69 View Post
                    Neither ideas work :P

                    I will just wait it out until the game is Mac ready, I hardly have any free time anyway.


                    (plus 10 sad smilies)
                    Unreal Carnage.com UT4 Maps: DM-Maelstrom DM-SpaceNoxx

                    Comment


                      #11
                      Originally posted by effects69 View Post
                      Neither ideas work :P

                      I will just wait it out until the game is Mac ready, I hardly have any free time anyway.
                      ****
                      Another crazy idea brought to you by richardboegli ;P

                      Comment


                        #12
                        excited to find this but bot matches and particularly online its unplayable. doing the early training maps all run smoothly. Changing resolution doesnt seem to do much as it all stays pretty fuzzy
                        looking forward to seeing this become more refined

                        Comment


                          #13
                          new update still running jerkily, aiming really difficult regardless of settings and my machine should easily handle it, Mac Pro 2.7 GHz 12 core Xeon E5, 64GB 1866 DDR3, dual AMD FirePro D700 6144

                          Comment


                            #14
                            Originally posted by MikeHuntUK View Post
                            new update still running jerkily, aiming really difficult regardless of settings and my machine should easily handle it, Mac Pro 2.7 GHz 12 core Xeon E5, 64GB 1866 DDR3, dual AMD FirePro D700 6144
                            It could be video card or sound card related. Not sure how to fix video, but try disabling / removing drivers for sound card....not sure how to do that on a Mac. Unless you are running Windows then just go into device manager and disable the sound card.

                            Let me know how you go.
                            Another crazy idea brought to you by richardboegli ;P

                            Comment


                              #15
                              Originally posted by richardboegli View Post
                              It could be video card or sound card related. Not sure how to fix video, but try disabling / removing drivers for sound card....not sure how to do that on a Mac. Unless you are running Windows then just go into device manager and disable the sound card.

                              Let me know how you go.

                              you cant really remove the gfx card drivers, i'll try turning the sound card off in the midi settings but macs dont work in the same way as a windows machine.

                              Comment

                              Working...
                              X