Announcement

Collapse
No announcement yet.

Trying UT on a 5K iMac

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    I haven't tried that, but I do have more information. Because of the hardware I use I play in windowed mode instead of full screen, and I noticed that if I leave (or maybe click) the mouse in the blank game window area as it's starting it doesn't crash. I also can't move the mouse out of the game window like I could before, but the game doesn't crash. I haven't done exhaustive testing yet, but it seems like the problem is related to windowed mode and possibly the mouse. I'll try to quantify things a little more and post back here.

    UPDATE: Immediately closing the Launcher while the game is starting does not help. The thing that does seem to prevent the crash is clicking the blank game window just after it appears (which takes quite a while). This is while that window is still completely black, since the crash happens before any graphics or other controls appear in that window. Just leaving the mouse in the area of the screen where the game window appears is not sufficient - I have to actually click somewhere in the window.

    Now if I could just figure out why the game seems to ignore most of my primary (left) mouse button clicks I'd be much happier...
    Last edited by OFSG; 02-07-2016, 06:43 PM. Reason: Update on crash symptoms

    Comment


      #32
      Originally posted by linoleumbnprt View Post
      Hey PHOSPHENE,

      Since you have a Radeon R9 series graphics card, there have been issues with the last couple driver releases that cause major crashes in UE4 games. The current workaround is to set Shadows to Low in your graphics settings. It might be a while before you get updated drivers for your card since I believe Apple includes all hardware driver updates in their OS updates. Let me know if that helps.

      Shadows have been on "low" the whole time.

      1600x900 full screen
      vsync = off
      frame rate cap = 200
      smooth framerate = off

      screen % = 50
      texture detail = low
      shadow quality = low
      effects quality = medium
      anti aliasing = none. Although it defaults to FXAA, which doesnt seem to affect FPS.
      decal life = 30 seconds

      Prior to Nov 19, those settings were playable for me. Maxing out at 200fps, and rarely dropping below 100fps.


      Bootcamp Drivers...
      Boot Camp Support Software 4.0.4326 https://support.apple.com/kb/DL1636?locale=en_US
      Boot Camp Support Software 5.1.5621 https://support.apple.com/kb/DL1720?locale=en_US
      Boot Camp requirements by Mac model https://support.apple.com/en-us/HT205016



      When I play in OSX windowed mode, it crashes less often. But it looks like ****, and theres tons of mouse lag. I just play on the windows/bootcamp partition.

      Comment


        #33
        Originally posted by OFSG View Post
        I haven't tried that, but I do have more information. Because of the hardware I use I play in windowed mode instead of full screen, and I noticed that if I leave (or maybe click) the mouse in the blank game window area as it's starting it doesn't crash. I also can't move the mouse out of the game window like I could before, but the game doesn't crash. I haven't done exhaustive testing yet, but it seems like the problem is related to windowed mode and possibly the mouse. I'll try to quantify things a little more and post back here.

        UPDATE: Immediately closing the Launcher while the game is starting does not help. The thing that does seem to prevent the crash is clicking the blank game window just after it appears (which takes quite a while). This is while that window is still completely black, since the crash happens before any graphics or other controls appear in that window. Just leaving the mouse in the area of the screen where the game window appears is not sufficient - I have to actually click somewhere in the window.

        Now if I could just figure out why the game seems to ignore most of my primary (left) mouse button clicks I'd be much happier...
        From the callstack you've found a bug in the ShaderCache which is causing a null pointer error - if you can provide the ShaderCache files we can find out why. They should be located at: ~/Documents/UnrealTournament/Saved

        Comment


          #34
          Originally posted by WhiteGumby View Post
          Windows logs are within the Documents\unrealtournament\Saved\Logs directory.
          OSX logs should be within Library>Logs>UnrealTournament. Also check within Library>Logs>UnrealTournament>DiagnosticReports for crash log.

          Thanks,
          WhiteGumby
          UT's own crash reporting places its logs in: ~/Library/Application Support/Epic/UnrealTournament/4.11/Saved/Crashes
          OS X's internal crash reporter will be in ~/Library/Logs/UnrealTournament/DiagnosticReports but I don't expect you'll find much there for UT.

          Comment


            #35
            Originally posted by OFSG View Post
            I haven't tried that, but I do have more information. Because of the hardware I use I play in windowed mode instead of full screen, and I noticed that if I leave (or maybe click) the mouse in the blank game window area as it's starting it doesn't crash. I also can't move the mouse out of the game window like I could before, but the game doesn't crash. I haven't done exhaustive testing yet, but it seems like the problem is related to windowed mode and possibly the mouse. I'll try to quantify things a little more and post back here.

            UPDATE: Immediately closing the Launcher while the game is starting does not help. The thing that does seem to prevent the crash is clicking the blank game window just after it appears (which takes quite a while). This is while that window is still completely black, since the crash happens before any graphics or other controls appear in that window. Just leaving the mouse in the area of the screen where the game window appears is not sufficient - I have to actually click somewhere in the window.

            Now if I could just figure out why the game seems to ignore most of my primary (left) mouse button clicks I'd be much happier...
            No need to supply the ShaderCache - I have the same problem reproduced on my 2012 MacBook Pro so I can debug it from here. I'll try and get it fixed for the next release!

            Comment


              #36
              Thanks pitbull! You're my Hero of the Day!

              Comment


                #37
                I wrote a blog post about running UT4 in macOS High Sierra on an iMac 5k – including how to show the FPS counter (good for validating the graphics performance tunings) and disabling the broken Tutorial Videos:

                https://swissmacuser.ch/best-graphics-settings-for-unrealtournament4-on-imac5k-highsierra/

                Would love to have it challenged or for any other suggestions regarding running Unreal Tournament – as best as possible – on macOS

                Cheers,
                Oliver

                Comment

                Working...
                X