Announcement

Collapse
No announcement yet.

Graphic quality drastically changed in the editor.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG] Graphic quality drastically changed in the editor.

    Hello,
    in those weeks I was experimenting with the editor, making a map with a sunset skybox. Then, yesterday I had to update the program, as well as the game. At the first startup, I noticed a drastic change in terms of quality, even though the Scalabity Settings are all set on Epic! My sunset is now OVER SATURATED. I don't know what actually happened.



    Then I also noticed other two strange things. Now, key bindings are totally different from the ones in the game, as well as HUD settings. Then, during the first startup, on bottom-right there was a message telling me 10k+ shaders were loading...



    Thanks for reading and I hope someone helps me!



    EDIT: I created a .pak file of the map and I played it in game. The skybox was not saturated and everything was fine. Then I started to do some tests in the game, scaling the graphic options. I noticed disabling the Tonemapper Film was the problem; as a matter of fact, everything became over saturated! So, I think the problem is how to activate Tonemapper Film in the editor's viewport.
    Attached Files
    Last edited by rapfamily4; 10-19-2016, 01:24 PM.

    -Luigi Rapetta
    (rapfamily4)

    My projects list:
    Unreal Monsters | Armor Pickups | Dispersion Pistol for Invasion | Fusion Cannon - a Flak Cannon variant

    #2
    [MENTION=247414]rapfamily4[/MENTION] I moved this thread into the correct section so I'll delete the other one.
    "Yeah. _Lynx can fire the lightning gun, have the lightning bolt turn a 90 degree corner, stop and ask the closest teammate for directions, confuse the directions and get lost, realize it went the wrong way, make a U-Turn, and get a headshot on the intended target."
    - RenegadeRetard

    Comment


      #3
      [MENTION=5909]_Lynx[/MENTION]

      Thanks!

      -Luigi Rapetta
      (rapfamily4)

      My projects list:
      Unreal Monsters | Armor Pickups | Dispersion Pistol for Invasion | Fusion Cannon - a Flak Cannon variant

      Comment


        #4
        I have noticed this, too with the new update. Not sure if it was from UE4.13 or 4.14 since both seems to have been applied. But searching through the engine forums doesn't seem to point in any direction.

        There is definitely a disconnect between the lighting in the editor and in game since updating. I'm trying to sort it out on my end but haven't been able to.
        MyArtstation
        @jayoplus

        Comment


          #5
          I've seen the LD guys in Discord mention the tone-mapper as well.
          "Yeah. _Lynx can fire the lightning gun, have the lightning bolt turn a 90 degree corner, stop and ask the closest teammate for directions, confuse the directions and get lost, realize it went the wrong way, make a U-Turn, and get a headshot on the intended target."
          - RenegadeRetard

          Comment


            #6
            Yea, can't figure this one out.
            Everything just seems to be washed out in the editor and appear darker in game. Kinda difficult to properly work on lighting with it :-)

            Hopefully, it's just me missing something and someone can point me in the right direction? Or maybe this issue gets fixed (if it is indeed an issue)
            ^_^
            MyArtstation
            @jayoplus

            Comment


              #7
              Originally posted by jayo_ View Post
              Kinda difficult to properly work on lighting with it :-)
              My current state...

              The fun fact is that I actually started making my first UT maps only two weeks ago! Now I have to wait, because, as you said, it's impossible to me working on lighting.

              -Luigi Rapetta
              (rapfamily4)

              My projects list:
              Unreal Monsters | Armor Pickups | Dispersion Pistol for Invasion | Fusion Cannon - a Flak Cannon variant

              Comment


                #8
                See also

                https://www.epicgames.com/unrealtour...-level-changes

                seems like one needs to enable tonemapper film in the UT editor via parameter:

                r.tonemapperfilm 1

                (is the default in-game setting, but off in the editor default)

                Comment


                  #9
                  [MENTION=108831]Mr Van[/MENTION]

                  Many thanks! It works fine! I hope this command doesn't change any effects given by PostProcessVolumes.

                  -Luigi Rapetta
                  (rapfamily4)

                  My projects list:
                  Unreal Monsters | Armor Pickups | Dispersion Pistol for Invasion | Fusion Cannon - a Flak Cannon variant

                  Comment


                    #10
                    This problem persists in the new version of the editor.

                    I still have to enable tonemapper film manually and the editor still seems disconnected from the game configuration.

                    -Luigi Rapetta
                    (rapfamily4)

                    My projects list:
                    Unreal Monsters | Armor Pickups | Dispersion Pistol for Invasion | Fusion Cannon - a Flak Cannon variant

                    Comment

                    Working...
                    X