Announcement

Collapse
No announcement yet.

UE4 crash with DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG (possibly solved)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    UE4 crash with DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG (possibly solved)

    Update on the fly (possible solution):

    I launched "Verify" option from Epic Games Launcher (Unreal Tournament Tab> "Create" section> gear button menu next to "Launch") and Unreal Tournament Editor now started normally.
    ----------------------------------------------------------------------------------------------------------------------

    Good evening,
    Version: 4.14.0-3164292+++UT+Release-Next

    Yesterday Unreal Editor had successfully recompiled >15 000 shaders. Today, when Editor loads, Project Settings window is open and below is a message, something about verifying >19 000 assets. After a minute Editor crashes with a message "UnrealEd stopped working". Unreal Tournament Game itself works without problems.

    Editor Log lines show:
    Code:
    [2016.10.23-16.01.55:373][  0]LogCrashTracker: Crashtracker disabled due to settings.
    [2016.10.23-16.01.55:516][  0]LogWindowsTextInputMethodSystem:Display: IME system now deactivated.
    [2016.10.23-16.01.57:978][  0]LogUObjectGlobals:Warning: Failed to find object 'Class None.'
    [2016.10.23-16.01.58:174][  0]LogContentBrowser: Native class hierarchy updated for 'HierarchicalLODOutliner' in 0.0004 seconds. Added 1 classes and 2 folders.
    [2016.10.23-16.01.58:174][  0]LogLoad: (Engine Initialization) Total time: 225.63 seconds
    [2016.10.23-16.01.58:174][  0]LogLoad: (Engine Initialization) Total Blueprint compile time: 6.13 seconds
    [2016.10.23-16.01.58:194][  0]LogExternalProfiler: Found external profiler: VSPerf
    [2016.10.23-16.01.58:194][  0]LogExternalProfiler: Using external profiler: VSPerf
    [2016.10.23-16.01.59:249][  0]LogContentStreaming: Texture pool size now 2400 MB
    [2016.10.23-16.02.00:082][  0]LogActorFactory: Loading ActorFactory Class UnrealTournament.UTPlayerStart
    [2016.10.23-16.02.01:976][  0]LogRenderer: Reallocating scene render targets to support 856x372 NumSamples 1 (Frame:2).
    [2016.10.23-16.02.05:587][  1]LogRenderer: Reallocating scene render targets to support 856x512 NumSamples 1 (Frame:2).
    [2016.10.23-16.02.22:969][  5]LogD3D11RHI:Error: Result failed 
     at D:\Build\++UT+Release-Next+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Viewport.cpp:267 
     with error DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG
    [2016.10.23-16.02.23:456][  5]LogWindows: Windows GetLastError: The operation completed successfully. (0)
    [2016.10.23-16.03.23:885][  5]LogCrashTracker:
    What could have caused this?
    Last edited by Hayrack; 10-23-2016, 01:59 PM.

    #2
    DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG means that the videocard driver stopped responding and OS tried rebooting it by virtually removing from the system and adding it back. This prevents OS from crashing to BSOD, but crashes any 3D apps you're running. This can be caused both by problems in 3D app's code or the driver itself, so the steps are the same that you took. Verify/reinstall/update app and update/verify/reinstall your graphics driver.
    "Yeah. _Lynx can fire the lightning gun, have the lightning bolt turn a 90 degree corner, stop and ask the closest teammate for directions, confuse the directions and get lost, realize it went the wrong way, make a U-Turn, and get a headshot on the intended target."
    - RenegadeRetard

    Comment


      #3
      I have the same problem! I have reinstalled the editor twice! I have verified! I have tried numerous Video Drivers! I have completely reformatted and new install of window 7 with service pack 1! I have checked dxdiag! I did not see your bug report and made one also. https://www.epicgames.com/unrealtour...533#post259533 If it is solved please let me know how!
      Last edited by Megasporwic; 10-24-2016, 10:28 PM.
      Running the Mega Hub for everyone to enjoy!

      Comment


        #4
        I have the same problem. Everything has begun from the moment of the translation the project on the 13th version. It was now updated on 14, has reinstalled windows, and all drivers. But no what helps.

        DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG

        Comment


          #5
          [MENTION=320676]Bebeka[/MENTION] [MENTION=5800]Megasporwic[/MENTION] what are your system specs?
          "Yeah. _Lynx can fire the lightning gun, have the lightning bolt turn a 90 degree corner, stop and ask the closest teammate for directions, confuse the directions and get lost, realize it went the wrong way, make a U-Turn, and get a headshot on the intended target."
          - RenegadeRetard

          Comment


            #6
            This is a windows error causing this to happen. Unfortunately it is not an unreal tournament bug, or even an unreal engine bug. Its your video card being inactive for 2 seconds and windows is shutting it down as _Lynx said previously. Some people have found solutions by doing one or more of these things. Lowering your graphics settings, Going to Borderless Fullscreen instead of just Fullscreen, Reinstalling the latest Direct X Drivers, Reverting your GPU to stock levels if you have overclocked it, Turning off Nvidia Shadowplay have all shown to have stopped this problem for various different reporters.

            Comment


              #7
              Originally posted by FG_Fennec View Post
              This is a windows error causing this to happen. Unfortunately it is not an unreal tournament bug, or even an unreal engine bug. Its your video card being inactive for 2 seconds and windows is shutting it down as _Lynx said previously. Some people have found solutions by doing one or more of these things. Lowering your graphics settings, Going to Borderless Fullscreen instead of just Fullscreen, Reinstalling the latest Direct X Drivers, Reverting your GPU to stock levels if you have overclocked it, Turning off Nvidia Shadowplay have all shown to have stopped this problem for various different reporters.
              Thanks! Fullscreen has helped me)

              Comment


                #8
                I do have a similar problem (the same DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG ) happens since 4.14 when I'm changing a texture parameter in an instanced material and save (don't know exactly when it happens, sometimes it's directly when I change, sometimes only when I save after changing the parameter). I tried the different solutions FG_Fennec gave but without success. Then I thought : Maybe it's different on a previous version. So I tried on the 4.13.2 build, and I do not have this problem!

                Comment


                  #9
                  What sort of hardware are you running in your PC?

                  Comment


                    #10
                    That's what I'm turning on :
                    Asus G75VW
                    i7-3610QM CPU @2.30Ghz
                    Ram 16Go
                    GPU GTX 670M

                    Comment


                      #11
                      So it started crashing again. The following combination produces crash 99% of the time - inactive open main editor window, inactive undocked content browser, active asset properties window (f.e. blueprint defaults or blueprint editor). Editor locks up and then closes itself after a while without crash or any other message, not even "this application stopped working".

                      Forcing dedicated GPU and disabling power saving modes (laptop system) didn't help, crash still happens. Updating, rolling back drivers doesn't help.

                      Gonna do a "Verify" thing tomorrow and play some more. Just wth, everything was working fine for a month...

                      Comment


                        #12
                        I'm bumping this post up since I still have the DXGI_Error issue only on 4.14 (even the 4.14.1), but I found a few other way the crash is happening :
                        Material Instance editing
                        Mesh viewer (like 30% of the time, there it depends if I let the model "unload" after closing it. If I open a new one directly without waiting, then it crashes like 90% of the time)
                        Particle editing on Cascade
                        I tried with older versions of the Engine (4.13/4.10) and it worked perfectly

                        Comment


                          #13
                          From your latest reply, it seems like we actually have a bug for this issue already logged. It should be included in the fix for this issue. https://unrealtournament.atlassian.net/browse/UT-6912

                          Comment


                            #14
                            Hello! I'm experiencing the same exact problem. I've been playing Fortnite too and it randomly crashes showing DXGI error device REMOVED & HUNG. I've tryed everything:
                            - Clean reinstall of drivers, software..
                            - Reinstalled Windows 10 and all updates
                            - All FG_Fennec tips

                            I think this could be an Epic Games bug at this point..
                            I'm running on:

                            <link below>

                            Comment


                              #15
                              i uninstalled all drivers and software for my gpu then downloaded an older driver version and its not crashing anymore should try

                              Comment

                              Working...
                              X