Announcement

Collapse
No announcement yet.

Can't seem to move objects correctly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't seem to move objects correctly

    So, I got the Unreal Editor the other day and as much as I've tried to figure out things for myself, I have literally gotten nowhere.

    Basically, I can't seem to move things around the axis properly. with Place mode selected, I select a BSP brush or Static Mesh, hold CTRL and try to move them using mouse direction + Left or Right mouse buttons, they often move in the correct direction but the movement is not very fluid, it moves a little bit and gets stuck where I can't move it any farther, sometimes it jumps suddenly down the axis and there's no way to place it in-between. if I don't hold CTRL, I can still move objects using left mouse button but it's also similarly un-fluid. using geomerty mode seems to work correctly but it's a pain to build anything with out being able to just move things around.

    Am I doing something wrong? maybe there's some setting I've overlooked?
    Is it suppose to be like this? or maybe it's a bug?

    I'm pretty confused and a little frustrated that this should be easy. I've built maps for UT99/UT2k4/UT3 so I have experience using previous versions, but I'm at a loss here.

    I took the tutorial at https://learn.unrealtournament.com/t...map02-geometry and cannot get the brush to move past the hazard stripes to align anything, well, that's not exactly true, It sort of snaps to the opposite side if I keep pretending it's moving (see pictures below). I could finish the tutorial, but it was more painful than the video. if feels like something is broken in the editor

    In the first pic, you can see where I placed the BSP box and where the brush currently sits. that is as far as I could move it in that direction until it suddenly snapped to where it is in the second pic
    Attached Files
    Last edited by Necron99; 03-05-2015, 12:38 PM.

    #2
    Does nobody have an idea what's happening? Something isn't right....

    Comment


      #3
      You should make a video of that.

      But you can move the object with Shift as well which moves the camera along your mouse movement:
      [Shift]+[Ctrl]+(LMB) + Moving

      Or using the widget.
      ] Map Scaler Tool | Betrayal for UT4 | No Spawn Protection | No Pickup Timer | BioLauncher (revived) | ForcePickupSpawn | Map cosmetics::P | Safe Spawn::P | Why numbers for Health/Armor suck!::ANALYSIS/CONCEPT
      ] UT3 Addons: NoMoreDemoGuy | PickupRespawnTweak | Mutate Spec | MutePawnSounds | NoPlayerBeacon | Epic FTW | Epic FOCK | TripodSound (... and many more)

      Comment


        #4
        Originally posted by RattleSN4K3 View Post
        You should make a video of that.

        But you can move the object with Shift as well which moves the camera along your mouse movement:
        [Shift]+[Ctrl]+(LMB) + Moving

        Or using the widget.
        Thanks for the reply. I tried [Shift]+[Ctrl]+(LMB) + Moving and got the same results.

        Sorry for the crappy Bandicam, but hopefully you get the gist of what's happening

        Comment


          #5
          When you use the widget (clicking on one arrow of the Red-Green-Blue-Arrow-Thingy), you don't need [Ctrl].

          Disable Vertex Snapping:
          Click image for larger version

Name:	UE4VertexSnapping.png
Views:	1
Size:	294.7 KB
ID:	334982
          ] Map Scaler Tool | Betrayal for UT4 | No Spawn Protection | No Pickup Timer | BioLauncher (revived) | ForcePickupSpawn | Map cosmetics::P | Safe Spawn::P | Why numbers for Health/Armor suck!::ANALYSIS/CONCEPT
          ] UT3 Addons: NoMoreDemoGuy | PickupRespawnTweak | Mutate Spec | MutePawnSounds | NoPlayerBeacon | Epic FTW | Epic FOCK | TripodSound (... and many more)

          Comment


            #6
            Originally posted by RattleSN4K3 View Post
            When you use the widget (clicking on one arrow of the Red-Green-Blue-Arrow-Thingy), you don't need [Ctrl].

            Disable Vertex Snapping:
            Thanks for that! that is exactly what was wrong.

            Comment

            Working...
            X