Announcement

Collapse
No announcement yet.

Custom Weapons

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom Weapons

    Hi,

    Since the update today (18/3/15) my custom weapons won't work. Have repackaged and resaved all assets. Deleted old versions and tried again all to no avail.

    In the weapon replacer mutator there appears to be 4 instances of Shock Rifle. I've tried all of these and they are all the default shock rifle not my modded instagib version.

    The other custom sniper I made is still working all okay just the instagib.

    Running out of things to try with it, any suggestions?

    Bashkov

    #2
    Hi Bashkov,

    If in C++ Have you compiled your code recently? Can you still locate the .cpp and .h file for your custom weapon in the Windows Explorer filepath? If in blueprints, are you getting any specific warnings when you open your project or has it just entirely disappeared?
    Adam Davis | Engine Support Technician | Epic Games
    How to report a bug? | Installation & Setup issues?

    Comment


      #3
      C++ weapons aren't supported in UT currently, so I'm positive this is a blueprint weapon.

      Did you update your editor in the launcher?

      How did you package?
      HABOUJI! Ouboudah! Batai d'va!
      BeyondUnreal - Liandri Archives [An extensive repository of Unreal lore.] - Join us on IRC [irc.utchat.com - #beyondunreal]

      Comment


        #4
        Hi,

        It's blueprint, C++ is something I've been meaning to learn for years but have never actually bothered doing.!

        The editor has been updated, I even deleted all the assets and verified to see if it was a conflict causing it.

        I'm packaging it via the 'share weapon' tab and when I do so there are no error messages at all. I have completely deleted all custom assets and started from scratch using a different name and am getting the same issue.

        I now have 5 shockrifles listed in the weapon replace / arena mutator, non of which are the modified shock rifle.

        Sent the .Pak to a friend and he has exactly the same issue.

        Hope you can shed some light.

        Bashkov


        EDIT:

        Here are the assets : https://www.dropbox.com/s/lr8bqh5pya...Rifle.rar?dl=0

        Bashkov
        Last edited by Bashkov; 03-19-2015, 04:52 PM.

        Comment


          #5
          I had the same problem using a copy of the Shock rather than using it as a child.
          Running the Mega Hub for everyone to enjoy!

          Comment


            #6
            Any joy so far guys?

            Comment

            Working...
            X