Announcement

Collapse
No announcement yet.

UT - Editor - Console command while PIE not showing up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG] UT - Editor - Console command while PIE not showing up

    Hello everyone!

    Since the Update from 2/1/2016 the console command while PIE doesn't work anymore.

    Before then, I only had to press the "Tilde-Key" when PIE, and it showed up, now it doesn't anymore.

    I've looked in the Editor Preferences under "Keyboard Shortcuts",
    but I could only find (under Section "System-wide") the general Console Command box, but not the one which appears while PIE.

    Can anyone give me a tip/solution to this please?

    Would be very grateful for any advice/help.
    • OS: Windows 8.1 Pro
    • UT-Editor Build: 4.11.0-2883976 (downloaded via Epic Games Launcher)
    WIP - Maps (UT - Build 0.1.12.1): https://goo.gl/v8ze8Y
    Channel: https://www.youtube.com/user/barsam2a

    #2
    The key pinput heavily depends on the regional settings (layout [en-US] etc.). There is also some inconsistency where specifics keys are somehow processed as a different key in other input fields. That said, even if you find the specific console command binding in the editor, the key you'll define might not work the same way in-game. It has been like that in UE4.0 (and mostly in all prior engine versions).

    The INI has Tilde set as console key, however on my system the engine shows it as grave `. Both keys are not direct buttons on my keyboard therefore these aren't working.

    Check the Project settings under Input, there should be a section Console with a list of Console Keys. You might already find keys in there. Use a different key if tilde is not working.
    Last edited by RattleSN4K3; 03-05-2016, 10:50 AM.
    ] Map Scaler Tool | Betrayal for UT4 | No Spawn Protection | No Pickup Timer | BioLauncher (revived) | ForcePickupSpawn | Map cosmetics::P | Safe Spawn::P | Why numbers for Health/Armor suck!::ANALYSIS/CONCEPT
    ] UT3 Addons: NoMoreDemoGuy | PickupRespawnTweak | Mutate Spec | MutePawnSounds | NoPlayerBeacon | Epic FTW | Epic FOCK | TripodSound (... and many more)

    Comment


      #3
      Originally posted by RattleSN4K3 View Post
      The key pinput heavily depends on the regional settings (layout [en-US] etc.). There is also some inconsistency where specifics keys are somehow processed as a different key in other input fields. That said, even if you find the specific console command binding in the editor, the key you'll define might not work the same way in-game. It has been like that in UE4.0 (and mostly in all prior engine versions).

      The INI has Tilde set as console key, however on my system the engine shows it as grave `. Both keys are not direct buttons on my keyboard therefore these aren't working.

      Check the Project settings under Input, there should be a section Console with a list of Console Keys. You might already find keys in there. Use a different key if tilde is not working.
      Thank you very much RattleSN4K3! it's working again!
      WIP - Maps (UT - Build 0.1.12.1): https://goo.gl/v8ze8Y
      Channel: https://www.youtube.com/user/barsam2a

      Comment

      Working...
      X