Announcement

Collapse
No announcement yet.

Weapons fire crash.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weapons fire crash.

    When either me or my opponents fire certain weapons, it crashes.

    Running Windows 7 64 bit. Redistributable is installed, video and audio drivers are up-to-date, dxdiag/log/dump linked below:

    http://www.filedropper.com/utcrashnew

    #2
    I believe this is caused by the DX11 impact effects not being compatible with below-DX11 graphics cards. Disabling impact effects (or even showflag.decals 0) appears to fix the issue.
    Last edited by fuolox; 08-26-2014, 12:20 AM.
    http://twitch.tv/MysTikalUT - Tune in for duels, TDM and random testing

    Comment


      #3
      Originally posted by MysTikal View Post
      Disabling impact effects (or even showflag.decals 0) appears to fix the issue.
      Pardon my noobishness, but how do I do this?

      Comment


        #4
        Originally posted by laser View Post
        Pardon my noobishness, but how do I do this?
        I had a similar issue. Once the game starts you would hit ~ to bring up the console and type showflag.decals 0 . I found it got rid of the crash after firing but it kills the graphics as to make it unplayable. Hoping someone has an alternative fix.

        Comment


          #5
          I had the same problem. With showflag.decals 0 it works fine.
          Originally posted by laser View Post
          Pardon my noobishness, but how do I do this?
          Open ingame console "`" (tilde) and type showflag.decals 0, then press enter

          Comment


            #6
            Originally posted by MÆST View Post
            I found it got rid of the crash after firing but it kills the graphics as to make it unplayable. Hoping someone has an alternative fix.
            Indeed. Turns out that command fixes the guns, but also turns off ALL of the lighting, so you're wandering around in almost complete darkness.

            Comment


              #7
              Originally posted by MysTikal View Post
              I believe this is caused by the DX11 impact effects not being compatible with below-DX11 graphics cards.
              but this was working out in earlier releases?

              Comment


                #8
                I have the same problem with that build. Previous working well.
                Every time when I try to shot, game get crashed
                There is my error message:
                http://oi57.tinypic.com/10r6azn.jpg

                Windows, radeon 4850

                Polish community DISCORD server: https://discord.gg/eMRKbAg Join us if you are Polish and let's play some 4v4

                Comment


                  #9
                  Same here with GTX 285. "showflag.decals 0" thing works but it also makes the game pretty much unplayable.

                  Comment


                    #10
                    Originally posted by laser View Post
                    When either me or my opponents fire certain weapons, it crashes.

                    Running Windows 7 64 bit. Redistributable is installed, video and audio drivers are up-to-date, dxdiag/log/dump linked below:

                    http://www.filedropper.com/utcrashnew
                    Which weapons are you using that causes the crash? Does the crash occur when you fire these weapons for the first time?

                    Comment


                      #11
                      For me they are:
                      Enforcer - both
                      Rocket launcer - both
                      Flack - second fire only
                      Sniper - primary will crash but zoom does not
                      Shock rifle - primary fire only

                      Yep, first time. Seems like it crashes when there's impact. (for example if you aim at the sky with Flack and shoot it only crashes when ammo is hitting the floor.)
                      Last edited by Frigidus; 08-26-2014, 11:25 AM.

                      Comment


                        #12
                        Originally posted by Excitnels View Post
                        I had the same problem. With showflag.decals 0 it works fine.

                        Open ingame console "`" (tilde) and type showflag.decals 0, then press enter
                        You may not be aware, that many of us use the UTDarkest theme, and the color code you used for your highlighted text blends in with the background. If I may suggest, please use a color other than gray for highlighting text. This will make it easier for everyone to see the text. Thanks!
                        Promotional consideration brought to you by: Tarydium Shards, those neat little projectiles that remove unwanted flesh...from your opponents!

                        Comment


                          #13
                          Originally posted by Skinnz View Post
                          Which weapons are you using that causes the crash? Does the crash occur when you fire these weapons for the first time?
                          The nature of the bug makes it time consuming to test, so I hope Frigidus' post (#11) will suffice...

                          ...but I can confirm that, yes, first shot crashes.
                          Last edited by laser; 08-26-2014, 06:30 PM.

                          Comment


                            #14
                            Looks like this was fixed today by Mysterial:

                            Disable DBuffer decals on DX10 as they currently crash the engine

                            The next build should hopefully be ok for you guys

                            Comment


                              #15
                              Originally posted by raxxy View Post
                              The next build should hopefully be ok for you guys
                              We shall see!

                              Comment

                              Working...
                              X