Announcement

Collapse
No announcement yet.

Virtual 7.1 / 5.1 surround sound problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Virtual 7.1 / 5.1 surround sound problem

    Hi there, I have a Situation and i am hoping some one could assist me.

    Not knowing if its the config setting or an Unreal Engine bug.

    You see, i bought myself the Genius Virtual 7.1 Channel Gaming Headset and it is great, but for some reason, when i play UT4 ( even ARK Survival Evolved ), the volume of any object that emits sound that moves to my left or right, fades out to nothing, Example, when a player walks past my left, i hear him clearly in front of me, moving towards my left, it goes soft until the sound is totally muted next to me, then starts fading in again as i hear him moving towards my back. same with projectiles like rockets, pickups. so i do not hear anything from my sides, left or right.

    I was hoping there is a quick fix to this that i could do on my side as my stereo really ain't that great, and i got this headgear for the surround. Like i said, Top and front i can hear as clear as day. judging distance and everything, but sides.. nada.

    Please if any one can help i would highly appreciate it.

    Manta

    #2
    Have you tried opening up the sound tool on your computer and testing the speakers? Maybe your headphones are set to play in stereo rather than 7.1.

    It also might happen if it's not plugged in right - although that's less likely if it's USB.
    Current Main Issues: Tri-Rox (Remove), Scoreboards lack player stats,Team Balance.

    My Pre-Alpha Highlights 2016 to early 2017 https://www.youtube.com/watch?v=IKlKQ349o8A | http://plays.tv/u/Smurgl

    Comment


      #3
      Thank you for the reply Smurgl, It is set to 7.1, tried 5.1 as well, it is USB, this problem only occurs when playing on surround sound, and only on Unreal Engine Titles, not that I have played any UE game with this headset besides ark and ut4. Other games appear to work just fine, which is quite weird for me, was hoping there was maybe a config setting I could change.

      Really hoping I can get this sorted.

      Manta

      Comment


        #4
        Please, if anyone can assist me with this issue, or ideas what it can be, i dont know if there are other drivers one could download that might fix my issue, i am running win10 64bit. this is a real dissadvantage when i duel. if there are any ini files that i could changed, please i need some assistance, any help will be highly appreciated

        Manta

        Comment


          #5
          Hi Man7a, sorry you're having trouble. Could you go to http://help.unrealtournament.com and click on "Email Us" so we can troubleshoot with you?

          Thank yoU!
          Stacey Conley
          -----------------------------
          Unreal Tournament Community Manager
          Epic Games, Inc.
          Twitter | Twitch | Facebook | Instagram | YouTube | Pinterest

          Comment


            #6
            Thank you Flak, will do.

            Manta

            Comment


              #7
              Bumping this old thread because this seems very common, Hellblade is the most current UE4/XAudio2 game I've tested that exhibits this issue. It's funny the bug doesn't exist in Fortnite because 5.1 is the max output supported in that game; if there's one way to prevent a bug, it's to just disable the feature!

              Here's a developer reporting the issue: https://answers.unrealengine.com/que...-channels.html

              Here's an example of the issue that I've recorded in 2015: https://www.youtube.com/watch?v=-UB_8G-Tr2c

              I don't experience the issue when I set my output to 5.1; audio appears to cleanly pan around without dropping out. This only happens with the native UE4 XAudio2, games that use other middleware don't have this problem. The real ugly thing is that you can't even change from 7.1 on Logitech headphones, so all these games are just broken on Logitech headsets.

              Comment


                #8
                I just updated to a beta release of The Solus Project, looks like they're using UE 4.17 or maybe 4.19, and it sounds like this issue was worked on. Now, instead of audio at 90-degrees just completely dropping out, it places the audio simultaneously in the front speaker and rear surround speaker corresponding to the side the sound is emitting from. I guess that's OK if you're using headphones, but it sounds bad in speakers because it ignores (doesn't play from) the side-surround speakers; the affected audio doesn't shift to that one left or right side surround speaker, it fills more speakers than is necessary and thus dulls or flattens the positioning effect.

                Having something is better than nothing, but there's still work to be done on it.

                Comment


                  #9
                  I have a Logitech g430 and it works properly with ut4, actually very well. FYI
                  Maps: DM-Dying_Sun WIP & DM-TokaraSwamp
                  www.shockandrockets.com

                  Comment


                    #10
                    i have a problem. my headset do not have proper surround sound but, i have always been able to hear if someone is to the left or the right, but now the past few days for some reason whenever somebody is running around or shooting it sounds like they are exactly where i am even if they a re like 5-10 meter away from me their footsteps still sounds like as if it would be me running!

                    Comment

                    Working...
                    X