Announcement

Collapse
No announcement yet.

Windowed Fullscreen vs Fullscreen and refresh rate in game

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windowed Fullscreen vs Fullscreen and refresh rate in game

    When I play in Fullscreen mode I get 60 hz refresh rate. When I change to Windowed Fullscreen I get my monitors setting - 120 hz. Is this by design ? Is there any performance impacts to mouse input, networking, code execution, etc when running in Windowed Fullscreen vs. Fullscreen ? Not sure where to ask this if this isn't right venue please advise, thanks!@

  • #2
    You're better playing in full screen where possible. It shouldn't cap your FPS to 60Hz though. Do you have different settings in windowed/full screen mode, or maybe in your graphics driver settings that causes it to limit to 60 Hz?
    Current Main Issues: Tri-Rox (Remove), Scoreboards lack player stats,Team Balance.

    My Pre-Alpha Highlights 2016 to early 2017 https://www.youtube.com/watch?v=IKlKQ349o8A | http://plays.tv/u/Smurgl

    Comment


    • #3
      I cap my FPS to 120 to match refresh rate setting for my monitor. I get a constant 120 fps always but when I use Fullscreen UT has me set at 60hz somehow and the display suffers with the framerate twice the refresh rate. When I set to Windowed (Fullscreen) in Settings==> System Settings==>General==> Display Mode then the field just below that changes from Vsynch (Monitor 60hz) to Vsynch (monitor 120 hz). I always leave Vsynch unchecked. I suspect the Windowed Fullscreen impacts performance. Is there a setting in one of the ini files to force the refresh rate to 120 when in Fullscreen mode ?

      Comment


      • #4
        Update - today I had some time to play with the Nvidia Control Panel settings. Under the 3D section==>Preferred Refresh Rate I had the default setting of Application controlled. When I changed that to "Highest Available" and restarted UT4, when I changed back to Fullscreen the Vsynch (120Hz) stayed set Apparently when Nvidia allows App to select refresh rate and the app uses Fullscreen, 60hz is forced. All is good now.

        Comment


        • #5
          Hi. I had this 60fps full screen cap after updating to windows creators edition recently. I couldn't work out how to get 120hz back so rolled back.
          Maps: DM-Dying_Sun WIP & DM-TokaraSwamp
          www.shockandrockets.com

          Comment


          • #6
            Windowed and Border-less modes will make use of your Desktop's refresh rate.
            To adjust that setting you need to go to Control Panel -> Display -> Screen Resolution -> Advanced Settings -> Monitor -> Set the Screen refresh rate to 120 or 144Hz (depending on your monitor).
            Full-screen allows for GPU utilization in exclusive-mode, allowing manipulation of the refresh rate independently, from the in-game settings.


            However, if you run a multi-monitor setup like me, there are two catches:

            1) Playing in full screen will sometimes turn black all your other monitors, besides the primary one, where the game is rendered.
            Alt-tabbing a few times, between the desktop and the game, will help bringing them back. Though sometimes they will just keep going black or appear frozen, if you insist enough, they will work eventually. (It's a bit tedious, I know)

            2) Windowed and Border-less might solve the aforementioned issue; but since the GPU is not utilized exclusively by the game, your performance will suffer. (As the GPU "juice" is distributed evenly across the monitors that are connected to it)
            I've heard somewhere that newer operating systems, like Windows 8.1 and 10, have made it possible to run games in both Windowed/Border-less and GPU exclusive modes at the same time (thanks to the newer WDDM). But, there have been reports that the OS will then force vSync/Triple-buffering, which are known to cause significant amounts of input lag.
            Last edited by FrostbyteGR; 05-27-2017, 07:21 AM.
            > FreezeTag [Blueprint]
            > Reimagining of Greed [BluePrint]
            > Avarice, a DM-variant of Greed [BluePrint]

            Comment


            • #7
              Originally posted by the_hack View Post
              Hi. I had this 60fps full screen cap after updating to windows creators edition recently. I couldn't work out how to get 120hz back so rolled back.
              I think the same thing happened to me. Did your game also get a bit darker after updating while in Fullscreen mode?

              I just updated to Win10 creators edition as well and I'm getting all sorts of issues in Fullscreen, stat fps numbers are stable/normal (144) but there's tons of tearing and just feels terrible.
              http://www.youtube.com/DrewTangNYC
              http://www.twitch.tv/drewtang

              Comment


              • #8
                After the Win10 Creators update, it seems as if regular fullscreen caps my monitor's refresh rate, while windowed fullscreen doesn't cap it, yet introduces noticeable input lag.
                http://www.youtube.com/DrewTangNYC
                http://www.twitch.tv/drewtang

                Comment


                • #9
                  I solved this with a new monitor. I was using a Yamasaki catleap on dual dvi and it wouldn’t go into full screen with ut4 above 60fps. BenQ with DisplayPort could.
                  Maps: DM-Dying_Sun WIP & DM-TokaraSwamp
                  www.shockandrockets.com

                  Comment


                  • #10
                    Originally posted by Rainmaker_CZ View Post
                    This happens in fullscreen + it says my monitor is 40hz (in vsync settings), which it is not.
                    I have a whole different problem. Also with fullscreen. Still not solved. Works "well" with fullscreen-windowed.

                    Comment

                    Working...
                    X