Announcement

Collapse
No announcement yet.

Mouse lag/smoothing ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mouse lag/smoothing ?

    Hi everybody,

    I've just started to test the latest UT build to test movement mechanics, and it feel better and better !
    I think there isn't lot of work anymore to get this game become nervous as it should be !

    But there is something that I've found when trying to play with combo move technics (which somehow happen when I try to launch the good and old ut99) which really disappoint me !
    I find that movement catched by the mouse is a little bit laggy or smoothy.
    My framerates are ok, so I don't know it comes from my hardware configuration (5770 + dual core E8400, ok it's old but still ok in the latest games...) on untextured levels.

    Do you encounter this same problem too ?


    Build used : https://github.com/EpicGames/UnrealT...113c08e2da3e7b

    #2
    Originally posted by globule View Post
    Hi everybody,

    I've just started to test the latest UT build to test movement mechanics, and it feel better and better !
    I think there isn't lot of work anymore to get this game become nervous as it should be !

    But there is something that I've found when trying to play with combo move technics (which somehow happen when I try to launch the good and old ut99) which really disappoint me !
    I find that movement catched by the mouse is a little bit laggy or smoothy.
    My framerates are ok, so I don't know it comes from my hardware configuration (5770 + dual core E8400, ok it's old but still ok in the latest games...) on untextured levels.

    Do you encounter this same problem too ?


    Build used : https://github.com/EpicGames/UnrealT...113c08e2da3e7b
    In UE4

    Look in \Unreal Engine\4.2\Engine\Config and you'll find the ini files

    At the top of BaseInput.ini you have

    bEnableMouseSmoothing=true - set this to false

    Also what sort of frame rates do you get? do stat fps in the console and see, i get better responsiveness from the mouse at over 150 fps

    If you go to BaseEngine.ini and look for these lines(note they are in two places, one is for when you're using the editor, the other is when you've gone into standalone mode

    bSmoothFrameRate=true
    SmoothedFrameRateRange=(LowerBound=(Type="ERangeBoundTypes::Inclusive",Value=5),UpperBound=(Type="ERangeBoundTypes::Inclusive",Value=144))

    I've changed the value at the end to 144, it will either be 120 or 62, these are the fps caps the editor works with, by setting the smooth frame rate to false it will unlock the fps limit and UE4 will run at whatever fps it's capable of doing

    If you've just downloaded a packaged UT and are not using the editor, go to \UnrealTournament\UnrealTournament\WindowsNoEditor\UnrealTournament\Saved\Config\WindowsNoEditor

    And you'll find Input.ini and Engine.ini, you may need to add the lines above into the inis like so

    At the bottom of the Engine.ini

    [/Script/Engine.Engine]
    bSmoothFrameRate=False
    SmoothedFrameRateRange=(LowerBound=(Type="ERangeBoundTypes::Inclusive",Value=22),UpperBound=(Type="ERangeBoundTypes::Exclusive",Value=120))

    (use true if you want to limit your fps by the end value and false if you want it to run as fast as it can)

    At the top of the Input.ini

    [/Script/Engine.InputSettings]
    bEnableMouseSmoothing=false

    These are just some super basic settings, i don't know nearly enough about this ini setup to do more so i'm hoping someone will come along with an in depth set of tweaks, either that or Epic introduce raw input

    Comment

    Working...
    X