Announcement

Collapse
No announcement yet.

Is there a way to adjust controller sensitivity?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Is there a way to adjust controller sensitivity?

    Before I start I would like to ask you not to bash me for using a controller, as it is not my main input device. I have always played arena shooters with M+K and will continue to do so. I am testing the controller support out of sheer curiosity. With that out of the way I can proceed

    I read that even though UT does not officially support console controllers, there is some default controller module in the UE4 itself and decided to test it. I plugged in my DualShock 2 (yup, the PS2 controller), did some basic configuration in X360CE and started the game. To my surprise, the title is playable and there is some default configuration for the controller which I find surprisingly decent.

    There is only one thing that bothers me - I do not seem to be able to adjust the sensitivity of the analog sticks. Is there a way to do it somehow - either through some UT variable, or through X360CE? There are some sensitivity settings in X360CE under the "left thumb / right thumb" tabs, but I cranked them up and nothing changed (from what I understand, they refer to dead zone settings more than general sensitivity, but I'm not sure). Has anyone managed (or even tried?) to alter the sensitivity of a controller?

    #2
    I'd suggest taking a look in your UT4 profile directory (sorry, don't know where that is for you) at Saved/Config/WindowsNoEditor/Input.ini. It includes gamepad control configuration with sensitivity values which may or may not actually work.

    Comment


      #3
      You may have to manually add the settings to your input.ini to set it that way. There are many threads on this forum about this already, which show the correct input.ini section, and it does indeed work. (search bar is at top-right side...) You can also adjust from within x360ce gui, in the thumb tabs.

      Comment


        #4
        use steam, add the launcher as a non steam game and see if the built in controller configuration applies to the game.

        Comment


          #5
          Thank you very much for your help guys! I tried HonoredMule's solution and it worked. In the past I tried altering the config files located within the game's folder and it did not work, but changing the file located in the "Saving\..." path did!

          I would also like to apologize for not using the search function before making the query. I appreciate you provided me with the help nonetheless.

          Comment

          Working...
          X