Announcement

Collapse
No announcement yet.

Setting up the Unreal Tournament Editor on Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I dont know if it helps, but here is what i get when running the Setup.sh files in Build/BatchFiles/Linux


    mena@mena-Lenovo-G500:~/Documents/Unreal/UnrealTournament/Engine/Build/BatchFiles/Linux$ ./Setup.sh


    Github build
    Checking / downloading the latest archives
    Checking dependencies (excluding Win32, Win64, Mac, HTML5, Android)...
    Result: 0
    Fixing inconsistent case in filenames.
    Removing a stable libLND.so binary that was relocated in 4.8


    Building ThirdParty libraries


    If you don't see SUCCESS message in the end, then building did not finish properly.
    In that case, take a look into /home/mena/Documents/Unreal/UnrealTournament/Engine/Build/BatchFiles/Linux/BuildThirdParty.log for details.


    You run Ubuntu or its fork. All dependencies have been already prebuilt.


    ********** SUCCESS ****************

    Comment


      #17
      That looks good. You should be able to compile it now.
      Unreal Tournament 4 eXpanded MultiPlayer (UT4XMP) efforts
      My website, listing all my Unreal series mods and mutators

      Comment


        #18
        Nop, still get the same error

        mena@mena-Lenovo-G500:~/Documents/Unreal/UnrealTournament/Engine/Build/BatchFiles/Linux$ sudo apt-get install mono-core mono-devel dos2unix cmake llvm-clang
        [sudo] password for mena:
        Reading package lists... Done
        Building dependency tree
        Reading state information... Done
        E: Unable to locate package mono-core
        E: Unable to locate package llvm-clang

        Comment


          #19
          Oh, I see what you're trying to do, and I suppose I should have made that part clearer. You don't need this on Ubuntu, only on distributions that aren't supported yet. Just go to the next step.
          Unreal Tournament 4 eXpanded MultiPlayer (UT4XMP) efforts
          My website, listing all my Unreal series mods and mutators

          Comment


            #20
            Great! i got it running, sorry for bothering

            Comment


              #21
              I'm glad to hear you got it working
              Unreal Tournament 4 eXpanded MultiPlayer (UT4XMP) efforts
              My website, listing all my Unreal series mods and mutators

              Comment


                #22
                @Sir_Brizz
                @GreatEmerald

                HI!
                I have a problem with compiling UT editor in the make step.
                I fix the UTGamestate.h/UTGameState.h issue making a duplicate of .h file with uppecase S
                But when i launch make command at making UnrealTournamentEditor i have this:

                Code:
                Assertion failed: HeaderDescriptor.GetSourceFile() == nullptr [File:Programs/UnrealHeaderTool/Private/UHTMakefile/UHTMakefile.h] [Line: 1082]  
                [Callstack]  00  0x00007fed5b928f7f  FLinuxPlatformStackWalk::CaptureStackBackTrace(unsigned long long*, unsigned int, void*)
                [Callstack]  01  0x00007fed5b82b295  FGenericPlatformStackWalk::StackWalkAndDump(char*, unsigned long, int, void*)
                [Callstack]  02  0x00007fed5b928e3b  FLinuxPlatformStackWalk::StackWalkAndDump(char*, unsigned long, int, void*)
                [Callstack]  03  0x00007fed5b92e0ba  FDebug::LogAssertFailedMessage(char const*, char const*, int, wchar_t const*, ...)
                [Callstack]  04  0x000000000055694f  FUHTMakefile::AddUnrealSourceFile(FUnrealSourceFile*) [Programs/UnrealHeaderTool/Private/UHTMakefile/UHTMakefile.h, line
                1082]
                [Callstack]  05  0x00000000004b1ae1  PreparseModules(FUHTMakefile&, FString const&, int&) [/opt4/ut4Ed/UnrealTournament/Engine/Source/Programs/UnrealHeaderToo
                l/Private/CodeGenerator.cpp, line 6314]
                [Callstack]  06  0x00000000004b3900  UnrealHeaderTool_Main(FString const&) [Runtime/Core/Public/Linux/LinuxPlatformTime.h, line 21]
                [Callstack]  07  0x0000000000516347  tchar_main(int, wchar_t**) [/opt4/ut4Ed/UnrealTournament/Engine/Source/Programs/UnrealHeaderTool/Private/UnrealHeaderTool
                Main.cpp, line 110]
                [Callstack]  08  0x0000000000515a65  main [/opt4/ut4Ed/UnrealTournament/Engine/Source/Programs/UnrealHeaderTool/Private/UnrealHeaderToolMain.cpp, line 45]
                [Callstack]  09  0x00007fed5a23ab97  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7fed5a23ab97]
                [Callstack]  10  0x000000000046a1fa  /opt4/ut4Ed/UnrealTournament/Engine/Source/../Binaries/Linux/UnrealHeaderTool(_start+0x2a) [0x46a1fa]
                
                Fatal error: [File:/opt4/ut4Ed/UnrealTournament/Engine/Source/Runtime/Core/Private/Linux/LinuxPlatformMisc.cpp] [Line: 454]  
                Error copying clipboard contents: Video subsystem must be initialized to set clipboard text
                
                [2019.12.19-12.58.44:763][  0]LogCompile: Preparsed module /
                Error: UnrealHeaderTool failed for target 'UnrealTournamentEditor' (platform: Linux, module info: /opt4/ut4Ed/UnrealTournament/UnrealTournament/Intermediate/B
                uild/Linux/B4D820EA/UnrealTournamentEditor/Development/UnrealTournamentEditor.uhtmanifest, exit code: Canceled (1)).
                Makefile:623: recipe for target 'UnrealTournamentEditor' failed
                make: *** [UnrealTournamentEditor] Error 1
                Repeated procedure "N" Times reloading git updates and all steps but i have this.
                Someone can help me please?
                Last edited by hormok; 12-19-2019, 09:15 AM.

                Comment

                Working...
                X