Announcement

Collapse
No announcement yet.

UT3 Detect GPU fix: (Add Device ID manually)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [TUTORIAL] UT3 Detect GPU fix: (Add Device ID manually)

    Title: UT3 Detect GPU fix: (Add Device ID manually)
    Author: TKBS
    Info: Dah fuq? is up with GPU score 4. 5 pls

    Click image for larger version  Name:	UT3-FIX-GPUID.jpg Views:	1 Size:	403.0 KB ID:	397215


    [01] Obtain Device ID:
    • Run UT3
    • Wait for it to full load
    • Exit Game
    • Open "Launch.log" here; "\Unreal Tournament 3\UTGame\Logs"
    • Grab DeviceID


    - Notice in the IMG i have" ut3.exe -log" running, so i can see the deviceID without actually having to open the log file. But Show'n'tell....

    [02] Add Device ID:
    • Add DeviceID to "UTCompat.ini" here; "\Unreal Tournament 3\UTGame\Config"


    Example:
    • DeviceID: 000013c2 becomes
    • 0x13C2=5,NVIDIA GeForce GTX 970
    • 5= for the higest setting, pointless doing this unless you set it to 5



    Click image for larger version  Name:	Untitled-2.jpg Views:	1 Size:	329.0 KB ID:	397216


    [03] Re-Do Config Files:
    • Users need to delete the Appcompat information for it to detect the changes
    • We might aswel add the CPU Stuff too..


    UTEngine.ini:

    [AppCompat]
    ;add for a line for the number of Processors you have
    ;DELETE ALL OTHER LINES

    CPUNumLogicalProcessors=8
    ;MeasuredCPUScore=1420.826782
    ;CompatLevelComposite=1
    ;CompatLevelCPU=1
    ;CompatLevelGPU=4

    [04] Re-boot UT3
    ... and your done.

    [xx] Combine the above with this below:
    • AllowD3D10=TRUE
    • AllowD3D10MSAA=True
    • and use DSR 4x Internal Resolution on your GPU settings
    • FSAA also works well with UT3

    I am sure how to get the CPU score up to 5, If someone can do the CPU and post it here that be appreciated im tired from fixing ut3


    I notice alot of complaints on steam about performance. Especially since around 2014+ and many comments with regards to the GS patch.
    I am not sure what is going here but after doing a clean install of UT3 and playing for about a week or 2 performance has decreased. I can see the difference because i am using my own Levels that i used to get 400fps and now im only getting 100
    - Stock maps give me 40fps average and they used to give me alot higher.
    - Something really is wrong with ut3, either the exe, new hardware/ new drivers, or something not sure what but the problem is real
    - also it is possible to stop the "enable fog volumes" button from auto enabling itself, but it doesn't do much.



    Anyway..
    Lame this is not included in the guide, not so ultimate after lol.
    Last edited by TKBS; 02-17-2018, 09:59 PM.
    Internet BlackOut in <2 weeks,last chance to request 4 years of Unreal Development(something from every Unreal Engine 50+ maps, chars, weapons, mods, mutators and more).

    #2
    Originally posted by TKBS View Post
    I notice alot of complaints on steam about performance. Especially since around 2014+ and many comments with regards to the GS patch.
    I am not sure what is going here but after doing a clean install of UT3 and playing for about a week or 2 performance has decreased. I can see the difference because i am using my own Levels that i used to get 400fps and now im only getting 100
    - Stock maps give me 40fps average and they used to give me alot higher.
    - Something really is wrong with ut3, either the exe, new hardware/ new drivers, or something not sure what but the problem is real
    Personally I continued got good performance through 2017 on modern cards (GTX 960, GTX 970, RX 480 and 580), then in late 2018 I started getting HORRIBLE (like 20 FPS) performance on my main rig (RX 580). I found this thread and based on others replies, it seemed AMD made some mistakes with their drivers in 2018 that tanked performance in UE3 and especially UT3. The OP on that thread heard from someone at AMD saying that the fix was found and tested, and would be released in a future driver update, but it never came, so after running into problems with some other UE3 games and also wanting a few more FPS in Borderlands 3, I picked up a GTX 1070.

    With the GTX 1070 I immediate was hitting 100-200+ framerates, but I was still getting dips as low as 60 in some areas of maps which really shouldn't have problems (i.e. Deck Pro2 which was optimized for performance). I tried lowering some settings (even though it really shouldn't be necessary) and it helped a little bit, but it was still dipping more than I wanted. Then I found your thread and followed the instructions to add my GPU to the compat list; this instantly gave me a boost and now 120 fps is my bottom floor most of the time.

    This is good enough for me, but still 10 year old games really shouldn't have this much trouble holding 144hz at 1080p on modern cards.

    Comment


      #3
      Glad it helped.

      It is also possible to completely remove the use of the "AppCompat.ini" file & "DefaultCompat.ini" lines, to run the game how it would run in editor (full spec)
      • Simply blank (comment) out the lines from the "DefaultCompat.ini" and and delete the "appcompat.ini";

      DefaultCompat.ini
      Code:
      ;
      ;[Configuration]
      ;BasedOn=..\Engine\Config\BaseCompat.ini
      ;
      EPIC
      You can effectively disable AppCompat by supplying an empty DefaultCompat.ini for your game (see example in UTGame), which causes it to initialize all buckets from [SystemSettings] in Engine.ini. In this case, the system operates exactly as it did before AppCompat was introduced.
      - This is useful for other Unreal Engine Based Games; Batman Arkham Asylum etc benefits from it greatly

      Links:
      Last edited by TKBS; 12-13-2019, 02:32 PM.
      Internet BlackOut in <2 weeks,last chance to request 4 years of Unreal Development(something from every Unreal Engine 50+ maps, chars, weapons, mods, mutators and more).

      Comment


        #4
        Originally posted by TKBS View Post
        Glad it helped.

        It is also possible to completely remove the use of the "AppCompat.ini" file & "DefaultCompat.ini" lines, to run the game how it would run in editor (full spec)
        • Simply blank (comment) out the lines from the "DefaultCompat.ini" and and delete the "appcompat.ini";

        DefaultCompat.ini
        Code:
        ;
        ;[Configuration]
        ;BasedOn=..\Engine\Config\BaseCompat.ini
        ;


        - This is useful for other Unreal Engine Based Games; Batman Arkham Asylum etc benefits from it greatly

        Links:
        The OP on that thread heard from someone at AMD saying that the fix was found and tested, and would be released in a future driver update, but it never came, so after running into problems with some other UE3 games and also wanting a few more FPS in Borderlands 3, I picked up a GTX 1070.

        With the GTX 1070 I immediate was hitting 100-200+ framerates, but I was still getting dips as low as 60 in some areas of maps which really shouldn't have problems (i.e. Deck Pro2 which was optimized for performance). I tried lowering some settings (even though it really shouldn't be necessary) and it helped a little bit, but it was still dipping more than I wanted. Then I found your thread and followed the instructions to add my GPU to the compat list; this instantly gave me a boost and now 120 fps is my bottom floor most of the time.

        Comment


          #5
          i have contacted the admin regarding this situation. for 2 reasons
          1) great if this posts helps peopl

          2) PEOPEL ARE NOT STUPID - NOONE WILL CLICK YOU PLANTED VIRAL LINKS - YOU WILL MOST LIKELY BE BANNED, or at least warned

          @admin:
           
          Spoiler
          Last edited by TKBS; 02-28-2020, 03:25 PM.
          Internet BlackOut in <2 weeks,last chance to request 4 years of Unreal Development(something from every Unreal Engine 50+ maps, chars, weapons, mods, mutators and more).

          Comment


            #6
            The OP on that thread heard from someone at AMD saying that the fix was found and tested, mygroundbiz and would be released in a future driver update, but it never came, so after running into problems with some other UE3 games and also wanting a few more FPS in Borderlands 3, I picked up a GTX 1070.

            With the GTX 1070 I immediate was hitting 100-200+ framerates, but I was still getting dips as low as 60 in some areas of maps which really shouldn't have problems (i.e. Deck Pro2 which was optimized for performance). I tried lowering some settings (even though it really shouldn't be necessary) and it helped a little bit, but it was still dipping more than I wanted. Then I found your thread and followed the instructions to add my GPU to the compat list; this instantly gave me a boost and now 120 fps is my bottom floor most of the time.

            Comment

            Working...
            X